summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-04 19:29:04 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-04 19:29:04 +0000
commitbe97f892adccfb9aa75ba921508dc635c21faf48 (patch)
tree93f2ffe0115ca425b6d6acae9cd9b0471cc8dc14 /app-backup/duplicity
parentVersion bump (bug #512358). (diff)
downloadgentoo-2-be97f892adccfb9aa75ba921508dc635c21faf48.tar.gz
gentoo-2-be97f892adccfb9aa75ba921508dc635c21faf48.tar.bz2
gentoo-2-be97f892adccfb9aa75ba921508dc635c21faf48.zip
Version bump (bug #511196).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/ChangeLog7
-rw-r--r--app-backup/duplicity/duplicity-0.6.24.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-backup/duplicity/ChangeLog b/app-backup/duplicity/ChangeLog
index 5ffe1bf09ab3..f284f6e80a4f 100644
--- a/app-backup/duplicity/ChangeLog
+++ b/app-backup/duplicity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/duplicity
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.95 2014/05/10 13:40:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.96 2014/06/04 19:29:04 radhermit Exp $
+
+*duplicity-0.6.24 (04 Jun 2014)
+
+ 04 Jun 2014; Tim Harder <radhermit@gentoo.org> +duplicity-0.6.24.ebuild:
+ Version bump (bug #511196).
10 May 2014; Agostino Sarubbo <ago@gentoo.org> duplicity-0.6.23-r1.ebuild:
Stable for ppc, wrt bug #508862
diff --git a/app-backup/duplicity/duplicity-0.6.24.ebuild b/app-backup/duplicity/duplicity-0.6.24.ebuild
new file mode 100644
index 000000000000..e3fa7c5afa47
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.24.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/duplicity-0.6.24.ebuild,v 1.1 2014/06/04 19:29:04 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3"
+
+DEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/lockfile
+"
+RDEPEND="${DEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die "Couldn't remove unnecessary COPYING file."
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}