summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-08-17 20:51:18 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-08-17 20:51:18 +0000
commitc577f9e38689af77f529e2a1469ddfac6a5f7379 (patch)
tree9f0678d8e12c52ebbb134a5bf25d5c31c81e448e /app-benchmarks/httperf/httperf-0.8.ebuild
parentNew vim7 snapshot, should fix the compile problems on some archs. (diff)
downloadgentoo-2-c577f9e38689af77f529e2a1469ddfac6a5f7379.tar.gz
gentoo-2-c577f9e38689af77f529e2a1469ddfac6a5f7379.tar.bz2
gentoo-2-c577f9e38689af77f529e2a1469ddfac6a5f7379.zip
Initial commit; ebuild by me.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-benchmarks/httperf/httperf-0.8.ebuild')
-rw-r--r--app-benchmarks/httperf/httperf-0.8.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-benchmarks/httperf/httperf-0.8.ebuild b/app-benchmarks/httperf/httperf-0.8.ebuild
new file mode 100644
index 000000000000..7b30738808d0
--- /dev/null
+++ b/app-benchmarks/httperf/httperf-0.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/httperf/httperf-0.8.ebuild,v 1.1 2005/08/17 20:51:18 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="A tool from HP for measuring web server performance."
+HOMEPAGE="http://www.hpl.hp.com/research/linux/httperf/index.php"
+SRC_URI="ftp://ftp.hpl.hp.com/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~mips ~sparc ~x86"
+IUSE="debug ssl"
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-optional-ssl.diff
+ epatch ${FILESDIR}/${P}-respect-DESTDIR.diff
+}
+
+src_compile() {
+ einfo "Regenerating configure"
+ autoconf || die "autoconf failed"
+
+ econf --bindir=/usr/bin \
+ $(use_enable debug) \
+ $(use_enable ssl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}