summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-01-26 21:43:51 +0000
committerAron Griffis <agriffis@gentoo.org>2002-01-26 21:43:51 +0000
commitc62d1427790a004fc983de1d5061a05dfd858694 (patch)
treea1ba7b12dad838bda045ff8ee9fccf740ff7928f /app-cdr/cddump
parentupdate-o (diff)
downloadgentoo-2-c62d1427790a004fc983de1d5061a05dfd858694.tar.gz
gentoo-2-c62d1427790a004fc983de1d5061a05dfd858694.tar.bz2
gentoo-2-c62d1427790a004fc983de1d5061a05dfd858694.zip
Added ebuild for cddump
Diffstat (limited to 'app-cdr/cddump')
-rw-r--r--app-cdr/cddump/cddump-0.7.ebuild42
-rw-r--r--app-cdr/cddump/files/digest-cddump-0.71
2 files changed, 43 insertions, 0 deletions
diff --git a/app-cdr/cddump/cddump-0.7.ebuild b/app-cdr/cddump/cddump-0.7.ebuild
new file mode 100644
index 000000000000..4961ac55c673
--- /dev/null
+++ b/app-cdr/cddump/cddump-0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Aron Griffis <agriffis@bigfoot.com>
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cddump/cddump-0.7.ebuild,v 1.1 2002/01/26 21:43:51 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="cddump - backup to CD-Recordable and CD-Rewritable"
+SRC_URI="http://www.joat.ca/software/${P}.tar.gz"
+HOMEPAGE="http://www.joat.ca/software/cddump.html"
+
+DEPEND="app-cdr/cdrtools
+ sys-devel/perl"
+
+src_compile() {
+ # These are appropriate defaults for my system (with an 8x
+ # writer). I don't know if these defaults will be appropriate for
+ # other systems.
+ ( echo /usr/bin/perl
+ echo /usr/bin/mkisofs
+ echo /usr/bin/cdrecord
+ echo /usr/bin/cpio
+ echo /dev/sg0
+ echo 8
+ echo .
+ echo y
+ ) | perl install.cddump
+}
+
+src_install() {
+ # Include the source in the documentation so that the user can be
+ # free to rerun the install.
+ dobin cddump
+ dodoc cddump.in CHANGELOG install.cddump LICENCE README TUTORIAL
+ doman cddump.8
+}
+
+pkg_postinst() {
+ echo
+ einfo "Cddump has been configured for an 8x writer at /dev/sg0."
+ einfo "To reconfigure, please run \"perl /usr/share/doc/${P}/cddump.in\""
+ echo
+}
diff --git a/app-cdr/cddump/files/digest-cddump-0.7 b/app-cdr/cddump/files/digest-cddump-0.7
new file mode 100644
index 000000000000..1665924e4838
--- /dev/null
+++ b/app-cdr/cddump/files/digest-cddump-0.7
@@ -0,0 +1 @@
+MD5 be1df6775272c01050c5779207bc0430 cddump-0.7.tar.gz 24576