summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-15 12:04:15 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-15 12:04:15 +0000
commitf444d7dc38f46ba0ee3e6db6e909cfa64ec0ecad (patch)
treeb3dd0099c933578168156735f860fefece380818 /app-cdr/k3b
parentMarking fetchmail-6.3.8-r2 ppc64 for bug 227105 (diff)
downloadgentoo-2-f444d7dc38f46ba0ee3e6db6e909cfa64ec0ecad.tar.gz
gentoo-2-f444d7dc38f46ba0ee3e6db6e909cfa64ec0ecad.tar.bz2
gentoo-2-f444d7dc38f46ba0ee3e6db6e909cfa64ec0ecad.zip
old, quoting
(Portage version: 2.1.5.5)
Diffstat (limited to 'app-cdr/k3b')
-rw-r--r--app-cdr/k3b/k3b-0.12.17.ebuild6
-rw-r--r--app-cdr/k3b/k3b-1.0.1-r1.ebuild153
-rw-r--r--app-cdr/k3b/k3b-1.0.1.ebuild149
-rw-r--r--app-cdr/k3b/k3b-1.0.2.ebuild146
-rw-r--r--app-cdr/k3b/k3b-1.0.3.ebuild4
-rw-r--r--app-cdr/k3b/k3b-1.0.ebuild151
6 files changed, 5 insertions, 604 deletions
diff --git a/app-cdr/k3b/k3b-0.12.17.ebuild b/app-cdr/k3b/k3b-0.12.17.ebuild
index 0ece7ef9fc06..c843a255ce0a 100644
--- a/app-cdr/k3b/k3b-0.12.17.ebuild
+++ b/app-cdr/k3b/k3b-0.12.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-0.12.17.ebuild,v 1.15 2008/01/01 23:51:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-0.12.17.ebuild,v 1.16 2008/06/15 12:04:15 drac Exp $
inherit kde eutils
@@ -124,9 +124,9 @@ src_install() {
# Move menu entry
if use kde; then
- mv ${D}/usr/share/applnk/Settings/System/k3bsetup2.desktop ${D}/usr/share/applications/kde/
+ mv "${D}"/usr/share/applnk/Settings/System/k3bsetup2.desktop "${D}"/usr/share/applications/kde/
fi
- rm -fR ${D}/usr/share/applnk/
+ rm -fR "${D}"/usr/share/applnk/
}
pkg_postinst() {
diff --git a/app-cdr/k3b/k3b-1.0.1-r1.ebuild b/app-cdr/k3b/k3b-1.0.1-r1.ebuild
deleted file mode 100644
index 418d54f68a2b..000000000000
--- a/app-cdr/k3b/k3b-1.0.1-r1.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.1-r1.ebuild,v 1.5 2008/01/01 23:51:31 aballier Exp $
-
-inherit kde eutils
-
-MY_P=${P/_/}
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="K3b, KDE CD Writing Software"
-HOMEPAGE="http://www.k3b.org/"
-SRC_URI="mirror://sourceforge/k3b/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa css dvdr dvdread encode ffmpeg flac hal kde mp3 musepack musicbrainz
- sndfile vcd vorbis emovix"
-
-DEPEND="kde? ( || ( kde-base/kdesu kde-base/kdebase ) )
- hal? ( dev-libs/dbus-qt3-old sys-apps/hal )
- media-libs/libsamplerate
- media-libs/taglib
- >=media-sound/cdparanoia-3.9.8
- sndfile? ( media-libs/libsndfile )
- ffmpeg? ( media-video/ffmpeg )
- flac? ( media-libs/flac )
- mp3? ( media-libs/libmad )
- musepack? ( media-libs/libmpcdec )
- vorbis? ( media-libs/libvorbis )
- musicbrainz? ( =media-libs/musicbrainz-2* )
- encode? ( media-sound/lame )
- alsa? ( media-libs/alsa-lib )
- dvdread? ( media-libs/libdvdread )"
-
-RDEPEND="${DEPEND}
- virtual/cdrtools
- >=app-cdr/cdrdao-1.1.7-r3
- media-sound/normalize
- dvdr? ( >=app-cdr/dvd+rw-tools-7.0 )
- css? ( media-libs/libdvdcss )
- encode? ( media-sound/sox
- media-video/transcode )
- vcd? ( media-video/vcdimager )
- emovix? ( media-video/emovix )"
-
-DEPEND="${DEPEND}
- dev-util/pkgconfig"
-
-need-kde 3.5
-
-# The following commented lines will have to be uncommented once the final
-# release is done. This pre-release version does not support i18n.
-I18N="${PN}-i18n-${PV}"
-
-# Supported languages and translated documentation
-LANGS="af ar bg br bs ca cs cy da de el en_GB es et eu fa fi fr ga gl he hi hu is it ja ka lt mk ms nb nds nl nn pa pl pt pt_BR ru rw se sk sr sr@Latn sv ta tr uk uz zh_CN zh_TW"
-for X in ${LANGS}; do
- SRC_URI="${SRC_URI} linguas_${X}? ( mirror://sourceforge/k3b/${I18N}.tar.bz2 )"
- IUSE="${IUSE} linguas_${X}"
-done
-
-pkg_setup() {
- if use hal && has_version '<sys-apps/dbus-0.91' && ! built_with_use sys-apps/dbus qt3; then
- eerror "You are trying to compile ${CATEGORY}/${PF} with the \"hal\" USE flag enabled,"
- eerror "but sys-apps/dbus is not built with Qt3 support."
- die "Please, rebuild sys-apps/dbus with the \"qt3\" USE flag."
- fi
- if use encode && ! built_with_use media-video/transcode dvdread; then
- eerror "You are trying to compile ${CATEGORY}/${PF} with the \"encode\""
- eerror "USE flag enabled, however media-video/transcode was not built"
- eerror "with libdvdread support. Also keep in mind that enabling"
- eerror "the dvdread USE flag will cause k3b to use libdvdread as well."
- die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
- fi
-
- if use flac && ! built_with_use --missing true media-libs/flac cxx; then
- eerror "To build ${PN} with flac support you need the C++ bindings for flac."
- eerror "Please enable the cxx USE flag for media-libs/flac"
- die "Missing FLAC C++ bindings."
- fi
-
- use kde || elog "You haven't set the kde use flag. k3bsetup won't be installed."
-
- kde_pkg_setup
-}
-
-src_unpack() {
- kde_src_unpack
-
- if [ -d "${WORKDIR}/${I18N}" ]; then
- cd "${WORKDIR}/${I18N}"
- for X in ${LANGS}; do
- use linguas_${X} || rm -rf "${X}"
- done
- rm -f configure
- fi
-
- cd "${S}"
- # Install k3b-iso.desktop, k3b-cue.desktop with NoDisplay=true.
- # Fixes bug 175263.
- epatch "${FILESDIR}/${P}-hidden.patch"
- rm -f "${S}/configure"
-}
-
-src_compile() {
- local myconf="--enable-libsuffix= \
- --with-external-libsamplerate \
- --without-resmgr \
- --without-cdrecord-suid-root \
- $(use_with kde k3bsetup) \
- $(use_with hal) \
- $(use_with encode lame) \
- $(use_with ffmpeg) \
- $(use_with flac) \
- $(use_with vorbis oggvorbis) \
- $(use_with sndfile) \
- $(use_with mp3 libmad) \
- $(use_with musepack) \
- $(use_with musicbrainz) \
- $(use_with alsa)"
-
- # Build process of K3b
- kde_src_compile
-
- # Build process of K3b-i18n
- if [ -d "${WORKDIR}/${I18N}" ]; then
- KDE_S="${WORKDIR}/${I18N}" \
- kde_src_compile
- fi
-}
-
-src_install() {
- kde_src_install
- dodoc FAQ KNOWNBUGS PERMISSIONS
-
- if [ -d "${WORKDIR}/${I18N}" ]; then
- KDE_S="${WORKDIR}/${I18N}" \
- kde_src_install
- fi
-}
-
-pkg_preinst() {
- kde_pkg_preinst
- use kde || rm ${D}/usr/share/applications/kde/k3bsetup2.desktop
-}
-
-pkg_postinst() {
- echo
- elog "Make sure you have proper read/write permissions on the cdrom device(s)."
- elog "Usually, it is sufficient to be in the cdrom group."
- echo
-}
diff --git a/app-cdr/k3b/k3b-1.0.1.ebuild b/app-cdr/k3b/k3b-1.0.1.ebuild
deleted file mode 100644
index 40ae3b995fcf..000000000000
--- a/app-cdr/k3b/k3b-1.0.1.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.1.ebuild,v 1.5 2008/01/01 23:51:30 aballier Exp $
-
-inherit kde eutils
-
-MY_P=${P/_/}
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="K3b, KDE CD Writing Software"
-HOMEPAGE="http://www.k3b.org/"
-SRC_URI="mirror://sourceforge/k3b/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa css dvdr dvdread encode ffmpeg flac hal kde mp3 musepack musicbrainz
- sndfile vcd vorbis emovix"
-
-DEPEND="kde? ( || ( kde-base/kdesu kde-base/kdebase ) )
- hal? ( dev-libs/dbus-qt3-old sys-apps/hal )
- media-libs/libsamplerate
- media-libs/taglib
- >=media-sound/cdparanoia-3.9.8
- sndfile? ( media-libs/libsndfile )
- ffmpeg? ( media-video/ffmpeg )
- flac? ( media-libs/flac )
- mp3? ( media-libs/libmad )
- musepack? ( media-libs/libmpcdec )
- vorbis? ( media-libs/libvorbis )
- musicbrainz? ( =media-libs/musicbrainz-2* )
- encode? ( media-sound/lame )
- alsa? ( media-libs/alsa-lib )
- dvdread? ( media-libs/libdvdread )"
-
-RDEPEND="${DEPEND}
- virtual/cdrtools
- >=app-cdr/cdrdao-1.1.7-r3
- media-sound/normalize
- dvdr? ( >=app-cdr/dvd+rw-tools-7.0 )
- css? ( media-libs/libdvdcss )
- encode? ( media-sound/sox
- media-video/transcode )
- vcd? ( media-video/vcdimager )
- emovix? ( media-video/emovix )"
-
-DEPEND="${DEPEND}
- dev-util/pkgconfig"
-
-need-kde 3.5
-
-# The following commented lines will have to be uncommented once the final
-# release is done. This pre-release version does not support i18n.
-I18N="${PN}-i18n-${PV}"
-
-# Supported languages and translated documentation
-LANGS="af ar bg br bs ca cs cy da de el en_GB es et eu fa fi fr ga gl he hi hu is it ja ka lt mk ms nb nds nl nn pa pl pt pt_BR ru rw se sk sr sr@Latn sv ta tr uk uz zh_CN zh_TW"
-for X in ${LANGS}; do
- SRC_URI="${SRC_URI} linguas_${X}? ( mirror://sourceforge/k3b/${I18N}.tar.bz2 )"
- IUSE="${IUSE} linguas_${X}"
-done
-
-pkg_setup() {
- if use hal && has_version '<sys-apps/dbus-0.91' && ! built_with_use sys-apps/dbus qt3; then
- eerror "You are trying to compile ${CATEGORY}/${PF} with the \"hal\" USE flag enabled,"
- eerror "but sys-apps/dbus is not built with Qt3 support."
- die "Please, rebuild sys-apps/dbus with the \"qt3\" USE flag."
- fi
- if use encode && ! built_with_use media-video/transcode dvdread; then
- eerror "You are trying to compile ${CATEGORY}/${PF} with the \"encode\""
- eerror "USE flag enabled, however media-video/transcode was not built"
- eerror "with libdvdread support. Also keep in mind that enabling"
- eerror "the dvdread USE flag will cause k3b to use libdvdread as well."
- die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
- fi
-
- if use flac && ! built_with_use --missing true media-libs/flac cxx; then
- eerror "To build ${PN} with flac support you need the C++ bindings for flac."
- eerror "Please enable the cxx USE flag for media-libs/flac"
- die "Missing FLAC C++ bindings."
- fi
-
- use kde || elog "You haven't set the kde use flag. k3bsetup won't be installed."
-
- kde_pkg_setup
-}
-
-src_unpack() {
- kde_src_unpack
-
- if [ -d "${WORKDIR}/${I18N}" ]; then
- cd "${WORKDIR}/${I18N}"
- for X in ${LANGS}; do
- use linguas_${X} || rm -rf "${X}"
- done
- rm -f configure
- fi
-
- rm -f "${S}/configure"
-}
-
-src_compile() {
- local myconf="--enable-libsuffix= \
- --with-external-libsamplerate \
- --without-resmgr \
- --without-cdrecord-suid-root \
- $(use_with kde k3bsetup) \
- $(use_with hal) \
- $(use_with encode lame) \
- $(use_with ffmpeg) \
- $(use_with flac) \
- $(use_with vorbis oggvorbis) \
- $(use_with sndfile) \
- $(use_with mp3 libmad) \
- $(use_with musepack) \
- $(use_with musicbrainz) \
- $(use_with alsa)"
-
- # Build process of K3b
- kde_src_compile
-
- # Build process of K3b-i18n
- if [ -d "${WORKDIR}/${I18N}" ]; then
- KDE_S="${WORKDIR}/${I18N}" \
- kde_src_compile
- fi
-}
-
-src_install() {
- kde_src_install
- dodoc FAQ KNOWNBUGS PERMISSIONS
-
- if [ -d "${WORKDIR}/${I18N}" ]; then
- KDE_S="${WORKDIR}/${I18N}" \
- kde_src_install
- fi
-}
-
-pkg_preinst() {
- kde_pkg_preinst
- use kde || rm ${D}/usr/share/applications/kde/k3bsetup2.desktop
-}
-
-pkg_postinst() {
- echo
- elog "Make sure you have proper read/write permissions on the cdrom device(s)."
- elog "Usually, it is sufficient to be in the cdrom group."
- echo
-}
diff --git a/app-cdr/k3b/k3b-1.0.2.ebuild b/app-cdr/k3b/k3b-1.0.2.ebuild
deleted file mode 100644
index 1ce2648c62c5..000000000000
--- a/app-cdr/k3b/k3b-1.0.2.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.2.ebuild,v 1.5 2008/01/01 23:51:31 aballier Exp $
-
-inherit kde eutils
-
-MY_P=${P/_/}
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="K3b, KDE CD Writing Software"
-HOMEPAGE="http://www.k3b.org/"
-SRC_URI="mirror://sourceforge/k3b/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa css dvdr dvdread encode ffmpeg flac hal kde mp3 musepack musicbrainz
- sndfile vcd vorbis emovix"
-
-DEPEND="kde? ( || ( kde-base/kdesu kde-base/kdebase ) )
- hal? ( dev-libs/dbus-qt3-old sys-apps/hal )
- media-libs/libsamplerate
- media-libs/taglib
- >=media-sound/cdparanoia-3.9.8
- sndfile? ( media-libs/libsndfile )
- ffmpeg? ( media-video/ffmpeg )
- flac? ( media-libs/flac )
- mp3? ( media-libs/libmad )
- musepack? ( media-libs/libmpcdec )
- vorbis? ( media-libs/libvorbis )
- musicbrainz? ( =media-libs/musicbrainz-2* )
- encode? ( media-sound/lame )
- alsa? ( media-libs/alsa-lib )
- dvdread? ( media-libs/libdvdread )"
-
-RDEPEND="${DEPEND}
- virtual/cdrtools
- >=app-cdr/cdrdao-1.1.7-r3
- media-sound/normalize
- dvdr? ( >=app-cdr/dvd+rw-tools-7.0 )
- css? ( media-libs/libdvdcss )
- encode? ( media-sound/sox
- media-video/transcode )
- vcd? ( media-video/vcdimager )
- emovix? ( media-video/emovix )"
-
-DEPEND="${DEPEND}
- dev-util/pkgconfig"
-
-need-kde 3.5
-
-I18N="${PN}-i18n-${PV}"
-
-# Supported languages and translated documentation
-LANGS="af ar bg br bs ca cs cy da de el en_GB es et eu fa fi fr ga gl he hi hu is it ja ka lt mk ms nb nds nl nn pa pl pt pt_BR ru rw se sk sr sr@Latn sv ta tr uk uz zh_CN zh_TW"
-for X in ${LANGS}; do
- SRC_URI="${SRC_URI} linguas_${X}? ( mirror://sourceforge/k3b/${I18N}.tar.bz2 )"
- IUSE="${IUSE} linguas_${X}"
-done
-
-pkg_setup() {
- if use hal && has_version '<sys-apps/dbus-0.91' && ! built_with_use sys-apps/dbus qt3; then
- eerror "You are trying to compile ${CATEGORY}/${PF} with the \"hal\" USE flag enabled,"
- eerror "but sys-apps/dbus is not built with Qt3 support."
- die "Please, rebuild sys-apps/dbus with the \"qt3\" USE flag."
- fi
- if use encode && ! built_with_use media-video/transcode dvdread; then
- eerror "You are trying to compile ${CATEGORY}/${PF} with the \"encode\""
- eerror "USE flag enabled, however media-video/transcode was not built"
- eerror "with libdvdread support. Also keep in mind that enabling"
- eerror "the dvdread USE flag will cause k3b to use libdvdread as well."
- die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
- fi
-
- if use flac && ! built_with_use --missing true media-libs/flac cxx; then
- eerror "To build ${PN} with flac support you need the C++ bindings for flac."
- eerror "Please enable the cxx USE flag for media-libs/flac"
- die "Missing FLAC C++ bindings."
- fi
-
- use kde || elog "You haven't set the kde use flag. k3bsetup won't be installed."
-
- kde_pkg_setup
-}
-
-src_unpack() {
- kde_src_unpack
-
- if [ -d "${WORKDIR}/${I18N}" ]; then
- cd "${WORKDIR}/${I18N}"
- for X in ${LANGS}; do
- use linguas_${X} || rm -rf "${X}"
- done
- rm -f configure
- fi
- rm -f "${S}/configure"
-}
-
-src_compile() {
- local myconf="--enable-libsuffix= \
- --with-external-libsamplerate \
- --without-resmgr \
- --without-cdrecord-suid-root \
- $(use_with kde k3bsetup) \
- $(use_with hal) \
- $(use_with encode lame) \
- $(use_with ffmpeg) \
- $(use_with flac) \
- $(use_with vorbis oggvorbis) \
- $(use_with sndfile) \
- $(use_with mp3 libmad) \
- $(use_with musepack) \
- $(use_with musicbrainz) \
- $(use_with alsa)"
-
- # Build process of K3b
- kde_src_compile
-
- # Build process of K3b-i18n
- if [ -d "${WORKDIR}/${I18N}" ]; then
- KDE_S="${WORKDIR}/${I18N}" \
- kde_src_compile
- fi
-}
-
-src_install() {
- kde_src_install
- dodoc FAQ KNOWNBUGS PERMISSIONS
-
- if [ -d "${WORKDIR}/${I18N}" ]; then
- KDE_S="${WORKDIR}/${I18N}" \
- kde_src_install
- fi
-}
-
-pkg_preinst() {
- kde_pkg_preinst
- use kde || rm ${D}/usr/share/applications/kde/k3bsetup2.desktop
-}
-
-pkg_postinst() {
- echo
- elog "Make sure you have proper read/write permissions on the cdrom device(s)."
- elog "Usually, it is sufficient to be in the cdrom group."
- echo
-}
diff --git a/app-cdr/k3b/k3b-1.0.3.ebuild b/app-cdr/k3b/k3b-1.0.3.ebuild
index ea37a526c27d..a23756de86e0 100644
--- a/app-cdr/k3b/k3b-1.0.3.ebuild
+++ b/app-cdr/k3b/k3b-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.3.ebuild,v 1.5 2008/01/01 23:51:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.3.ebuild,v 1.6 2008/06/15 12:04:15 drac Exp $
inherit kde eutils
@@ -135,7 +135,7 @@ src_install() {
pkg_preinst() {
kde_pkg_preinst
- use kde || rm ${D}/usr/share/applications/kde/k3bsetup2.desktop
+ use kde || rm "${D}"/usr/share/applications/kde/k3bsetup2.desktop
}
pkg_postinst() {
diff --git a/app-cdr/k3b/k3b-1.0.ebuild b/app-cdr/k3b/k3b-1.0.ebuild
deleted file mode 100644
index 372dea3ff0f7..000000000000
--- a/app-cdr/k3b/k3b-1.0.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-1.0.ebuild,v 1.9 2008/01/01 23:51:31 aballier Exp $
-
-inherit kde eutils
-
-MY_P=${P/_/}
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="K3b, KDE CD Writing Software"
-HOMEPAGE="http://www.k3b.org/"
-SRC_URI="mirror://sourceforge/k3b/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa css dvdr dvdread encode ffmpeg flac hal kde mp3 musepack musicbrainz
- sndfile vcd vorbis emovix"
-
-DEPEND="kde? ( || ( kde-base/kdesu kde-base/kdebase ) )
- hal? ( dev-libs/dbus-qt3-old sys-apps/hal )
- media-libs/libsamplerate
- media-libs/taglib
- >=media-sound/cdparanoia-3.9.8
- sndfile? ( media-libs/libsndfile )
- ffmpeg? ( media-video/ffmpeg )
- flac? ( media-libs/flac )
- mp3? ( media-libs/libmad )
- musepack? ( media-libs/libmpcdec )
- vorbis? ( media-libs/libvorbis )
- musicbrainz? ( =media-libs/musicbrainz-2* )
- encode? ( media-sound/lame )
- alsa? ( media-libs/alsa-lib )
- dvdread? ( media-libs/libdvdread )"
-
-RDEPEND="${DEPEND}
- virtual/cdrtools
- >=app-cdr/cdrdao-1.1.7-r3
- media-sound/normalize
- dvdr? ( >=app-cdr/dvd+rw-tools-7.0 )
- css? ( media-libs/libdvdcss )
- encode? ( media-sound/sox
- media-video/transcode )
- vcd? ( media-video/vcdimager )
- emovix? ( media-video/emovix )"
-
-DEPEND="${DEPEND}
- dev-util/pkgconfig"
-
-need-kde 3.5
-
-PATCHES="${FILESDIR}/${P}-alsa-fix.patch"
-
-# The following commented lines will have to be uncommented once the final
-# release is done. This pre-release version does not support i18n.
-I18N="${PN}-i18n-${PV}"
-
-# Supported languages and translated documentation
-LANGS="af ar bg br bs ca cs cy da de el en_GB es et eu fa fi fr ga gl he hi hu is it ja ka lt mk ms nb nds nl nn pa pl pt pt_BR ru rw se sk sr sr@Latn sv ta tr uk uz zh_CN zh_TW"
-for X in ${LANGS}; do
- SRC_URI="${SRC_URI} linguas_${X}? ( mirror://sourceforge/k3b/${I18N}.tar.bz2 )"
- IUSE="${IUSE} linguas_${X}"
-done
-
-pkg_setup() {
- if use hal && has_version '<sys-apps/dbus-0.91' && ! built_with_use sys-apps/dbus qt3; then
- eerror "You are trying to compile ${CATEGORY}/${PF} with the \"hal\" USE flag enabled,"
- eerror "but sys-apps/dbus is not built with Qt3 support."
- die "Please, rebuild sys-apps/dbus with the \"qt3\" USE flag."
- fi
- if use encode && ! built_with_use media-video/transcode dvdread; then
- eerror "You are trying to compile ${CATEGORY}/${PF} with the \"encode\""
- eerror "USE flag enabled, however media-video/transcode was not built"
- eerror "with libdvdread support. Also keep in mind that enabling"
- eerror "the dvdread USE flag will cause k3b to use libdvdread as well."
- die "Please, rebuild media-video/transcode with the \"dvdread\" USE flag."
- fi
-
- if use flac && ! built_with_use --missing true media-libs/flac cxx; then
- eerror "To build ${PN} with flac support you need the C++ bindings for flac."
- eerror "Please enable the cxx USE flag for media-libs/flac"
- die "Missing FLAC C++ bindings."
- fi
-
- use kde || elog "You haven't set the kde use flag. k3bsetup won't be installed."
-
- kde_pkg_setup
-}
-
-src_unpack() {
- kde_src_unpack
-
- if [ -d "${WORKDIR}/${I18N}" ]; then
- cd "${WORKDIR}/${I18N}"
- for X in ${LANGS}; do
- use linguas_${X} || rm -rf "${X}"
- done
- rm -f configure
- fi
-
- rm -f "${S}/configure"
-}
-
-src_compile() {
- local myconf="--enable-libsuffix= \
- --with-external-libsamplerate \
- --without-resmgr \
- $(use_with kde k3bsetup) \
- $(use_with hal) \
- $(use_with encode lame) \
- $(use_with ffmpeg) \
- $(use_with flac) \
- $(use_with vorbis oggvorbis) \
- $(use_with sndfile) \
- $(use_with mp3 libmad) \
- $(use_with musepack) \
- $(use_with musicbrainz) \
- $(use_with alsa)"
-
- # Build process of K3b
- kde_src_compile
-
- # Build process of K3b-i18n
- if [ -d "${WORKDIR}/${I18N}" ]; then
- KDE_S="${WORKDIR}/${I18N}" \
- kde_src_compile
- fi
-}
-
-src_install() {
- kde_src_install
- dodoc FAQ KNOWNBUGS PERMISSIONS
-
- if [ -d "${WORKDIR}/${I18N}" ]; then
- KDE_S="${WORKDIR}/${I18N}" \
- kde_src_install
- fi
-
- # Move menu entry
- if use kde; then
- mv ${D}/usr/share/applnk/Settings/System/k3bsetup2.desktop ${D}/usr/share/applications/kde/
- fi
- rm -fR ${D}/usr/share/applnk/
-}
-
-pkg_postinst() {
- echo
- elog "Make sure you have proper read/write permissions on the cdrom device(s)."
- elog "Usually, it is sufficient to be in the cdrom group."
- echo
-}