summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-07 19:11:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-07 19:11:57 +0000
commit9cda49bdfd61ea1d470b1cc034e6de1a6b73e71a (patch)
tree7518ee5b6a246577a54f3fa8d8e5435a65503188 /app-crypt/bcwipe
parentMasking net-misc/tkusr for removal, bug #247985 (diff)
downloadgentoo-2-9cda49bdfd61ea1d470b1cc034e6de1a6b73e71a.tar.gz
gentoo-2-9cda49bdfd61ea1d470b1cc034e6de1a6b73e71a.tar.bz2
gentoo-2-9cda49bdfd61ea1d470b1cc034e6de1a6b73e71a.zip
Version bump.
(Portage version: 14801-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/bcwipe')
-rw-r--r--app-crypt/bcwipe/ChangeLog8
-rw-r--r--app-crypt/bcwipe/bcwipe-1.9.3.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/app-crypt/bcwipe/ChangeLog b/app-crypt/bcwipe/ChangeLog
index acc994a7eb05..6ad889d2d518 100644
--- a/app-crypt/bcwipe/ChangeLog
+++ b/app-crypt/bcwipe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/bcwipe
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.38 2009/06/02 17:03:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.39 2009/11/07 19:11:57 arfrever Exp $
+
+*bcwipe-1.9.3 (07 Nov 2009)
+
+ 07 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +bcwipe-1.9.3.ebuild:
+ Version bump.
02 Jun 2009; Raúl Porcel <armin76@gentoo.org> bcwipe-1.9.1.ebuild:
sparc stable wrt #271910
diff --git a/app-crypt/bcwipe/bcwipe-1.9.3.ebuild b/app-crypt/bcwipe/bcwipe-1.9.3.ebuild
new file mode 100644
index 000000000000..e7785a1aa24d
--- /dev/null
+++ b/app-crypt/bcwipe/bcwipe-1.9.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.9.3.ebuild,v 1.1 2009/11/07 19:11:57 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+MY_PV="$(replace_version_separator 2 -)"
+
+DESCRIPTION="BCWipe secure file removal utility"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BCWipe-${MY_PV}.tar.gz
+ doc? ( http://www.jetico.com/linux/BCWipe.doc.tgz )"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.9.1-fix_warnings.patch"
+}
+
+src_test() {
+ echo "abc123" >> testfile
+ ./bcwipe -f testfile || die "bcwipe test failed"
+ [[ -f testfile ]] && die "test file still exists. bcwipe should have deleted it"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc ; then
+ dohtml -r ../bcwipe-help || die "dohtml failed"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn "full details /usr/share/doc/${PF}/html/bcwipe-help/wu_licen.htm"
+}