summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-12-26 18:03:23 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-12-26 18:03:23 +0000
commit2534de49ae476733f219ad207952b6b0f6824cc4 (patch)
treecfdf7743a97d404b34517ebca8a27fc9d0cacd71 /app-crypt/gnupg/gnupg-1.2.4.ebuild
parentMoved from x11-misc to x11-plugins (diff)
downloadgentoo-2-2534de49ae476733f219ad207952b6b0f6824cc4.tar.gz
gentoo-2-2534de49ae476733f219ad207952b6b0f6824cc4.tar.bz2
gentoo-2-2534de49ae476733f219ad207952b6b0f6824cc4.zip
version bump
Diffstat (limited to 'app-crypt/gnupg/gnupg-1.2.4.ebuild')
-rw-r--r--app-crypt/gnupg/gnupg-1.2.4.ebuild129
1 files changed, 129 insertions, 0 deletions
diff --git a/app-crypt/gnupg/gnupg-1.2.4.ebuild b/app-crypt/gnupg/gnupg-1.2.4.ebuild
new file mode 100644
index 000000000000..2bab5eb10f46
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.2.4.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.4.ebuild,v 1.1 2003/12/26 18:03:13 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2
+ idea? ( ftp://ftp.gnupg.dk/pub/contrib-dk/idea.c.gz )"
+SLOT="0"
+LICENSE="GPL-2 IDEA"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ia64"
+IUSE="X ldap nls static caps idea"
+
+RDEPEND="!static? ( ldap? ( net-nds/openldap )
+ caps? ( sys-libs/libcap )
+ app-arch/bzip2
+ sys-libs/zlib )
+ X? ( x11-misc/xloadimage )
+ nls? ( sys-devel/gettext )
+ virtual/glibc
+ dev-lang/perl
+ virtual/mta"
+
+# XXX: libpcap earlier than 1.10-r3 did not provide libcap.a
+# DEPEND="caps? ( static? ( >=sys-libs/libcap-1.10-r3 )
+# !static? ( sys-libs/libcap ) )
+DEPEND="caps? ( sys-libs/libcap )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ !static? ( sys-libs/zlib )
+ app-arch/bzip2
+ virtual/glibc
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+
+ # Please read http://www.gnupg.org/why-not-idea.html
+ if use idea; then
+ mv ${WORKDIR}/idea.c ${S}/cipher/idea.c || ewarn "failed to insert IDEA module"
+ fi
+}
+
+src_compile() {
+ # support for external HKP keyservers requested in #16457.
+ local myconf="--enable-external-hkp --enable-static-rnd=linux --libexecdir=/usr/lib --enable-sha512"
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if use ldap; then
+ myconf="${myconf} --enable-ldap"
+ else
+ myconf="${myconf} --disable-ldap"
+ fi
+
+ if use X; then
+ myconf="${myconf} --enable-photo-viewers"
+ else
+ myconf="${myconf} --disable-photo-viewers"
+ fi
+
+ # `USE=static` support was requested in #29299
+ if use static; then
+ myconf="${myconf} --with-included-zlib"
+ export LDFLAGS="${LDFLAGS} -static"
+ else
+ myconf="${myconf} --without-included-zlib"
+ fi
+
+ if use caps; then
+ myconf="${myconf} --with-capabilities"
+ fi
+
+ # Still needed?
+ # Bug #6387, --enable-m-guard causes bus error on sparcs
+ if ! use sparc; then
+ myconf="${myconf} --enable-m-guard"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall libexecdir="${D}/usr/lib/gnupg"
+
+ # keep the documentation in /usr/share/doc/...
+ rm -rf "${D}/usr/share/gnupg/FAQ" "${D}/usr/share/gnupg/faq.html"
+
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS \
+ README THANKS TODO VERSION doc/{FAQ,HACKING,DETAILS,ChangeLog,OpenPGP,faq.raw}
+
+ docinto sgml
+ dodoc doc/*.sgml
+
+ dohtml doc/faq.html
+
+ if ! use caps; then
+ chmod u+s "${D}/usr/bin/gpg"
+ fi
+}
+
+pkg_postinst() {
+ if ! use caps; then
+ einfo "gpg is installed suid root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your"
+ einfo "passphrases, etc. at runtime but may make some sysadmins nervous."
+ fi
+ echo
+ if use idea; then
+ einfo "you have compiled gnupg with support for the IDEA algorithm, this code"
+ einfo "is distributed under the GPL in countries where it is permitted to do so"
+ einfo "by law."
+ einfo "Please read http://www.gnupg.org/why-not-idea.html for more information."
+ einfo
+ einfo "If you are in a country where the IDEA algorithm is patented, you are permitted"
+ einfo "to use it freely (FAIB) for non revenue generating data transfer between private"
+ einfo "individuals only."
+ einfo
+ einfo "Special conditions are applicable to European research projects, who may also be"
+ einfo "permitted FAIB use within the scope of their project."
+ einfo
+ einfo "Other licenses and further information is availble from http://www.mediacrypt.com"
+ fi
+}