summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ Robert Ray <jrray@gentoo.org>2003-01-30 06:56:06 +0000
committerJ Robert Ray <jrray@gentoo.org>2003-01-30 06:56:06 +0000
commit19a371de5d7c8eea31d27a6727d9a3dcdbbc6762 (patch)
tree38fbb8a0f451b65a31813893ad308dde52757375 /app-crypt/gpgme/gpgme-0.3.14.ebuild
parentAlso install header files. (diff)
downloadgentoo-2-19a371de5d7c8eea31d27a6727d9a3dcdbbc6762.tar.gz
gentoo-2-19a371de5d7c8eea31d27a6727d9a3dcdbbc6762.tar.bz2
gentoo-2-19a371de5d7c8eea31d27a6727d9a3dcdbbc6762.zip
adding/unmasking 0.3.14 and adding 0.4.0 ebuilds
Diffstat (limited to 'app-crypt/gpgme/gpgme-0.3.14.ebuild')
-rw-r--r--app-crypt/gpgme/gpgme-0.3.14.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/gpgme/gpgme-0.3.14.ebuild b/app-crypt/gpgme/gpgme-0.3.14.ebuild
new file mode 100644
index 000000000000..158c3f7ee2f0
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-0.3.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-0.3.14.ebuild,v 1.1 2003/01/30 06:56:06 jrray Exp $
+
+DESCRIPTION="GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications."
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gpgme/${P}.tar.gz"
+HOMEPAGE="http://www.gnupg.org/gpgme.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc "
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ >=app-crypt/gnupg-1.0.7"
+# crypt? ( app-crypt/gpgsm )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls \
+ || myconf="--disable-nls"
+ use crypt \
+ && myconf="${myconf} --enable-gpgmeplug"
+ use doc \
+ && myconf="${myconf} --enable-maintainer-mode"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README README-alpha THANKS TODO VERSION
+}