summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-06-08 14:15:45 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-06-08 14:15:45 +0000
commite3c84a032ec8298ff54d4667bdce725472034409 (patch)
treecdc289811e8fac14d061288381acf46fde29e9df /app-crypt/gpgme/gpgme-1.0.1.ebuild
parentNew upstream version, fixes #95183. (diff)
downloadgentoo-2-e3c84a032ec8298ff54d4667bdce725472034409.tar.gz
gentoo-2-e3c84a032ec8298ff54d4667bdce725472034409.tar.bz2
gentoo-2-e3c84a032ec8298ff54d4667bdce725472034409.zip
added dropped mips keyword. old version cleanout
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-crypt/gpgme/gpgme-1.0.1.ebuild')
-rw-r--r--app-crypt/gpgme/gpgme-1.0.1.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/app-crypt/gpgme/gpgme-1.0.1.ebuild b/app-crypt/gpgme/gpgme-1.0.1.ebuild
deleted file mode 100644
index 620b07b74bae..000000000000
--- a/app-crypt/gpgme/gpgme-1.0.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.0.1.ebuild,v 1.4 2005/01/02 11:20:37 corsair Exp $
-
-inherit eutils
-
-DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
-HOMEPAGE="http://www.gnupg.org/(en)/related_software/gpgme/index.html"
-SRC_URI="ftp://ftp.gnupg.org/gcrypt/gpgme/${P}.tar.gz"
-
-#SRC_URI="mirror://gnu/gcrypt/gpgme/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~ppc64"
-IUSE=""
-#IUSE="smime"
-
-DEPEND=">=app-crypt/gnupg-1.2.2
- sys-apps/gawk
- sys-devel/libtool
- sys-devel/gcc
- >=dev-libs/libgpg-error-0.5
- !ia64? ( dev-libs/pth )"
-
-# For when gnupg-1.9+ gets unmasked
-# !smime? ( >=app-crypt/gnupg-1.2.2 )
-# smime? ( >=app-crypt/gnupg-1.9.6 )
-
-RDEPEND="virtual/libc
- >=dev-libs/libgpg-error-0.5
- dev-libs/libgcrypt
- >=app-crypt/gnupg-1.2.2
- !ia64? ( dev-libs/pth )"
-
-src_compile() {
-
- WANT_AUTOCONF=2.57
- autoconf || die "failed to autoconfigure"
-
- if [ -x /usr/bin/gpg2 ]; then
- GPGBIN=/usr/bin/gpg2
- else
- GPGBIN=/usr/bin/gpg
- fi
-
- # For when gnupg-1.9+ gets unmasked
- # $(use_with smime gpgsm /usr/bin/gpgsm) \
-
- econf \
- --includedir=/usr/include/gpgme \
- --with-gpg=$GPGBIN \
- --with-pth=yes \
- --disable-test \
- || die "econf failed"
- emake CFLAGS="${CFLAGS} -I../assuan/" || die
-}
-
-src_test() {
- einfo "testing currently broken - bypassing"
-}
-
-src_install() {
- emake DESTDIR=${D} install || die
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO VERSION
-}