summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-04-20 21:58:55 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-04-20 21:58:55 +0000
commit50f4fa83f59ce35891938dea9b41040e17d93be8 (patch)
treefe454f492a8c95a4e407d78b19bab42a001c3592 /app-crypt/gringotts
parentRun eautoreconf in src_unpack phase, bug #207489. (diff)
downloadgentoo-2-50f4fa83f59ce35891938dea9b41040e17d93be8.tar.gz
gentoo-2-50f4fa83f59ce35891938dea9b41040e17d93be8.tar.bz2
gentoo-2-50f4fa83f59ce35891938dea9b41040e17d93be8.zip
bump to 1.2.9, fix bug #151020.
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'app-crypt/gringotts')
-rw-r--r--app-crypt/gringotts/ChangeLog10
-rw-r--r--app-crypt/gringotts/gringotts-1.2.9.ebuild77
2 files changed, 85 insertions, 2 deletions
diff --git a/app-crypt/gringotts/ChangeLog b/app-crypt/gringotts/ChangeLog
index 91c3e1a2af6e..f1ff37b899ae 100644
--- a/app-crypt/gringotts/ChangeLog
+++ b/app-crypt/gringotts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/gringotts
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/ChangeLog,v 1.26 2007/01/05 07:56:49 compnerd Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/ChangeLog,v 1.27 2008/04/20 21:58:55 eva Exp $
+
+*gringotts-1.2.9 (20 Apr 2008)
+
+ 20 Apr 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gringotts-1.2.9.ebuild:
+ bump to 1.2.9, fix bug #151020.
*gringotts-1.2.8-r2 (05 Jan 2007)
diff --git a/app-crypt/gringotts/gringotts-1.2.9.ebuild b/app-crypt/gringotts/gringotts-1.2.9.ebuild
new file mode 100644
index 000000000000..e450ea6b1bf2
--- /dev/null
+++ b/app-crypt/gringotts/gringotts-1.2.9.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-1.2.9.ebuild,v 1.1 2008/04/20 21:58:55 eva Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit autotools eutils fdo-mime flag-o-matic
+
+DESCRIPTION="Utility that allows you to jot down sensitive data"
+HOMEPAGE="http://gringotts.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="suid"
+
+RDEPEND=">=dev-libs/libgringotts-1.2
+ >=x11-libs/gtk+-2.12
+ dev-libs/popt"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Remove deprecation flag, soit compiles with >=GTK+-2.4
+ sed -i -e 's:-DGTK_DISABLE_DEPRECATED::g' src/Makefile.am
+
+ # Patch up to install desktop entry correctly
+ epatch "${FILESDIR}/${PN}-1.2.8-desktop.patch"
+ epatch "${FILESDIR}/${PN}-1.2.8-desktop-entry.patch"
+
+ # Prevent prestripping
+ epatch "${FILESDIR}/${PN}-1.2.8-no-strip.patch"
+
+ eautomake
+}
+
+src_compile() {
+ append-ldflags $(bindnow-flags)
+
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+
+ # The FAQ and README documents shouldn't be gzip'd, as they need to be
+ # available in plain format when they are called from the `Help' menu.
+ #
+ # dodoc FAQ README
+ dodoc AUTHORS BUGS ChangeLog TODO
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ if use suid; then
+ ewarn "You have installed a suid binary for the \`gringotts' program."
+ ewarn "Be aware that this setup may break with some glibc installations"
+ ewarn "For more information, see bug #69458 in Gentoo's bugzilla at:"
+ ewarn " http://bugs.gentoo.org/"
+ else
+ einfo "Changing permissions for the gringotts binary."
+ chmod u-s "${ROOT}"/usr/bin/gringotts
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}