summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-02-20 18:16:10 +0000
committerEray Aslan <eras@gentoo.org>2011-02-20 18:16:10 +0000
commit6bab1216315215506b9db7c10121f2e45d4b9cac (patch)
tree3a117bbf958fef7f0c463c38863a044608fb825d /app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild
parentFix building with libpng-1.5, convert to EAPI=2, disable unneeded configure w... (diff)
downloadgentoo-2-6bab1216315215506b9db7c10121f2e45d4b9cac.tar.gz
gentoo-2-6bab1216315215506b9db7c10121f2e45d4b9cac.tar.bz2
gentoo-2-6bab1216315215506b9db7c10121f2e45d4b9cac.zip
Correct -berkdb option to configure script. Thanks to Jan Psota. Remove old.
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild')
-rw-r--r--app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild b/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild
index 2436c9b613b2..9d866cfd377c 100644
--- a/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild
+++ b/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild,v 1.1 2011/02/20 10:22:40 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-1.4.1_pre20110216-r1.ebuild,v 1.2 2011/02/20 18:16:10 eras Exp $
EAPI=2
# PYTHON_BDEPEND="2"
@@ -51,6 +51,12 @@ src_prepare() {
}
src_configure() {
+ local myconf=""
+ if use berkdb; then
+ myconf="--with-berkeley-db --with-berkeley-db-include=$(db_includedir)"
+ else
+ myconf="--without-berkeley-db"
+ fi
econf \
--enable-kcm \
--disable-osfc2 \
@@ -64,13 +70,12 @@ src_configure() {
$(use_enable pkinit kx509) \
$(use_enable pkinit pk-init) \
$(use_enable threads pthread-support) \
- $(use_with berkdb berkeley-db) \
- $(use_with berkdb berkeley-db-include=$(db_includedir)) \
$(use_with caps capng) \
$(use_with hdb-ldap openldap /usr) \
$(use_with ipv6) \
$(use_with ssl openssl /usr) \
- $(use_with X x)
+ $(use_with X x) \
+ ${myconf}
}
src_compile() {