summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2005-04-21 01:46:27 +0000
committerKito Danya Dietrich <kito@gentoo.org>2005-04-21 01:46:27 +0000
commit666294e41a0502f93f6a82472ededd1b09f8b297 (patch)
treead2f5c99a2056ccf65c9238577bec0d3c232e3b8 /app-crypt/md5deep/md5deep-1.5-r1.ebuild
parentAdded ~sparc keyword wrt bug #88697. (diff)
downloadgentoo-2-666294e41a0502f93f6a82472ededd1b09f8b297.tar.gz
gentoo-2-666294e41a0502f93f6a82472ededd1b09f8b297.tar.bz2
gentoo-2-666294e41a0502f93f6a82472ededd1b09f8b297.zip
add conditional build target for darwin support, missing sh256deep binary and manpage fixed.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-crypt/md5deep/md5deep-1.5-r1.ebuild')
-rw-r--r--app-crypt/md5deep/md5deep-1.5-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-crypt/md5deep/md5deep-1.5-r1.ebuild b/app-crypt/md5deep/md5deep-1.5-r1.ebuild
new file mode 100644
index 000000000000..3897dcabc137
--- /dev/null
+++ b/app-crypt/md5deep/md5deep-1.5-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/md5deep/md5deep-1.5-r1.ebuild,v 1.1 2005/04/21 01:46:27 kito Exp $
+
+DESCRIPTION="Expanded md5sum program that has recursive and comparison options. Also includes SHA hash generation."
+HOMEPAGE="http://md5deep.sourceforge.net"
+SRC_URI="mirror://sourceforge/md5deep/${P}.tar.gz"
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~ppc-macos"
+IUSE=""
+DEPEND=""
+
+src_compile () {
+ BUILDTARGET="linux"
+ use ppc-macos && BUILDTARGET="mac"
+ make CFLAGS="${CFLAGS}" ${BUILDTARGET} || die
+}
+
+src_install() {
+ dobin md5deep sha1deep sha256deep
+ dodoc README CHANGES
+ doman md5deep.1 sha1deep.1 sha256deep.1
+}