summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-15 17:39:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-15 17:39:40 +0000
commit23a49ce5eb81a95c6290e0904263f94a5a8a2bb6 (patch)
treeee2c6ddbfda5f4cec3eb7bb1f2bdfec8c7d350c6 /app-crypt/scl011-bin
parentAdd SCM-MICRO license to the EULA group. (diff)
downloadgentoo-2-23a49ce5eb81a95c6290e0904263f94a5a8a2bb6.tar.gz
gentoo-2-23a49ce5eb81a95c6290e0904263f94a5a8a2bb6.tar.bz2
gentoo-2-23a49ce5eb81a95c6290e0904263f94a5a8a2bb6.zip
Import of SCM Micro scl011-bin driver, ebuild proxy-maintained by Christoph Brill in bug #358119.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/scl011-bin')
-rw-r--r--app-crypt/scl011-bin/ChangeLog11
-rw-r--r--app-crypt/scl011-bin/files/92_pcscd_scl011-bin.rules10
-rw-r--r--app-crypt/scl011-bin/metadata.xml13
-rw-r--r--app-crypt/scl011-bin/scl011-bin-2.06.ebuild42
4 files changed, 76 insertions, 0 deletions
diff --git a/app-crypt/scl011-bin/ChangeLog b/app-crypt/scl011-bin/ChangeLog
new file mode 100644
index 000000000000..1f3d69fcea4a
--- /dev/null
+++ b/app-crypt/scl011-bin/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-crypt/scl011-bin
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/scl011-bin/ChangeLog,v 1.1 2011/04/15 17:39:40 flameeyes Exp $
+
+*scl011-bin-2.06 (15 Apr 2011)
+
+ 15 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/92_pcscd_scl011-bin.rules, +scl011-bin-2.06.ebuild, +metadata.xml:
+ Import of SCM Micro scl011-bin driver, ebuild proxy-maintained by Christoph
+ Brill in bug #358119.
+
diff --git a/app-crypt/scl011-bin/files/92_pcscd_scl011-bin.rules b/app-crypt/scl011-bin/files/92_pcscd_scl011-bin.rules
new file mode 100644
index 000000000000..dda4dc2afdbf
--- /dev/null
+++ b/app-crypt/scl011-bin/files/92_pcscd_scl011-bin.rules
@@ -0,0 +1,10 @@
+# If not adding the device, go away
+ACTION!="add", GOTO="pcscd_scl011-bin_rules_end"
+SUBSYSTEM!="usb", GOTO="pcscd_scl011-bin_rules_end"
+ENV{DEVTYPE}!="usb_device", GOTO="pcscd_scl011-bin_rules_end"
+
+# Tested on scl011
+ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="5292", ENV{PCSCD}="1"
+
+# All done
+LABEL="pcscd_scl011-bin_rules_end"
diff --git a/app-crypt/scl011-bin/metadata.xml b/app-crypt/scl011-bin/metadata.xml
new file mode 100644
index 000000000000..638c694b00fa
--- /dev/null
+++ b/app-crypt/scl011-bin/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <maintainer>
+ <email>egore@gmx.de</email>
+ <description>Proxied maintainer, assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ <description>Proxy-maintainer, CC him on bugs</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-crypt/scl011-bin/scl011-bin-2.06.ebuild b/app-crypt/scl011-bin/scl011-bin-2.06.ebuild
new file mode 100644
index 000000000000..9a8dcf2131c4
--- /dev/null
+++ b/app-crypt/scl011-bin/scl011-bin-2.06.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/scl011-bin/scl011-bin-2.06.ebuild,v 1.1 2011/04/15 17:39:40 flameeyes Exp $
+
+EAPI=4
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="pcsc-lite driver for the German identification card (nPA)"
+HOMEPAGE="http://www.scmmicro.com/de/products-services/chipkartenleser-terminals/kontaktlos-dual-interface/it-sicherheitskit-basisleser/treiber.html"
+SRC_URI="x86? ( http://www.scmmicro.com/npa/files/scl011_${PV}_linux_32bit.tar.gz )
+ amd64? ( http://www.scmmicro.com/npa/files/scl011_${PV}_linux_64bit.tar.gz )"
+
+LICENSE="SCM-MICRO"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}"
+
+RESTRICT="mirror bindist"
+
+src_install() {
+ local INSTALL_DIR=`$(tc-getPKG_CONFIG) libpcsclite --variable=usbdropdir`
+ local BASEPATH
+ case $(tc-arch) in
+ amd64) BASEPATH="${S}/scl011_${PV}_linux_64bit" ;;
+ x86) BASEPATH="${S}/scl011_${PV}_linux_32bit" ;;
+ esac
+
+ insinto "${INSTALL_DIR}"/SCL011.bundle/Contents
+ doins "${BASEPATH}"/proprietary/SCL011.bundle/Contents/Info.plist
+ exeinto "${INSTALL_DIR}"/SCL011.bundle/Contents/Linux
+ doexe "${BASEPATH}"/proprietary/SCL011.bundle/Contents/Linux/libSCL011.so.${PV}
+
+ insinto /$(get_libdir)/udev/rules.d
+ doins "${FILESDIR}"/92_pcscd_scl011-bin.rules
+}