summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-03-21 17:24:54 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-03-21 17:24:54 +0000
commit10d1ffe079d5b1110da382eb9264444b9f9d33a9 (patch)
treee85675bf304791d9a2ba89a79f05099b7e7040cb /app-crypt/truecrypt/files
parentFix up regex dependency handling - system pcre is never needed with the glib ... (diff)
downloadgentoo-2-10d1ffe079d5b1110da382eb9264444b9f9d33a9.tar.gz
gentoo-2-10d1ffe079d5b1110da382eb9264444b9f9d33a9.tar.bz2
gentoo-2-10d1ffe079d5b1110da382eb9264444b9f9d33a9.zip
Version bump, bug#213846
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-crypt/truecrypt/files')
-rw-r--r--app-crypt/truecrypt/files/truecrypt-5.0-64bit.patch110
-rw-r--r--app-crypt/truecrypt/files/truecrypt-5.0-build.patch28
-rw-r--r--app-crypt/truecrypt/files/truecrypt-5.0-nogui.patch347
-rw-r--r--app-crypt/truecrypt/files/truecrypt-5.1-nogui.patch351
-rw-r--r--app-crypt/truecrypt/files/truecrypt-5.1a-external-wx.patch33
5 files changed, 33 insertions, 836 deletions
diff --git a/app-crypt/truecrypt/files/truecrypt-5.0-64bit.patch b/app-crypt/truecrypt/files/truecrypt-5.0-64bit.patch
deleted file mode 100644
index 3c69844cf7b5..000000000000
--- a/app-crypt/truecrypt/files/truecrypt-5.0-64bit.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-diff -urNP truecrypt-5.0-source.org/Platform/StringConverter.cpp truecrypt-5.0-source/Platform/StringConverter.cpp
---- truecrypt-5.0-source.org/Platform/StringConverter.cpp 2008-02-04 13:14:18.000000000 +0200
-+++ truecrypt-5.0-source/Platform/StringConverter.cpp 2008-02-09 21:38:23.000000000 +0200
-@@ -32,12 +32,14 @@
- return s.str();
- }
-
-+#if __WORDSIZE == 32
- wstring StringConverter::FromNumber (int64 number)
- {
- wstringstream s;
- s << number;
- return s.str();
- }
-+#endif
-
- wstring StringConverter::FromNumber (int number)
- {
-@@ -60,12 +62,14 @@
- return s.str();
- }
-
-+#if __WORDSIZE == 32
- wstring StringConverter::FromNumber (uint64 number)
- {
- wstringstream s;
- s << number;
- return s.str();
- }
-+#endif
-
- string StringConverter::GetTrailingNumber (const string &str)
- {
-diff -urNP truecrypt-5.0-source.org/Platform/StringConverter.h truecrypt-5.0-source/Platform/StringConverter.h
---- truecrypt-5.0-source.org/Platform/StringConverter.h 2008-02-04 13:14:16.000000000 +0200
-+++ truecrypt-5.0-source/Platform/StringConverter.h 2008-02-09 21:38:03.000000000 +0200
-@@ -19,11 +19,15 @@
- public:
- static wstring FromNumber (double number);
- static wstring FromNumber (int number);
-+#if __WORDSIZE == 32
- static wstring FromNumber (int64 number);
-+#endif
- static wstring FromNumber (long number);
- static wstring FromNumber (unsigned int number);
- static wstring FromNumber (unsigned long number);
-+#if __WORDSIZE == 32
- static wstring FromNumber (uint64 number);
-+#endif
- static string GetTrailingNumber (const string &str);
- static string GetTypeName (const type_info &typeInfo);
- static wstring QuoteSpaces (const wstring &str);
---- truecrypt-5.0-source.org/Platform/PlatformTest.cpp 2008-02-04 13:14:16.000000000 +0200
-+++ truecrypt-5.0-source/Platform/PlatformTest.cpp 2008-02-09 21:49:15.000000000 +0200
-@@ -270,7 +270,11 @@ namespace TrueCrypt
- // shared_ptr, make_shared, StringConverter, foreach
- list <shared_ptr <uint64> > numList;
-
-+#if __WORDSIZE == 32
- numList.push_front (make_shared <uint64> (StringConverter::ToUInt64 (StringConverter::FromNumber (0xFFFFffffFFFFfffeULL))));
-+#else
-+ numList.push_front (make_shared <uint64> (StringConverter::ToUInt64 (StringConverter::FromNumber (0xFFFFffffFFFFfffeUL))));
-+#endif
- numList.push_front (make_shared <uint64> (StringConverter::ToUInt32 (StringConverter::GetTrailingNumber ("str2"))));
- numList.push_front (make_shared <uint64> (3));
-
---- truecrypt-5.0-source.org/Main/StringFormatter.h 2008-02-04 13:14:14.000000000 +0200
-+++ truecrypt-5.0-source/Main/StringFormatter.h 2008-02-09 22:15:04.000000000 +0200
-@@ -27,11 +27,15 @@ namespace TrueCrypt
- StringFormatterArg (const wstring &str) : Empty (false), Referenced (false), StringArg (str) { }
- StringFormatterArg (const wxString &str) : Empty (false), Referenced (false), StringArg (str) { }
- StringFormatterArg (int number) : Empty (false), Referenced (false), StringArg (StringConverter::FromNumber (number)) { }
-+#if __WORDSIZE == 32
- StringFormatterArg (int64 number) : Empty (false), Referenced (false), StringArg (StringConverter::FromNumber (number)) { }
-+#endif
- StringFormatterArg (long number) : Empty (false), Referenced (false), StringArg (StringConverter::FromNumber (number)) { }
- StringFormatterArg (unsigned int number) : Empty (false), Referenced (false), StringArg (StringConverter::FromNumber (number)) { }
- StringFormatterArg (unsigned long number) : Empty (false), Referenced (false), StringArg (StringConverter::FromNumber (number)) { }
-+#if __WORDSIZE == 32
- StringFormatterArg (uint64 number) : Empty (false), Referenced (false), StringArg (StringConverter::FromNumber (number)) { }
-+#endif
-
- operator wxString () { Referenced = true; return StringArg; }
-
---- truecrypt-5.0-source.org/Main/Forms/VolumeSizeWizardPage.cpp 2008-02-04 13:14:46.000000000 +0200
-+++ truecrypt-5.0-source/Main/Forms/VolumeSizeWizardPage.cpp 2008-02-09 22:27:35.000000000 +0200
-@@ -55,7 +55,7 @@ namespace TrueCrypt
- {
- uint64 prefixMult = 1;
- if (VolumeSizePrefixChoice->GetSelection() != wxNOT_FOUND)
-- prefixMult = reinterpret_cast <int> (VolumeSizePrefixChoice->GetClientData (VolumeSizePrefixChoice->GetSelection()));
-+ prefixMult = reinterpret_cast <uint64> (VolumeSizePrefixChoice->GetClientData (VolumeSizePrefixChoice->GetSelection()));
-
- uint64 val = StringConverter::ToUInt64 (wstring (VolumeSizeTextCtrl->GetValue()));
- if (val <= 0x7fffFFFFffffFFFFull / prefixMult)
---- truecrypt-5.0a-source.org/Makefile 2008-02-04 20:19:02.000000000 +0200
-+++ truecrypt-5.0a-source/Makefile 2008-02-13 19:47:58.000000000 +0200
-@@ -42,8 +42,12 @@ export CFLAGS := -W
- export CXXFLAGS := -Wall
-
- C_CXX_FLAGS := -MMD -I$(BASE_DIR) -I$(BASE_DIR)/Crypto
- C_CXX_FLAGS += -DBOOL=int -DFALSE=0 -DTRUE=1
-+ifeq "$(origin USE64BIT)" "command line"
-+C_CXX_FLAGS += -D__int8=char -D__int16=short -D__int32=int '-D__int64=long' # Tested in PlatformTest
-+else
- C_CXX_FLAGS += -D__int8=char -D__int16=short -D__int32=int '-D__int64=long long' # Tested in PlatformTest
-+endif
-
- export LFLAGS :=
- export PKG_CONFIG_PATH ?= /usr/local/lib/pkgconfig
diff --git a/app-crypt/truecrypt/files/truecrypt-5.0-build.patch b/app-crypt/truecrypt/files/truecrypt-5.0-build.patch
deleted file mode 100644
index e34e5be2eacc..000000000000
--- a/app-crypt/truecrypt/files/truecrypt-5.0-build.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -urNp truecrypt-5.0-source.org/Main/Main.make truecrypt-5.0-source/Main/Main.make
---- truecrypt-5.0-source.org/Main/Main.make 2008-02-05 01:16:52.000000000 +0200
-+++ truecrypt-5.0-source/Main/Main.make 2008-02-08 19:09:47.000000000 +0200
-@@ -62,18 +62,20 @@ RESOURCES += ../Mount/Logo_96dpi.bmp.h
-
- CXXFLAGS += -I$(BASE_DIR)/Main
-
-+WX_CONFIG ?= $(WX_BUILD_DIR)/wx-config
-+WX_CONFIG_EXTRA ?= --static
-
- #------ wxWidgets configuration ------
-
- ifeq "$(TC_BUILD_CONFIG)" "Release"
-
--CXXFLAGS += $(shell $(WX_BUILD_DIR)/wx-config --unicode --static --cxxflags)
--WX_LIBS = $(shell $(WX_BUILD_DIR)/wx-config --unicode --static --libs adv,core,base)
-+CXXFLAGS += $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --cxxflags)
-+WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --libs adv,core,base)
-
- else
-
--CXXFLAGS += $(shell $(WX_BUILD_DIR)/wx-config --debug --unicode --static --cxxflags)
--WX_LIBS = $(shell $(WX_BUILD_DIR)/wx-config --debug --unicode --static --libs adv,core,base)
-+CXXFLAGS += $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --debug --cxxflags)
-+WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --debug --libs adv,core,base)
-
- endif
-
diff --git a/app-crypt/truecrypt/files/truecrypt-5.0-nogui.patch b/app-crypt/truecrypt/files/truecrypt-5.0-nogui.patch
deleted file mode 100644
index 5c2f649f416d..000000000000
--- a/app-crypt/truecrypt/files/truecrypt-5.0-nogui.patch
+++ /dev/null
@@ -1,347 +0,0 @@
-diff -urNp truecrypt-5.0a-source/Main/Application.cpp truecrypt-5.0a-source.new/Main/Application.cpp
---- truecrypt-5.0a-source/Main/Application.cpp 2008-02-04 13:14:16.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/Application.cpp 2008-02-23 00:18:40.000000000 +0200
-@@ -22,11 +22,13 @@ namespace TrueCrypt
- return mUserInterface;
- }
-
-+#ifdef ENABLE_wxGUI
- wxApp* Application::CreateGuiApp ()
- {
- mUserInterface = new GraphicUserInterface;
- return mUserInterface;
- }
-+#endif
-
- FilePath Application::GetConfigFilePath (const wxString &configFileName, bool createConfigDir)
- {
-@@ -72,11 +74,13 @@ namespace TrueCrypt
- wxAppInitializer wxTheAppInitializer((wxAppInitializerFunction) CreateConsoleApp);
- break;
- }
-+#ifdef ENABLE_wxGUI
- case UserInterfaceType::Graphic:
- {
- wxAppInitializer wxTheAppInitializer((wxAppInitializerFunction) CreateGuiApp);
- break;
- }
-+#endif
-
- default:
- throw ParameterIncorrect (SRC_POS);
-diff -urNp truecrypt-5.0a-source/Main/FatalErrorHandler.cpp truecrypt-5.0a-source.new/Main/FatalErrorHandler.cpp
---- truecrypt-5.0a-source/Main/FatalErrorHandler.cpp 2008-02-04 13:14:16.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/FatalErrorHandler.cpp 2008-02-23 00:18:40.000000000 +0200
-@@ -90,6 +90,7 @@ namespace TrueCrypt
-
- #endif // wxUSE_STACKWALKER
-
-+#ifdef ENABLE_wxGUI
- wxString url = Gui->GetHomepageLinkURL (L"err-report", vars.str());
- url.Replace (L"0x", L"");
-
-@@ -109,6 +110,7 @@ namespace TrueCrypt
-
- if (Gui->AskYesNo (msg, true))
- wxLaunchDefaultBrowser (url, wxBROWSER_NEW_WINDOW);
-+#endif
-
- _exit (1);
- }
-@@ -155,6 +157,7 @@ namespace TrueCrypt
- vars.Replace (L"::", L".");
- vars.Replace (L":", L".");
-
-+#ifdef ENABLE_wxGUI
- wxString url = Gui->GetHomepageLinkURL (L"err-report", vars);
-
- wxString msg = L"An unhandled exception has occured and TrueCrypt must be terminated. If this is caused by a bug in TrueCrypt, we would like to fix it. To help us, you can send us an automatically generated error report containing the following items:\n\n- Program version\n- Operating system version\n- Hardware architecture\n- Error description\n- Error location\n";
-@@ -164,15 +167,20 @@ namespace TrueCrypt
-
- if (Gui->AskYesNo (msg, true))
- wxLaunchDefaultBrowser (url, wxBROWSER_NEW_WINDOW);
-+#endif
-
- }
- catch (exception &e)
- {
-+#ifdef ENABLE_wxGUI
- Gui->ShowError (e);
-+#endif
- }
- catch (...)
- {
-+#ifdef ENABLE_wxGUI
- Gui->ShowError (_("Unknown exception occurred."));
-+#endif
- }
-
- _exit (1);
-diff -urNp truecrypt-5.0a-source/Main/GraphicUserInterface.cpp truecrypt-5.0a-source.new/Main/GraphicUserInterface.cpp
---- truecrypt-5.0a-source/Main/GraphicUserInterface.cpp 2008-02-07 17:48:16.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/GraphicUserInterface.cpp 2008-02-23 00:18:40.000000000 +0200
-@@ -19,6 +19,9 @@
- #include "Application.h"
- #include "GraphicUserInterface.h"
- #include "FatalErrorHandler.h"
-+
-+#ifdef ENABLE_wxGUI
-+
- #include "Forms/DeviceSelectionDialog.h"
- #include "Forms/MainFrame.h"
- #include "Forms/MountOptionsDialog.h"
-@@ -1039,3 +1042,4 @@ namespace TrueCrypt
-
- GraphicUserInterface *Gui = nullptr;
- }
-+#endif
-diff -urNp truecrypt-5.0a-source/Main/GraphicUserInterface.h truecrypt-5.0a-source.new/Main/GraphicUserInterface.h
---- truecrypt-5.0a-source/Main/GraphicUserInterface.h 2008-02-05 19:56:46.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/GraphicUserInterface.h 2008-02-23 00:18:40.000000000 +0200
-@@ -14,6 +14,7 @@
- #include "Main.h"
- #include "UserInterface.h"
-
-+#ifdef ENABLE_wxGUI
- namespace TrueCrypt
- {
- class GraphicUserInterface : public UserInterface
-@@ -128,5 +129,6 @@ namespace TrueCrypt
-
- extern GraphicUserInterface *Gui;
- }
-+#endif
-
- #endif // TC_HEADER_Main_GraphicUserInterface
-diff -urNp truecrypt-5.0a-source/Main/Main.make truecrypt-5.0a-source.new/Main/Main.make
---- truecrypt-5.0a-source/Main/Main.make 2008-02-22 19:05:05.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/Main.make 2008-02-23 00:19:04.000000000 +0200
-@@ -21,6 +21,7 @@ OBJS += UserPreferences.o
- OBJS += VolumeHistory.o
- OBJS += Xml.o
- OBJS += Unix/Main.o
-+ifeq "$(TC_BUILD_GUI)" "True"
- OBJS += Forms/AboutDialog.o
- OBJS += Forms/ChangePasswordDialog.o
- OBJS += Forms/DeviceSelectionDialog.o
-@@ -47,6 +48,7 @@ OBJS += Forms/VolumeLocationWizardPage.o
- OBJS += Forms/VolumePasswordWizardPage.o
- OBJS += Forms/VolumeSizeWizardPage.o
- OBJS += Forms/WizardFrame.o
-+endif
- OBJS += Resources.o
-
- PCH := SystemPrecompiled.h.gch
-@@ -70,12 +72,12 @@ WX_CONFIG_EXTRA ?= --static
- ifeq "$(TC_BUILD_CONFIG)" "Release"
-
- CXXFLAGS += $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --cxxflags)
--WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --libs adv,core,base)
-+WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --libs)
-
- else
-
- CXXFLAGS += $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --debug --cxxflags)
--WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --debug --libs adv,core,base)
-+WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --debug --libs)
-
- endif
-
-diff -urNp truecrypt-5.0a-source/Main/Resources.cpp truecrypt-5.0a-source.new/Main/Resources.cpp
---- truecrypt-5.0a-source/Main/Resources.cpp 2008-02-04 13:14:16.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/Resources.cpp 2008-02-23 00:18:40.000000000 +0200
-@@ -35,6 +35,7 @@ namespace TrueCrypt
- }
- #endif // TC_WINDOWS
-
-+#ifdef ENABLE_wxGUI
- wxBitmap Resources::GetDriveIconBitmap ()
- {
- #ifdef TC_WINDOWS
-@@ -72,6 +73,7 @@ namespace TrueCrypt
- # endif
- #endif
- }
-+#endif
-
- string Resources::GetLanguageXml ()
- {
-@@ -111,6 +113,7 @@ namespace TrueCrypt
- #endif
- }
-
-+#ifdef ENABLE_wxGUI
- wxBitmap Resources::GetLogoBitmap ()
- {
- #ifdef TC_WINDOWS
-@@ -173,4 +176,5 @@ namespace TrueCrypt
- return wxBitmap (image);
- #endif
- }
-+#endif
- }
-diff -urNp truecrypt-5.0a-source/Main/Resources.h truecrypt-5.0a-source.new/Main/Resources.h
---- truecrypt-5.0a-source/Main/Resources.h 2008-02-04 13:14:14.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/Resources.h 2008-02-23 00:18:40.000000000 +0200
-@@ -17,14 +17,18 @@ namespace TrueCrypt
- class Resources
- {
- public:
-+#ifdef ENABLE_wxGUI
- static wxBitmap GetDriveIconBitmap ();
- static wxBitmap GetDriveIconMaskBitmap ();
-+#endif
- static string GetLanguageXml ();
- static string GetLegalNotices ();
-+#ifdef ENABLE_wxGUI
- static wxBitmap GetLogoBitmap ();
- static wxBitmap GetTextualLogoBitmap ();
- static wxIcon GetTrueCryptIcon ();
- static wxBitmap GetVolumeCreationWizardBitmap (int height = -1);
-+#endif
-
- protected:
- };
-diff -urNp truecrypt-5.0a-source/Main/SystemPrecompiled.h truecrypt-5.0a-source.new/Main/SystemPrecompiled.h
---- truecrypt-5.0a-source/Main/SystemPrecompiled.h 2008-02-04 13:22:08.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/SystemPrecompiled.h 2008-02-23 00:18:40.000000000 +0200
-@@ -7,16 +7,24 @@
- */
-
- #include <wx/wx.h>
-+#ifdef ENABLE_wxGUI
- #include <wx/dnd.h>
-+#endif
- #include <wx/filename.h>
-+#ifdef ENABLE_wxGUI
- #include <wx/imaglist.h>
- #include <wx/listctrl.h>
-+#endif
- #include <wx/mstream.h>
- #include <wx/power.h>
- #include <wx/snglinst.h>
-+#ifdef ENABLE_wxGUI
- #include <wx/taskbar.h>
-+#endif
- #include <wx/txtstrm.h>
-+#ifdef ENABLE_wxGUI
- #include <wx/valgen.h>
-+#endif
- #include <wx/wfstream.h>
-
- #include <iostream>
-diff -urNp truecrypt-5.0a-source/Main/TextUserInterface.cpp truecrypt-5.0a-source.new/Main/TextUserInterface.cpp
---- truecrypt-5.0a-source/Main/TextUserInterface.cpp 2008-02-04 18:38:04.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/TextUserInterface.cpp 2008-02-23 00:18:40.000000000 +0200
-@@ -423,8 +423,9 @@ namespace TrueCrypt
-
- InterfaceType = UserInterfaceType::Text;
- Init();
--
-+#ifdef ENABLE_wxGUI
- SetExitOnFrameDelete (false);
-+#endif
- }
- catch (exception &e)
- {
-diff -urNp truecrypt-5.0a-source/Main/Unix/Main.cpp truecrypt-5.0a-source.new/Main/Unix/Main.cpp
---- truecrypt-5.0a-source/Main/Unix/Main.cpp 2008-02-12 22:21:58.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/Unix/Main.cpp 2008-02-23 00:18:40.000000000 +0200
-@@ -59,6 +59,9 @@ int main (int argc, char **argv)
- if (!getenv ("DISPLAY"))
- forceTextUI = true;
- #endif
-+#ifndef ENABLE_wxGUI
-+ forceTextUI = true;
-+#endif
-
- // Set user interface type
- if (forceTextUI || (argc > 1 && (strcmp (argv[1], "-t") == 0 || strcmp (argv[1], "--text") == 0)))
-diff -urNp truecrypt-5.0a-source/Main/UserInterface.cpp truecrypt-5.0a-source.new/Main/UserInterface.cpp
---- truecrypt-5.0a-source/Main/UserInterface.cpp 2008-02-12 22:28:34.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/UserInterface.cpp 2008-02-23 00:18:40.000000000 +0200
-@@ -302,8 +302,10 @@ namespace TrueCrypt
- {
- wxString message = ExceptionTypeToString (typeid (ex));
-
-+#ifdef ENABLE_wxGUI
- if (wxGetKeyState (WXK_CAPITAL))
- message += wxString (L"\n\n") + LangString["CAPSLOCK_ON"];
-+#endif
-
- return message;
- }
-diff -urNp truecrypt-5.0a-source/Main/VolumeHistory.cpp truecrypt-5.0a-source.new/Main/VolumeHistory.cpp
---- truecrypt-5.0a-source/Main/VolumeHistory.cpp 2008-02-04 13:14:16.000000000 +0200
-+++ truecrypt-5.0a-source.new/Main/VolumeHistory.cpp 2008-02-23 00:18:40.000000000 +0200
-@@ -10,6 +10,9 @@
- #include "Application.h"
- #include "GraphicUserInterface.h"
- #include "Xml.h"
-+
-+#ifdef ENABLE_wxGUI
-+
- #include "VolumeHistory.h"
-
- namespace TrueCrypt
-@@ -150,3 +153,5 @@ namespace TrueCrypt
- Mutex VolumeHistory::AccessMutex;
-
- }
-+
-+#endif
-diff -urNp truecrypt-5.0a-source/Makefile truecrypt-5.0a-source.new/Makefile
---- truecrypt-5.0a-source/Makefile 2008-02-22 19:05:05.000000000 +0200
-+++ truecrypt-5.0a-source.new/Makefile 2008-02-23 00:18:40.000000000 +0200
-@@ -11,6 +11,7 @@
- # DEBUGGER: Enable debugging information for use by debuggers
- # NOSTRIP: Do not strip release binaries
- # VERBOSE: Enable verbose messages
-+# NOGUI: Do not build GUI truecrypt
-
- #------ Targets ------
- # all
-@@ -30,6 +31,11 @@ TC_BUILD_CONFIG := Debug
- endif
- endif
-
-+export TC_BUILD_GUI := True
-+
-+ifeq "$(origin NOGUI)" "command line"
-+TC_BUILD_GUI := False
-+endif
-
- #------ Build configuration ------
-
-@@ -150,6 +156,9 @@ C_CXX_FLAGS += -DTC_UNIX -DTC_BSD -DTC_F
-
- endif
-
-+ifeq "$(TC_BUILD_GUI)" "True"
-+C_CXX_FLAGS += -DENABLE_wxGUI
-+endif
-
- CFLAGS := $(C_CXX_FLAGS) $(CFLAGS) $(EXTRA_CFLAGS)
- CXXFLAGS := $(C_CXX_FLAGS) $(CXXFLAGS) $(EXTRA_CXXFLAGS)
-@@ -194,6 +203,12 @@ CXXFLAGS :=
- LFLAGS :=
- endif
-
-+ifeq "$(TC_BUILD_GUI)" "True"
-+WX_NO_GUI:=
-+else
-+WX_NO_GUI:=--disable-gui
-+endif
-+
- wxbuild:
-
- ifneq "$(shell test -f $(WX_ROOT)/configure || test -f $(WX_BUILD_DIR)/../configure && echo 1)" "1"
-@@ -203,7 +218,7 @@ endif
-
- mkdir -p $(WX_BUILD_DIR)
- @echo Configuring wxWidgets library...
-- cd $(WX_BUILD_DIR) && $(WX_ROOT)/configure $(WX_CONFIGURE_FLAGS) >/dev/null
-+ cd $(WX_BUILD_DIR) && $(WX_ROOT)/configure $(WX_NO_GUI) $(WX_CONFIGURE_FLAGS) >/dev/null
-
- @echo Building wxWidgets library...
- cd $(WX_BUILD_DIR) && make
diff --git a/app-crypt/truecrypt/files/truecrypt-5.1-nogui.patch b/app-crypt/truecrypt/files/truecrypt-5.1-nogui.patch
deleted file mode 100644
index 569e2636765f..000000000000
--- a/app-crypt/truecrypt/files/truecrypt-5.1-nogui.patch
+++ /dev/null
@@ -1,351 +0,0 @@
-diff -urNp truecrypt-5.1-source.org/Main/Application.cpp truecrypt-5.1-source/Main/Application.cpp
---- truecrypt-5.1-source.org/Main/Application.cpp 2008-03-02 13:03:30.000000000 +0200
-+++ truecrypt-5.1-source/Main/Application.cpp 2008-03-12 23:40:04.000000000 +0200
-@@ -23,12 +23,14 @@ namespace TrueCrypt
- return mUserInterface;
- }
-
-+#ifdef ENABLE_wxGUI
- wxApp* Application::CreateGuiApp ()
- {
- mUserInterface = new GraphicUserInterface;
- mUserInterfaceType = UserInterfaceType::Graphic;
- return mUserInterface;
- }
-+#endif
-
- FilePath Application::GetConfigFilePath (const wxString &configFileName, bool createConfigDir)
- {
-@@ -74,11 +76,13 @@ namespace TrueCrypt
- wxAppInitializer wxTheAppInitializer((wxAppInitializerFunction) CreateConsoleApp);
- break;
- }
-+#ifdef ENABLE_wxGUI
- case UserInterfaceType::Graphic:
- {
- wxAppInitializer wxTheAppInitializer((wxAppInitializerFunction) CreateGuiApp);
- break;
- }
-+#endif
-
- default:
- throw ParameterIncorrect (SRC_POS);
-diff -urNp truecrypt-5.1-source.org/Main/FatalErrorHandler.cpp truecrypt-5.1-source/Main/FatalErrorHandler.cpp
---- truecrypt-5.1-source.org/Main/FatalErrorHandler.cpp 2008-03-09 21:18:58.000000000 +0200
-+++ truecrypt-5.1-source/Main/FatalErrorHandler.cpp 2008-03-12 23:39:24.000000000 +0200
-@@ -92,6 +92,7 @@ namespace TrueCrypt
-
- #endif // wxUSE_STACKWALKER
-
-+#ifdef ENABLE_wxGUI
- wxString url = Gui->GetHomepageLinkURL (L"err-report", vars.str());
- url.Replace (L"0x", L"");
-
-@@ -111,6 +112,7 @@ namespace TrueCrypt
-
- if (Gui->AskYesNo (msg, true))
- wxLaunchDefaultBrowser (url, wxBROWSER_NEW_WINDOW);
-+#endif
-
- _exit (1);
- }
-@@ -157,6 +159,7 @@ namespace TrueCrypt
- vars.Replace (L"::", L".");
- vars.Replace (L":", L".");
-
-+#ifdef ENABLE_wxGUI
- wxString url = Gui->GetHomepageLinkURL (L"err-report", vars);
-
- wxString msg = L"An unhandled exception has occured and TrueCrypt must be terminated. If this is caused by a bug in TrueCrypt, we would like to fix it. To help us, you can send us an automatically generated error report containing the following items:\n\n- Program version\n- Operating system version\n- Hardware architecture\n- Error description\n- Error location\n";
-@@ -166,15 +169,20 @@ namespace TrueCrypt
-
- if (Gui->AskYesNo (msg, true))
- wxLaunchDefaultBrowser (url, wxBROWSER_NEW_WINDOW);
-+#endif
-
- }
- catch (exception &e)
- {
-+#ifdef ENABLE_wxGUI
- Gui->ShowError (e);
-+#endif
- }
- catch (...)
- {
-+#ifdef ENABLE_wxGUI
- Gui->ShowError (_("Unknown exception occurred."));
-+#endif
- }
-
- _exit (1);
-diff -urNp truecrypt-5.1-source.org/Main/GraphicUserInterface.cpp truecrypt-5.1-source/Main/GraphicUserInterface.cpp
---- truecrypt-5.1-source.org/Main/GraphicUserInterface.cpp 2008-03-09 09:41:24.000000000 +0200
-+++ truecrypt-5.1-source/Main/GraphicUserInterface.cpp 2008-03-12 23:39:24.000000000 +0200
-@@ -19,6 +19,9 @@
- #include "Application.h"
- #include "GraphicUserInterface.h"
- #include "FatalErrorHandler.h"
-+
-+#ifdef ENABLE_wxGUI
-+
- #include "Forms/DeviceSelectionDialog.h"
- #include "Forms/MainFrame.h"
- #include "Forms/MountOptionsDialog.h"
-@@ -1055,3 +1058,4 @@ namespace TrueCrypt
-
- GraphicUserInterface *Gui = nullptr;
- }
-+#endif
-diff -urNp truecrypt-5.1-source.org/Main/GraphicUserInterface.h truecrypt-5.1-source/Main/GraphicUserInterface.h
---- truecrypt-5.1-source.org/Main/GraphicUserInterface.h 2008-03-09 09:40:00.000000000 +0200
-+++ truecrypt-5.1-source/Main/GraphicUserInterface.h 2008-03-12 23:39:24.000000000 +0200
-@@ -14,6 +14,7 @@
- #include "Main.h"
- #include "UserInterface.h"
-
-+#ifdef ENABLE_wxGUI
- namespace TrueCrypt
- {
- class GraphicUserInterface : public UserInterface
-@@ -129,5 +130,6 @@ namespace TrueCrypt
-
- extern GraphicUserInterface *Gui;
- }
-+#endif
-
- #endif // TC_HEADER_Main_GraphicUserInterface
-diff -urNp truecrypt-5.1-source.org/Main/Main.make truecrypt-5.1-source/Main/Main.make
---- truecrypt-5.1-source.org/Main/Main.make 2008-03-12 23:38:24.000000000 +0200
-+++ truecrypt-5.1-source/Main/Main.make 2008-03-12 23:39:24.000000000 +0200
-@@ -21,6 +21,7 @@ OBJS += UserPreferences.o
- OBJS += VolumeHistory.o
- OBJS += Xml.o
- OBJS += Unix/Main.o
-+ifeq "$(TC_BUILD_GUI)" "True"
- OBJS += Forms/AboutDialog.o
- OBJS += Forms/ChangePasswordDialog.o
- OBJS += Forms/DeviceSelectionDialog.o
-@@ -47,6 +48,7 @@ OBJS += Forms/VolumeLocationWizardPage.o
- OBJS += Forms/VolumePasswordWizardPage.o
- OBJS += Forms/VolumeSizeWizardPage.o
- OBJS += Forms/WizardFrame.o
-+endif
- OBJS += Resources.o
-
- ifndef DISABLE_PRECOMPILED_HEADERS
-@@ -72,12 +74,12 @@ WX_CONFIG_EXTRA ?= --static
- ifeq "$(TC_BUILD_CONFIG)" "Release"
-
- CXXFLAGS += $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --cxxflags)
--WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --libs adv,core,base)
-+WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --libs)
-
- else
-
- CXXFLAGS += $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --debug --cxxflags)
--WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --debug --libs adv,core,base)
-+WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --debug --libs)
-
- endif
-
-diff -urNp truecrypt-5.1-source.org/Main/Resources.cpp truecrypt-5.1-source/Main/Resources.cpp
---- truecrypt-5.1-source.org/Main/Resources.cpp 2008-02-04 13:14:16.000000000 +0200
-+++ truecrypt-5.1-source/Main/Resources.cpp 2008-03-12 23:39:24.000000000 +0200
-@@ -35,6 +35,7 @@ namespace TrueCrypt
- }
- #endif // TC_WINDOWS
-
-+#ifdef ENABLE_wxGUI
- wxBitmap Resources::GetDriveIconBitmap ()
- {
- #ifdef TC_WINDOWS
-@@ -72,6 +73,7 @@ namespace TrueCrypt
- # endif
- #endif
- }
-+#endif
-
- string Resources::GetLanguageXml ()
- {
-@@ -111,6 +113,7 @@ namespace TrueCrypt
- #endif
- }
-
-+#ifdef ENABLE_wxGUI
- wxBitmap Resources::GetLogoBitmap ()
- {
- #ifdef TC_WINDOWS
-@@ -173,4 +176,5 @@ namespace TrueCrypt
- return wxBitmap (image);
- #endif
- }
-+#endif
- }
-diff -urNp truecrypt-5.1-source.org/Main/Resources.h truecrypt-5.1-source/Main/Resources.h
---- truecrypt-5.1-source.org/Main/Resources.h 2008-02-04 13:14:14.000000000 +0200
-+++ truecrypt-5.1-source/Main/Resources.h 2008-03-12 23:39:24.000000000 +0200
-@@ -17,14 +17,18 @@ namespace TrueCrypt
- class Resources
- {
- public:
-+#ifdef ENABLE_wxGUI
- static wxBitmap GetDriveIconBitmap ();
- static wxBitmap GetDriveIconMaskBitmap ();
-+#endif
- static string GetLanguageXml ();
- static string GetLegalNotices ();
-+#ifdef ENABLE_wxGUI
- static wxBitmap GetLogoBitmap ();
- static wxBitmap GetTextualLogoBitmap ();
- static wxIcon GetTrueCryptIcon ();
- static wxBitmap GetVolumeCreationWizardBitmap (int height = -1);
-+#endif
-
- protected:
- };
-diff -urNp truecrypt-5.1-source.org/Main/SystemPrecompiled.h truecrypt-5.1-source/Main/SystemPrecompiled.h
---- truecrypt-5.1-source.org/Main/SystemPrecompiled.h 2008-02-04 13:22:08.000000000 +0200
-+++ truecrypt-5.1-source/Main/SystemPrecompiled.h 2008-03-12 23:39:24.000000000 +0200
-@@ -7,16 +7,24 @@
- */
-
- #include <wx/wx.h>
-+#ifdef ENABLE_wxGUI
- #include <wx/dnd.h>
-+#endif
- #include <wx/filename.h>
-+#ifdef ENABLE_wxGUI
- #include <wx/imaglist.h>
- #include <wx/listctrl.h>
-+#endif
- #include <wx/mstream.h>
- #include <wx/power.h>
- #include <wx/snglinst.h>
-+#ifdef ENABLE_wxGUI
- #include <wx/taskbar.h>
-+#endif
- #include <wx/txtstrm.h>
-+#ifdef ENABLE_wxGUI
- #include <wx/valgen.h>
-+#endif
- #include <wx/wfstream.h>
-
- #include <iostream>
-diff -urNp truecrypt-5.1-source.org/Main/TextUserInterface.cpp truecrypt-5.1-source/Main/TextUserInterface.cpp
---- truecrypt-5.1-source.org/Main/TextUserInterface.cpp 2008-03-10 15:05:40.000000000 +0200
-+++ truecrypt-5.1-source/Main/TextUserInterface.cpp 2008-03-12 23:39:24.000000000 +0200
-@@ -712,8 +712,9 @@ namespace TrueCrypt
-
- InterfaceType = UserInterfaceType::Text;
- Init();
--
-+#ifdef ENABLE_wxGUI
- SetExitOnFrameDelete (false);
-+#endif
- }
- catch (exception &e)
- {
-diff -urNp truecrypt-5.1-source.org/Main/Unix/Main.cpp truecrypt-5.1-source/Main/Unix/Main.cpp
---- truecrypt-5.1-source.org/Main/Unix/Main.cpp 2008-03-09 22:13:10.000000000 +0200
-+++ truecrypt-5.1-source/Main/Unix/Main.cpp 2008-03-12 23:39:24.000000000 +0200
-@@ -61,6 +61,9 @@ int main (int argc, char **argv)
- if (!getenv ("DISPLAY"))
- forceTextUI = true;
- #endif
-+#ifndef ENABLE_wxGUI
-+ forceTextUI = true;
-+#endif
-
- // Set user interface type
- if (forceTextUI || (argc > 1 && (strcmp (argv[1], "-t") == 0 || strcmp (argv[1], "--text") == 0)))
-diff -urNp truecrypt-5.1-source.org/Main/UserInterface.cpp truecrypt-5.1-source/Main/UserInterface.cpp
---- truecrypt-5.1-source.org/Main/UserInterface.cpp 2008-03-09 19:02:54.000000000 +0200
-+++ truecrypt-5.1-source/Main/UserInterface.cpp 2008-03-12 23:41:46.000000000 +0200
-@@ -356,11 +356,13 @@ namespace TrueCrypt
- {
- wxString message = ExceptionTypeToString (typeid (ex));
-
-+#ifdef ENABLE_wxGUI
- #ifdef __WXGTK__
- if (Application::GetUserInterfaceType() != UserInterfaceType::Text)
- #endif
- if (wxGetKeyState (WXK_CAPITAL))
- message += wxString (L"\n\n") + LangString["CAPSLOCK_ON"];
-+#endif
-
- return message;
- }
-diff -urNp truecrypt-5.1-source.org/Main/VolumeHistory.cpp truecrypt-5.1-source/Main/VolumeHistory.cpp
---- truecrypt-5.1-source.org/Main/VolumeHistory.cpp 2008-02-04 13:14:16.000000000 +0200
-+++ truecrypt-5.1-source/Main/VolumeHistory.cpp 2008-03-12 23:39:24.000000000 +0200
-@@ -10,6 +10,9 @@
- #include "Application.h"
- #include "GraphicUserInterface.h"
- #include "Xml.h"
-+
-+#ifdef ENABLE_wxGUI
-+
- #include "VolumeHistory.h"
-
- namespace TrueCrypt
-@@ -150,3 +153,5 @@ namespace TrueCrypt
- Mutex VolumeHistory::AccessMutex;
-
- }
-+
-+#endif
-diff -urNp truecrypt-5.1-source.org/Makefile truecrypt-5.1-source/Makefile
---- truecrypt-5.1-source.org/Makefile 2008-03-12 23:38:33.000000000 +0200
-+++ truecrypt-5.1-source/Makefile 2008-03-12 23:39:24.000000000 +0200
-@@ -12,6 +12,7 @@
- # NOSTRIP: Do not strip release binary
- # NOTEST: Do not test release binary
- # VERBOSE: Enable verbose messages
-+# NOGUI: Do not build GUI truecrypt
-
- #------ Targets ------
- # all
-@@ -31,6 +32,11 @@ TC_BUILD_CONFIG := Debug
- endif
- endif
-
-+export TC_BUILD_GUI := True
-+
-+ifeq "$(origin NOGUI)" "command line"
-+TC_BUILD_GUI := False
-+endif
-
- #------ Build configuration ------
-
-@@ -147,6 +153,9 @@ endif
-
- endif
-
-+ifeq "$(TC_BUILD_GUI)" "True"
-+C_CXX_FLAGS += -DENABLE_wxGUI
-+endif
-
- #------ FreeBSD configuration ------
-
-@@ -203,6 +212,12 @@ CXXFLAGS :=
- LFLAGS :=
- endif
-
-+ifeq "$(TC_BUILD_GUI)" "True"
-+WX_NO_GUI:=
-+else
-+WX_NO_GUI:=--disable-gui
-+endif
-+
- wxbuild:
-
- ifneq "$(shell test -f $(WX_ROOT)/configure || test -f $(WX_BUILD_DIR)/../configure && echo 1)" "1"
-@@ -212,7 +227,7 @@ endif
-
- mkdir -p $(WX_BUILD_DIR)
- @echo Configuring wxWidgets library...
-- cd $(WX_BUILD_DIR) && $(WX_ROOT)/configure $(WX_CONFIGURE_FLAGS) >/dev/null
-+ cd $(WX_BUILD_DIR) && $(WX_ROOT)/configure $(WX_NO_GUI) $(WX_CONFIGURE_FLAGS) >/dev/null
-
- @echo Building wxWidgets library...
- cd $(WX_BUILD_DIR) && make
diff --git a/app-crypt/truecrypt/files/truecrypt-5.1a-external-wx.patch b/app-crypt/truecrypt/files/truecrypt-5.1a-external-wx.patch
new file mode 100644
index 000000000000..2cdd183b169b
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt-5.1a-external-wx.patch
@@ -0,0 +1,33 @@
+diff -urNp truecrypt-5.1a-source.org/Main/Main.make truecrypt-5.1a-source/Main/Main.make
+--- truecrypt-5.1a-source.org/Main/Main.make 2008-03-11 20:48:42.000000000 +0200
++++ truecrypt-5.1a-source/Main/Main.make 2008-03-21 18:38:43.000000000 +0200
+@@ -70,21 +70,25 @@ CXXFLAGS += -I$(BASE_DIR)/Main
+
+ #------ wxWidgets configuration ------
+
++WX_CONFIG ?= $(WX_BUILD_DIR)/wx-config
++WX_CONFIG_EXTRA ?= --static
++
+ ifdef TC_NO_GUI
+ WX_CONFIG_LIBS := base
+ else
+ WX_CONFIG_LIBS := adv,core,base
+ endif
++WX_CONFIG_LIBS =
+
+ ifeq "$(TC_BUILD_CONFIG)" "Release"
+
+-CXXFLAGS += $(shell $(WX_BUILD_DIR)/wx-config --unicode --static --cxxflags)
+-WX_LIBS = $(shell $(WX_BUILD_DIR)/wx-config --unicode --static --libs $(WX_CONFIG_LIBS))
++CXXFLAGS += $(shell $(WX_CONFIG) --unicode $(WX_CONFIG_EXTRA) --cxxflags)
++WX_LIBS = $(shell $(WX_CONFIG) --unicode $(WX_CONFIG_EXTRA) --libs $(WX_CONFIG_LIBS))
+
+ else
+
+-CXXFLAGS += $(shell $(WX_BUILD_DIR)/wx-config --debug --unicode --static --cxxflags)
+-WX_LIBS = $(shell $(WX_BUILD_DIR)/wx-config --debug --unicode --static --libs $(WX_CONFIG_LIBS))
++CXXFLAGS += $(shell $(WX_CONFIG) --debug --unicode $(WX_CONFIG_EXTRA) --cxxflags)
++WX_LIBS = $(shell $(WX_CONFIG) --debug --unicode $(WX_CONFIG_EXTRA) --libs $(WX_CONFIG_LIBS))
+
+ endif
+