summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-06-05 08:19:18 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-06-05 08:19:18 +0000
commit8c57c91ae46365b224cf72df0670a9e35148ce57 (patch)
tree207bc6d2778ee01cea6b8bf033ee4b8304664720 /app-crypt/truecrypt/files
parentStable amd64 and sparc. (diff)
downloadgentoo-2-8c57c91ae46365b224cf72df0670a9e35148ce57.tar.gz
gentoo-2-8c57c91ae46365b224cf72df0670a9e35148ce57.tar.bz2
gentoo-2-8c57c91ae46365b224cf72df0670a9e35148ce57.zip
initial ebuild as per bug #112197 largely based off ebuild by Greg Tassone
(Portage version: 2.1_rc4-r1)
Diffstat (limited to 'app-crypt/truecrypt/files')
-rw-r--r--app-crypt/truecrypt/files/digest-truecrypt-4.23
-rw-r--r--app-crypt/truecrypt/files/truecrypt-4.2-makefile.patch67
2 files changed, 70 insertions, 0 deletions
diff --git a/app-crypt/truecrypt/files/digest-truecrypt-4.2 b/app-crypt/truecrypt/files/digest-truecrypt-4.2
new file mode 100644
index 000000000000..9951f54d3da9
--- /dev/null
+++ b/app-crypt/truecrypt/files/digest-truecrypt-4.2
@@ -0,0 +1,3 @@
+MD5 8ea4464f3f89fe8c367dc19982a8f611 truecrypt-4.2-source-code.tar.gz 1076093
+RMD160 74ba185bad9952ea9b3b0e358e9fee6f2080e6b9 truecrypt-4.2-source-code.tar.gz 1076093
+SHA256 54f54cd68c99efe3fd2c0899174b38d4cfe1ad576112672aabd2ac64e336cd1f truecrypt-4.2-source-code.tar.gz 1076093
diff --git a/app-crypt/truecrypt/files/truecrypt-4.2-makefile.patch b/app-crypt/truecrypt/files/truecrypt-4.2-makefile.patch
new file mode 100644
index 000000000000..8b4017f6bc09
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt-4.2-makefile.patch
@@ -0,0 +1,67 @@
+--- Linux/Cli/Makefile.orig 2006-03-26 06:29:38.000000000 +1100
++++ Linux/Cli/Makefile 2006-06-05 17:57:29.000000000 +1000
+@@ -3,27 +3,16 @@
+ TC_COMMON := ../../Common
+ TC_CRYPTO := ../../Crypto
+
+-CC := gcc
++CC ?= gcc
+
+ ifneq ($(MAKECMDGOALS),clean)
+ -include ../Common/.platform
+ endif
+
+-ifdef NO_WARNINGS
+-CFLAGS := -w
+-else
+-CFLAGS := -W
+-endif
+ CFLAGS += -I../../Crypto -I../../Common -I../Kernel
+ CFLAGS += -D_cdecl="" -DBOOL=int -DTRUE=1 -DFALSE=0 -DMAX_PATH=260
+ CFLAGS += $(TYPES)
+
+-ifndef DEBUG
+-CFLAGS += -O2 -fno-strict-aliasing
+-else
+-CFLAGS += -ggdb
+-endif
+-
+ KERNEL_OBJS_F := ../.kernel-objs
+ USER_OBJS_F := ../.user-objs
+
+@@ -61,18 +50,18 @@
+ @echo Compiling $(<F)
+ @$(CC) $(CFLAGS) $(EXTRA_CFLAGS) -MMD -o $@ -c $<
+
+-all: objclean truecrypt
++all: $(USER_OBJS_F) truecrypt
+ @echo Done.
+
+ ../Common/.platform: ../Common/Platform.c
+- @$(CC) -o ../Common/platform $<
++ $(CC) -o ../Common/platform $<
+ @../Common/platform >../Common/.platform
+
+ -include $(OBJS:.o=.d)
+
+ truecrypt: $(OBJS)
+ @echo Linking $@
+- @$(CC) -o $@ $(OBJS)
++ $(CC) -o $@ $(OBJS)
+ ifndef DEBUG
+ @strip $@
+ endif
+@@ -82,9 +71,11 @@
+ truecrypt.1: objclean truecrypt
+ help2man -N -i Man/help2man.inc ./truecrypt >Man/truecrypt.1
+
+-objclean:
+- @if [ -f $(KERNEL_OBJS_F) ]; then rm -f ${OBJS} $(KERNEL_OBJS_F); fi
++$(USER_OBJS_F):
++ @[ -f $(KERNEL_OBJS_F) ] && rm -f ${OBJS} $(KERNEL_OBJS_F)
+ @>$(USER_OBJS_F)
+
+ clean:
+ -rm -f truecrypt ${OBJS} *.d $(TC_COMMON)/*.d $(TC_CRYPTO)/*.d ../Common/platform ../Common/.platform
++
++.PHONY: man clean