summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2014-12-21 20:07:18 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2014-12-21 20:07:18 +0000
commit15281455893a208d853e1fe659e31bc6d82e3a54 (patch)
treee18fccd288751835b88c53c99eb14814238aa63f /app-crypt/xca
parentVersion bump. Bug #515494. Thanks to mike@marineau.org for the ebuild (diff)
downloadgentoo-2-15281455893a208d853e1fe659e31bc6d82e3a54.tar.gz
gentoo-2-15281455893a208d853e1fe659e31bc6d82e3a54.tar.bz2
gentoo-2-15281455893a208d853e1fe659e31bc6d82e3a54.zip
Version bump, bug#531290
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/ChangeLog7
-rw-r--r--app-crypt/xca/xca-1.1.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-crypt/xca/ChangeLog b/app-crypt/xca/ChangeLog
index 6d7956fb4a3d..fbb993ff340c 100644
--- a/app-crypt/xca/ChangeLog
+++ b/app-crypt/xca/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/xca
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.45 2014/11/07 07:16:53 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.46 2014/12/21 20:07:18 alonbl Exp $
+
+*xca-1.1.0 (21 Dec 2014)
+
+ 21 Dec 2014; Alon Bar-Lev <alonbl@gentoo.org> +xca-1.1.0.ebuild:
+ Version bump, bug#531290
07 Nov 2014; Alon Bar-Lev <alonbl@gentoo.org> -xca-0.9.0.ebuild,
-xca-0.9.1.ebuild, -xca-0.9.3.ebuild:
diff --git a/app-crypt/xca/xca-1.1.0.ebuild b/app-crypt/xca/xca-1.1.0.ebuild
new file mode 100644
index 000000000000..a7e8eaee2809
--- /dev/null
+++ b/app-crypt/xca/xca-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-1.1.0.ebuild,v 1.1 2014/12/21 20:07:18 alonbl Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://xca.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist"
+
+RDEPEND=">=dev-libs/openssl-0.9.8[bindist=]
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.0-desktop.patch
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+
+ insinto /etc/xca
+ doins misc/*.txt
+}