summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-03-31 16:06:16 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-03-31 16:06:16 +0000
commit8e3f774a9448282df9c1d32bb247d412c0a24c19 (patch)
tree5cfa62de94014b9dab25d0eaf2c053d165d6d9a2 /app-crypt
parentStable for amd64, wrt bug #462890 (diff)
downloadgentoo-2-8e3f774a9448282df9c1d32bb247d412c0a24c19.tar.gz
gentoo-2-8e3f774a9448282df9c1d32bb247d412c0a24c19.tar.bz2
gentoo-2-8e3f774a9448282df9c1d32bb247d412c0a24c19.zip
Version bump.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libsecret/ChangeLog7
-rw-r--r--app-crypt/libsecret/libsecret-0.15.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/app-crypt/libsecret/ChangeLog b/app-crypt/libsecret/ChangeLog
index f47339d37eb1..510cf1c9c147 100644
--- a/app-crypt/libsecret/ChangeLog
+++ b/app-crypt/libsecret/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/libsecret
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/ChangeLog,v 1.17 2013/03/30 23:16:06 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/ChangeLog,v 1.18 2013/03/31 16:06:16 eva Exp $
+
+*libsecret-0.15 (31 Mar 2013)
+
+ 31 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> +libsecret-0.15.ebuild:
+ Version bump.
30 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> libsecret-0.14.ebuild:
Policy fixups, switch to python-any-r1.
diff --git a/app-crypt/libsecret/libsecret-0.15.ebuild b/app-crypt/libsecret/libsecret-0.15.ebuild
new file mode 100644
index 000000000000..66b57769e6dd
--- /dev/null
+++ b/app-crypt/libsecret/libsecret-0.15.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/libsecret-0.15.ebuild,v 1.1 2013/03/31 16:06:16 eva Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
+VALA_MIN_API_VERSION=0.18
+VALA_USE_DEPEND=vapigen
+
+inherit eutils gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
+HOMEPAGE="https://live.gnome.org/Libsecret"
+
+LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
+SLOT="0"
+IUSE="+crypt debug +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32.0:2
+ crypt? ( >=dev-libs/libgcrypt-1.2.2:= )
+ introspection? ( >=dev-libs/gobject-introspection-1.29 )"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gnome-keyring-3"
+# Add ksecrets to RDEPEND when it's added to portage
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-python/mock
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gjs-1.32
+ dev-python/pygobject:3 )
+ )
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # FIXME: disable failing test
+ sed -e '/test_get_sync);/d' \
+ -e '/test_get_async);/d' \
+ -i libsecret/tests/test-service.c || die
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ gnome2_src_configure \
+ --enable-manpages \
+ --disable-strict \
+ --disable-coverage \
+ --disable-static \
+ $(use_enable crypt gcrypt) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ Xemake check
+}