summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2008-07-21 19:16:12 +0000
committerMike Auty <ikelos@gentoo.org>2008-07-21 19:16:12 +0000
commitb53ed236596e73e4bd2230c4da4a4335c44c9d63 (patch)
tree7340291b57038bf84bedd6684f1b3aef04b6b36d /app-crypt
parentAdd patch to fix madwifi-ng 0.9.4 building against 2.6.26 kernels. (diff)
downloadgentoo-2-b53ed236596e73e4bd2230c4da4a4335c44c9d63.tar.gz
gentoo-2-b53ed236596e73e4bd2230c4da4a4335c44c9d63.tar.bz2
gentoo-2-b53ed236596e73e4bd2230c4da4a4335c44c9d63.zip
Version bump and split out tables into a separate ebuild.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/ophcrack/ChangeLog7
-rw-r--r--app-crypt/ophcrack/ophcrack-3.0.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/app-crypt/ophcrack/ChangeLog b/app-crypt/ophcrack/ChangeLog
index 385d87796c84..009781e13a97 100644
--- a/app-crypt/ophcrack/ChangeLog
+++ b/app-crypt/ophcrack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/ophcrack
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ChangeLog,v 1.17 2008/01/31 14:24:00 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ChangeLog,v 1.18 2008/07/21 19:16:12 ikelos Exp $
+
+*ophcrack-3.0 (21 Jul 2008)
+
+ 21 Jul 2008; Mike Auty <ikelos@gentoo.org> +ophcrack-3.0.ebuild:
+ Version bump and split out tables into a separate ebuild.
31 Jan 2008; Mike Auty <ikelos@gentoo.org> ChangeLog:
Resign digest-less manifest
diff --git a/app-crypt/ophcrack/ophcrack-3.0.ebuild b/app-crypt/ophcrack/ophcrack-3.0.ebuild
new file mode 100644
index 000000000000..4bee578453ea
--- /dev/null
+++ b/app-crypt/ophcrack/ophcrack-3.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ophcrack-3.0.ebuild,v 1.1 2008/07/21 19:16:12 ikelos Exp $
+
+inherit toolchain-funcs autotools eutils
+
+BKHIVE_VER="1.1.1"
+SAMDUMP_VER="1.1.1"
+
+DESCRIPTION="A time-memory-trade-off-cracker"
+HOMEPAGE="http://ophcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://sourceforge/${PN}/bkhive-${BKHIVE_VER}.tar.gz
+ mirror://sourceforge/${PN}/samdump2-${SAMDUMP_VER}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ >=dev-util/pkgconfig-0.22
+ dev-libs/openssl
+ net-libs/netwib
+ >=x11-libs/qt-4"
+RDEPEND="dev-libs/openssl
+ net-libs/netwib
+ >=x11-libs/qt-4
+ app-crypt/ophcrack-tables"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ # Make samdump2
+ einfo "Compiling samdump2"
+ cd "${WORKDIR}/samdump2-${SAMDUMP_VER}"
+ MAKEOPTS="-j1" emake || die "Failed to make samdump"
+
+ # Make bkhive2
+ einfo "Compiling bkhive"
+ cd "${WORKDIR}/bkhive-${BKHIVE_VER}"
+ MAKEOPTS="-j1" emake || die "Failed to make bkhive2"
+
+ # Make the program
+ einfo "Compiling ophcrack"
+ cd "${S}"
+ econf
+ emake || die "Failed to make ophcrack"
+
+ # Don't try to install the prebuilt binaries,
+ # they'll cause an access violation
+ rm -fr "${S}/linux_tools"
+}
+
+src_install() {
+ make install DESTDIR="${D}"
+
+ cd "${WORKDIR}/bkhive-${BKHIVE_VER}"
+ make install DESTDIR="${D}" PREFIX=/usr/
+
+ cd "${WORKDIR}/samdump2-${SAMDUMP_VER}"
+ make install DESTDIR="${D}" PREFIX=/usr/
+}