summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-04-18 05:26:43 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-04-18 05:26:43 +0000
commitd6a15ee36f346eb99e7a5f4d15072b897cb37d28 (patch)
tree82444f61f6407f4de34a2671eeaf326c3fd727ee /app-crypt
parentVersion bump, thanks to Thorsten Vollmer in bug #218179. (diff)
downloadgentoo-2-d6a15ee36f346eb99e7a5f4d15072b897cb37d28.tar.gz
gentoo-2-d6a15ee36f346eb99e7a5f4d15072b897cb37d28.tar.bz2
gentoo-2-d6a15ee36f346eb99e7a5f4d15072b897cb37d28.zip
Fix gcc-4.3 issue, bug#218137, thanks to Holger Ackermann
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog6
-rw-r--r--app-crypt/truecrypt/files/truecrypt-5.1a-gcc-4.3.patch33
-rw-r--r--app-crypt/truecrypt/truecrypt-5.1a.ebuild3
3 files changed, 40 insertions, 2 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 76c11390c191..6ba515827c63 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.36 2008/03/21 17:24:53 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.37 2008/04/18 05:26:42 alonbl Exp $
+
+ 18 Apr 2008; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/truecrypt-5.1a-gcc-4.3.patch, truecrypt-5.1a.ebuild:
+ Fix gcc-4.3 issue, bug#218137, thanks to Holger Ackermann
*truecrypt-5.1a (21 Mar 2008)
diff --git a/app-crypt/truecrypt/files/truecrypt-5.1a-gcc-4.3.patch b/app-crypt/truecrypt/files/truecrypt-5.1a-gcc-4.3.patch
new file mode 100644
index 000000000000..acd92a2eb23e
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt-5.1a-gcc-4.3.patch
@@ -0,0 +1,33 @@
+diff -ubr ./truecrypt-5.1a-source/Core/FatFormatter.cpp ./truecrypt-5.1a-source-patch/Core/FatFormatter.cpp
+--- ./truecrypt-5.1a-source/Core/FatFormatter.cpp 2008-02-04 18:28:50.000000000 +0100
++++ ./truecrypt-5.1a-source-patch/Core/FatFormatter.cpp 2008-04-17 18:58:06.000000000 +0200
+@@ -13,6 +13,7 @@
+ #include "Common/Tcdefs.h"
+ #include "Platform/Platform.h"
+ #include "FatFormatter.h"
++#include <cstring>
+
+ namespace TrueCrypt
+ {
+diff -ubr ./truecrypt-5.1a-source/Platform/Memory.cpp ./truecrypt-5.1a-source-patch/Platform/Memory.cpp
+--- ./truecrypt-5.1a-source/Platform/Memory.cpp 2008-02-04 12:14:46.000000000 +0100
++++ ./truecrypt-5.1a-source-patch/Platform/Memory.cpp 2008-04-17 18:58:06.000000000 +0200
+@@ -8,6 +8,7 @@
+
+ #include "Memory.h"
+ #include "Exception.h"
++#include <cstring>
+
+ namespace TrueCrypt
+ {
+diff -ubr ./truecrypt-5.1a-source/Volume/EncryptionTest.cpp ./truecrypt-5.1a-source-patch/Volume/EncryptionTest.cpp
+--- ./truecrypt-5.1a-source/Volume/EncryptionTest.cpp 2008-02-04 12:14:12.000000000 +0100
++++ ./truecrypt-5.1a-source-patch/Volume/EncryptionTest.cpp 2008-04-17 18:58:06.000000000 +0200
+@@ -15,6 +15,7 @@
+ #include "EncryptionModeXTS.h"
+ #include "EncryptionTest.h"
+ #include "Pkcs5Kdf.h"
++#include <cstring>
+
+ namespace TrueCrypt
+ {
diff --git a/app-crypt/truecrypt/truecrypt-5.1a.ebuild b/app-crypt/truecrypt/truecrypt-5.1a.ebuild
index fb266ccf0782..f5ce651c074b 100644
--- a/app-crypt/truecrypt/truecrypt-5.1a.ebuild
+++ b/app-crypt/truecrypt/truecrypt-5.1a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-5.1a.ebuild,v 1.1 2008/03/21 17:24:53 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-5.1a.ebuild,v 1.2 2008/04/18 05:26:42 alonbl Exp $
inherit eutils toolchain-funcs multilib wxwidgets
@@ -38,6 +38,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
epatch "${FILESDIR}/${P}-external-wx.patch"
epatch "${FILESDIR}/${PN}-5.1-64bit.patch"
epatch "${FILESDIR}/${PN}-5.0-bool.patch"