summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-03-03 17:14:39 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-03-03 17:14:39 +0000
commitf34122be03378d18ca3a3f8a8b9b8430a948ebaa (patch)
tree912c7bfe3c18f555c752ca60379fd299d3cd9684 /app-dicts/gwaei
parentnewer stable version to match stable version of nvidia-drivers. Thanks to <da... (diff)
downloadgentoo-2-f34122be03378d18ca3a3f8a8b9b8430a948ebaa.tar.gz
gentoo-2-f34122be03378d18ca3a3f8a8b9b8430a948ebaa.tar.bz2
gentoo-2-f34122be03378d18ca3a3f8a8b9b8430a948ebaa.zip
Removed --disable-gconf.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-dicts/gwaei')
-rw-r--r--app-dicts/gwaei/ChangeLog7
-rw-r--r--app-dicts/gwaei/gwaei-0.15.1-r2.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/app-dicts/gwaei/ChangeLog b/app-dicts/gwaei/ChangeLog
index 41d23110290c..b8717fc70240 100644
--- a/app-dicts/gwaei/ChangeLog
+++ b/app-dicts/gwaei/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-dicts/gwaei
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/gwaei/ChangeLog,v 1.11 2009/03/03 14:44:45 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gwaei/ChangeLog,v 1.12 2009/03/03 17:14:39 matsuu Exp $
+
+*gwaei-0.15.1-r2 (03 Mar 2009)
+
+ 03 Mar 2009; MATSUU Takuto <matsuu@gentoo.org> +gwaei-0.15.1-r2.ebuild:
+ Removed --disable-gconf.
*gwaei-0.15.1-r1 (02 Mar 2009)
diff --git a/app-dicts/gwaei/gwaei-0.15.1-r2.ebuild b/app-dicts/gwaei/gwaei-0.15.1-r2.ebuild
new file mode 100644
index 000000000000..e2a1c83091fa
--- /dev/null
+++ b/app-dicts/gwaei/gwaei-0.15.1-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gwaei/gwaei-0.15.1-r2.ebuild,v 1.1 2009/03/03 17:14:39 matsuu Exp $
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="Japanese-English Dictionary for GNOME"
+HOMEPAGE="http://gwaei.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gwaei/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome libsexy nls"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=net-misc/curl-7.18
+ >=dev-libs/glib-2.16.5
+ >=gnome-base/gconf-2.22
+ gnome? (
+ >=gnome-base/libgnome-2.22
+ )
+ libsexy? ( >=x11-libs/libsexy-0.1.11 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.17 )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-parallel-install.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable gnome) \
+ $(use_enable libsexy) \
+ $(use_enable nls) \
+ --disable-schemas-install || die
+# $(use_enable gnome gconf) \
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ rm -rf "${D}/usr/share/doc/${P}"
+ dodoc AUTHORS ChangeLog NEWS README
+}
+pkg_preinst() {
+ if use gnome ; then
+ gnome2_gconf_savelist
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+}