summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-11-23 20:15:44 +0000
committerPacho Ramos <pacho@gentoo.org>2014-11-23 20:15:44 +0000
commitd7c7af9c9e5b83c6f025688f2fccc8240964743c (patch)
tree6214fcfc85976a8ece74d3a285f5b78a009e3515 /app-dicts/opendict
parentDeprecate eapis 0 and 1 for gnome2.eclass (#530046) (diff)
downloadgentoo-2-d7c7af9c9e5b83c6f025688f2fccc8240964743c.tar.gz
gentoo-2-d7c7af9c9e5b83c6f025688f2fccc8240964743c.tar.bz2
gentoo-2-d7c7af9c9e5b83c6f025688f2fccc8240964743c.zip
Port to new python eclasses
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-dicts/opendict')
-rw-r--r--app-dicts/opendict/ChangeLog7
-rw-r--r--app-dicts/opendict/opendict-0.6.3-r1.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/app-dicts/opendict/ChangeLog b/app-dicts/opendict/ChangeLog
index 031240c7c270..3f177d703659 100644
--- a/app-dicts/opendict/ChangeLog
+++ b/app-dicts/opendict/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-dicts/opendict
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/ChangeLog,v 1.29 2014/08/10 02:33:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/ChangeLog,v 1.30 2014/11/23 20:15:44 pacho Exp $
+
+*opendict-0.6.3-r1 (23 Nov 2014)
+
+ 23 Nov 2014; Pacho Ramos <pacho@gentoo.org> +opendict-0.6.3-r1.ebuild:
+ Port to new python eclasses
10 Aug 2014; Patrick Lauer <patrick@gentoo.org> opendict-0.6.3.ebuild:
Fix description for more repoman happy
diff --git a/app-dicts/opendict/opendict-0.6.3-r1.ebuild b/app-dicts/opendict/opendict-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..664aaa940d8e
--- /dev/null
+++ b/app-dicts/opendict/opendict-0.6.3-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/opendict-0.6.3-r1.ebuild,v 1.1 2014/11/23 20:15:44 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="no" # We skip gnome2_src_configure entirely
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2 python-single-r1 readme.gentoo
+
+DESCRIPTION="OpenDict is a free cross-platform dictionary program"
+HOMEPAGE="http://opendict.sourceforge.net/"
+SRC_URI="http://opendict.idiles.com/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="If you want system-wide plugins, unzip them into
+${ROOT}usr/share/${PN}/dictionaries/plugins
+
+Some are available from http://opendict.sourceforge.net/?cid=3"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-pyxml.patch
+
+ sed -e "s:), '..')):), '../../../../..', 'share', 'opendict')):g" \
+ -i "${S}/lib/info.py"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # override gnome2_src_configure
+ default
+}
+
+src_compile() {
+ # evil makefile
+ :
+}
+
+src_install() {
+ # makefile is broken, do it manually
+
+ dodir /usr/share/${PN}/dictionaries/plugins # global dictionary plugins folder
+
+ # Needed by GUI
+ insinto /usr/share/${PN}
+ doins "${S}"/copying.html
+
+ insinto /usr/share/${PN}/pixmaps
+ doins "${S}"/pixmaps/*
+
+ DHOME="$(python_get_sitedir)/opendict"
+ insinto "${DHOME}/lib"
+ doins -r "${S}"/lib/*
+ exeinto "${DHOME}"
+ python_fix_shebang opendict.py
+ doexe opendict.py
+
+ dosym "${DHOME}/opendict.py" /usr/bin/opendict
+
+ domenu misc/${PN}.desktop
+
+ insinto /usr/share/icons/hicolor/24x24/apps/
+ newins "${S}/pixmaps/icon-24x24.png" opendict.png
+ insinto /usr/share/icons/hicolor/32x32/apps/
+ newins "${S}/pixmaps/icon-32x32.png" opendict.png
+ insinto /usr/share/icons/hicolor/48x48/apps/
+ newins "${S}/pixmaps/icon-48x48.png" opendict.png
+ insinto /usr/share/icons/hicolor/scalable/apps/
+ newins "${S}/pixmaps/SVG/icon-rune.svg" opendict.svg
+
+ doman opendict.1
+ dodoc README.txt TODO.txt doc/Plugin-HOWTO.html
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}