summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-09-02 18:10:59 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-09-02 18:10:59 +0000
commit3731ff78a21738d5d6a585eb9e3e07fe7d371ca0 (patch)
treeee82b6494c86ce9d5c16a081f272c876e965329c /app-doc/doxygen
parentadded new nodot flag for doxygen (diff)
downloadgentoo-2-3731ff78a21738d5d6a585eb9e3e07fe7d371ca0.tar.gz
gentoo-2-3731ff78a21738d5d6a585eb9e3e07fe7d371ca0.tar.bz2
gentoo-2-3731ff78a21738d5d6a585eb9e3e07fe7d371ca0.zip
updated to latest release, added desktop entry and nodot use flag
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-doc/doxygen')
-rw-r--r--app-doc/doxygen/ChangeLog15
-rw-r--r--app-doc/doxygen/doxygen-1.5.3.ebuild145
-rw-r--r--app-doc/doxygen/files/digest-doxygen-1.5.33
-rw-r--r--app-doc/doxygen/files/doxywizard.pngbin0 -> 4231 bytes
4 files changed, 160 insertions, 3 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index c6d180babe73..2ff2a7081088 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-doc/doxygen
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.130 2007/07/12 19:20:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.131 2007/09/02 18:10:59 nerdboy Exp $
+
+*doxygen-1.5.3 (02 Sep 2007)
+
+ 02 Sep 2007; Steve Arnold <nerdboy@gentoo.org> +files/doxywizard.png,
+ +doxygen-1.5.3.ebuild:
+ Updated to latest release, added desktop entry and nodot use flag
+ (addresses bugs 188124 and 181890). USE=nodot will remove both the
+ graphviz dependency and the capability to generate dot-based graphs.
+ If someone has a better icon for doxywizard, please post a bug :)
12 Jul 2007; Fabian Groffen <grobian@gentoo.org> doxygen-1.4.2.ebuild,
doxygen-1.4.3-r1.ebuild, doxygen-1.4.4.ebuild, doxygen-1.4.5.ebuild,
@@ -32,8 +41,8 @@
*doxygen-1.5.2 (24 Apr 2007)
24 Apr 2007; Steve Arnold <nerdboy@gentoo.org> +doxygen-1.5.2.ebuild:
- updated to latest upstream release, and removed unicode USE flag (russian
- patch incorporate dupstream). Closes bug #174831.
+ updated to latest upstream release, and removed unicode USE flag (ru
+ patch incorporated upstream). Closes bug #174831.
12 Mar 2007; Steve Arnold <nerdboy@gentoo.org> doxygen-1.4.7.ebuild,
doxygen-1.5.1.ebuild:
diff --git a/app-doc/doxygen/doxygen-1.5.3.ebuild b/app-doc/doxygen/doxygen-1.5.3.ebuild
new file mode 100644
index 000000000000..91e122fff053
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.5.3.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.3.ebuild,v 1.1 2007/09/02 18:10:59 nerdboy Exp $
+
+inherit eutils flag-o-matic toolchain-funcs qt3 fdo-mime
+
+DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
+HOMEPAGE="http://www.doxygen.org/"
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc nodot qt3 tetex"
+
+RDEPEND="qt3? ( $(qt_min_version 3.3) )
+ tetex? ( virtual/tetex )
+ virtual/ghostscript
+ !nodot? ( >=media-gfx/graphviz-2.6 )"
+DEPEND=">=sys-apps/sed-4
+ ${RDEPEND}"
+
+EPATCH_SUFFIX="patch"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # use CFLAGS, CXXFLAGS, LDFLAGS
+ sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
+ -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
+ -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
+ tmake/lib/{{linux,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++}/tmake.conf \
+ || die "sed failed"
+
+ # Consolidate patches, apply FreeBSD configure patch, codepage patch,
+ # qtools stuff, and patches for bugs 129142, 121770, and 129560.
+ epatch ${FILESDIR}/${PN}-1.5-legacy-patches.diff
+
+ if is-flagq "-O3" ; then
+ echo
+ ewarn "Compiling with -O3 is known to produce incorrectly"
+ ewarn "optimized code which breaks doxygen."
+ echo
+ epause 6
+ elog "Continuing with -O2 instead ..."
+ echo
+ replace-flags "-O3" "-O2"
+ fi
+}
+
+src_compile() {
+ export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
+ # set ./configure options (prefix, Qt based wizard, docdir)
+
+ if use debug; then
+ local my_conf="--prefix ${D}usr --debug"
+ else
+ local my_conf="--prefix ${D}usr"
+ fi
+
+ if use qt3; then
+ einfo "using QTDIR: '$QTDIR'."
+ export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
+ export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
+ einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
+ einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
+ ./configure ${my_conf} $(use_with qt3 doxywizard) \
+ || die 'configure with qt3 failed'
+ else
+ ./configure ${my_conf} || die 'configure failed'
+ fi
+
+ # and compile
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
+ LINK_SHLIB="$(tc-getCXX)" all || die 'emake failed'
+
+ # generate html and pdf (if tetex in use) documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ if use nodot; then
+ sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
+ {Doxyfile,doc/Doxyfile} || ewarn "disabling dot failed"
+ fi
+ if use tetex; then
+ addwrite /var/cache/fonts
+ addwrite /usr/share/texmf/fonts/pk
+ addwrite /usr/share/texmf/ls-R
+ make pdf || ewarn '"make pdf docs" failed.'
+ else
+ cp doc/Doxyfile doc/Doxyfile.orig
+ cp doc/Makefile doc/Makefile.orig
+ sed -i.orig -e "s/GENERATE_LATEX = YES/GENERATE_LATEX = NO/" \
+ doc/Doxyfile
+ sed -i.orig -e "s/@epstopdf/# @epstopdf/" \
+ -e "s/@cp Makefile.latex/# @cp Makefile.latex/" \
+ -e "s/@sed/# @sed/" doc/Makefile
+ make docs || ewarn '"make html docs" failed.'
+ fi
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ install || die '"make install" failed.'
+
+ if use qt3; then
+ doicon ${FILESDIR}/doxywizard.png
+ make_desktop_entry doxywizard "DoxyWizard ${PV}" \
+ "doxywizard.png" "Application;Development"
+ fi
+
+ dodoc INSTALL LANGUAGE.HOWTO README
+
+ # pdf and html manuals
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ if use tetex; then
+ doins latex/doxygen_manual.pdf
+ fi
+ dohtml -r html/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ elog
+ elog "The USE flags qt, doc, and tetex will enable doxywizard, or"
+ elog "the html and pdf documentation, respectively. For examples"
+ elog "and other goodies, see the source tarball. For some example"
+ elog "output, run doxygen on the doxygen source using the Doxyfile"
+ elog "provided in the top-level source dir."
+ elog
+ elog "Enabling the nodot USE flag will remove the GraphViz dependency,"
+ elog "along with Doxygen's ability to generate diagrams in the docs."
+ elog "See the Doxygen homepage for additional language support tools."
+ elog
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-doc/doxygen/files/digest-doxygen-1.5.3 b/app-doc/doxygen/files/digest-doxygen-1.5.3
new file mode 100644
index 000000000000..311af2831aaa
--- /dev/null
+++ b/app-doc/doxygen/files/digest-doxygen-1.5.3
@@ -0,0 +1,3 @@
+MD5 5fd6f0c2c7946005703b47dc6b663757 doxygen-1.5.3.src.tar.gz 3617278
+RMD160 f5e83a0feae0a53ae5c5733305f86cfa8937dafd doxygen-1.5.3.src.tar.gz 3617278
+SHA256 f0423a198c3183c03f88c16fdaec69c65f29756c893d0c688ac2c670f0d83a0b doxygen-1.5.3.src.tar.gz 3617278
diff --git a/app-doc/doxygen/files/doxywizard.png b/app-doc/doxygen/files/doxywizard.png
new file mode 100644
index 000000000000..c648231e7ea2
--- /dev/null
+++ b/app-doc/doxygen/files/doxywizard.png
Binary files differ