summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2011-05-07 16:37:12 +0000
committerAkinori Hattori <hattya@gentoo.org>2011-05-07 16:37:12 +0000
commitad5f59f52a609c7605ce1219e88634db2d7dde94 (patch)
tree5c5abb1c314c5afd23114799568a7d7f12eb9606 /app-editors/ee
parentarm/ia64/m68k/s390/sh/sparc stable wrt #362025 (diff)
downloadgentoo-2-ad5f59f52a609c7605ce1219e88634db2d7dde94.tar.gz
gentoo-2-ad5f59f52a609c7605ce1219e88634db2d7dde94.tar.bz2
gentoo-2-ad5f59f52a609c7605ce1219e88634db2d7dde94.zip
new upstream release. fixes bug #332729.
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'app-editors/ee')
-rw-r--r--app-editors/ee/ChangeLog8
-rw-r--r--app-editors/ee/ee-1.5.2.ebuild52
-rw-r--r--app-editors/ee/files/ee-init-location.diff42
3 files changed, 101 insertions, 1 deletions
diff --git a/app-editors/ee/ChangeLog b/app-editors/ee/ChangeLog
index f3145ccf21a0..a6d602f001c9 100644
--- a/app-editors/ee/ChangeLog
+++ b/app-editors/ee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/ee
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ee/ChangeLog,v 1.1 2011/05/07 15:46:17 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ee/ChangeLog,v 1.2 2011/05/07 16:37:12 hattya Exp $
+
+*ee-1.5.2 (07 May 2011)
+
+ 07 May 2011; Akinori Hattori <hattya@gentoo.org> +ee-1.5.2.ebuild,
+ +files/ee-init-location.diff:
+ new upstream release. fixes bug #332729.
*ee-1.4.7 (07 May 2011)
*ee-1.4.6 (07 May 2011)
diff --git a/app-editors/ee/ee-1.5.2.ebuild b/app-editors/ee/ee-1.5.2.ebuild
new file mode 100644
index 000000000000..27d1490c6bb2
--- /dev/null
+++ b/app-editors/ee/ee-1.5.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ee/ee-1.5.2.ebuild,v 1.1 2011/05/07 16:37:12 hattya Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+IUSE=""
+
+DESCRIPTION="An easy to use text editor. A subset of aee."
+HOMEPAGE="http://mahon.cwx.net/"
+SRC_URI="http://mahon.cwx.net/sources/${P}.src.tgz"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+S="${WORKDIR}/easyedit-${PV}"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${PN}-*.diff
+
+ sed -i \
+ -e "s/make -/\$(MAKE) -/g" \
+ -e "/^buildee/s/$/ localmake/" \
+ Makefile \
+ || die
+
+ sed -i \
+ -e "s/\tcc /\t\\\\\$(CC) /" \
+ -e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
+ -e "/other_cflag/s/ *-s//" \
+ create.make \
+ || die
+
+}
+
+src_compile() {
+
+ emake CC="$(tc-getCC)" || die
+
+}
+
+src_install() {
+
+ dobin ee
+ doman ee.1
+ dodoc Changes README.ee ee.i18n.guide ee.msg
+ dodir /usr/share/${PN}
+
+}
diff --git a/app-editors/ee/files/ee-init-location.diff b/app-editors/ee/files/ee-init-location.diff
new file mode 100644
index 000000000000..c623bcdba807
--- /dev/null
+++ b/app-editors/ee/files/ee-init-location.diff
@@ -0,0 +1,42 @@
+diff -ur easyedit-1.5.2.orig/ee.1 easyedit-1.5.2/ee.1
+--- easyedit-1.5.2.orig/ee.1
++++ easyedit-1.5.2/ee.1
+@@ -406,7 +406,7 @@
+ .PP
+ Since different users have different preferences, \fIee\fR allows some
+ slight configurability. There are three possible locations for an
+-initialization file for ee: the file \fI/usr/local/lib/init.ee\fR, the
++initialization file for ee: the file \fI/usr/share/ee/init.ee\fR, the
+ file \fI.init.ee\fR in the user's home directory, or the file \fI.init.ee\fR
+ in the current directory (if different from the home
+ directory). This allows system administrators to set some preferences for
+@@ -414,7 +414,7 @@
+ and the user to customize settings for particular directories (like one
+ for correspondence, and a different directory for programming).
+ .PP
+-The file \fI\/usr/local/lib/init.ee\fR is read first, then
++The file \fI\/usr/share/ee/init.ee\fR is read first, then
+ \fI$HOME/.init.ee\fR, then \fI.init.ee\fR, with the settings specified by the
+ most recent file read taking precedence.
+ .PP
+@@ -521,7 +521,7 @@
+ may be too slow for slower systems.
+ .SH FILES
+ .PP
+-.I /usr/local/lib/init.ee
++.I /usr/share/ee/init.ee
+ .br
+ .I $HOME/.init.ee
+ .br
+diff -ur easyedit-1.5.2.orig/ee.c easyedit-1.5.2/ee.c
+--- easyedit-1.5.2.orig/ee.c
++++ easyedit-1.5.2/ee.c
+@@ -4124,7 +4124,7 @@
+ }
+
+ unsigned char *init_name[3] = {
+- "/usr/local/lib/init.ee",
++ "/usr/share/ee/init.ee",
+ NULL,
+ ".init.ee"
+ };