summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Tolboom <ryan@gentoo.org>2001-05-15 01:49:44 +0000
committerRyan Tolboom <ryan@gentoo.org>2001-05-15 01:49:44 +0000
commite7ad96188a0f532bc8b2492abfc6bf53a155bf8e (patch)
treece731c5c1a9c33e538a334299ce6143d785fd12a /app-editors/elvis
parentupdated db-3.2.3h-r2 to r3, fixed a libtool issue (diff)
downloadgentoo-2-e7ad96188a0f532bc8b2492abfc6bf53a155bf8e.tar.gz
gentoo-2-e7ad96188a0f532bc8b2492abfc6bf53a155bf8e.tar.bz2
gentoo-2-e7ad96188a0f532bc8b2492abfc6bf53a155bf8e.zip
*** empty log message ***
Diffstat (limited to 'app-editors/elvis')
-rw-r--r--app-editors/elvis/elvis-2.1.4.ebuild42
-rw-r--r--app-editors/elvis/files/digest-elvis-2.1.41
2 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/elvis/elvis-2.1.4.ebuild b/app-editors/elvis/elvis-2.1.4.ebuild
new file mode 100644
index 000000000000..1422983d577b
--- /dev/null
+++ b/app-editors/elvis/elvis-2.1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ryan Tolboom <ryan@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4.ebuild,v 1.1 2001/05/15 01:49:44 ryan Exp $
+
+A=elvis-2.1_4.tar.gz
+S=${WORKDIR}/elvis-2.1_4
+DESCRIPTION="A vi/ex clone"
+SRC_URI="ftp://ftp.cs.pdx.edu/pub/elvis/${A}"
+HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ X? ( virtual/x11 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use X`" ]; then
+ mconf="--with-x"
+ else
+ mconf="--without-x"
+ fi
+ try ./configure --bindir=${D}/usr/bin --datadir=${D}/usr/share/elvis ${myconf}
+ cp Makefile Makefile.orig
+ cat Makefile.orig | sed -e "s:gcc -O2:gcc ${CFLAGS}:" > Makefile
+ try make
+
+}
+
+src_install () {
+
+ cp instman.sh instman.sh.orig
+ cat instman.sh.orig | sed -e "s:/usr/man:${D}/usr/share/man:g" > instman.sh
+ cp insticon.sh insticon.sh.orig
+ cat insticon.sh.orig | sed -e "s:^xinc=.*$:xinc=${D}/usr/include:" \
+ | sed -e "s:^xlib=.*$:xlib=${D}/usr/lib:" > insticon.sh
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ try make install
+
+}
diff --git a/app-editors/elvis/files/digest-elvis-2.1.4 b/app-editors/elvis/files/digest-elvis-2.1.4
new file mode 100644
index 000000000000..b87166ae8699
--- /dev/null
+++ b/app-editors/elvis/files/digest-elvis-2.1.4
@@ -0,0 +1 @@
+MD5 b5a5040899bdc197e9ccc70a561a6676 elvis-2.1_4.tar.gz