summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-22 23:29:49 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-22 23:29:49 +0000
commit3b034f0c997b4ae2934c6d732defb6e2388cda92 (patch)
tree99eec6cff5eb11cb54fdf37c23cf8e576ebb2f96 /app-editors/gedit-plugins
parentVersion bump with assorted bugfixes and UI improvements. (diff)
downloadgentoo-2-3b034f0c997b4ae2934c6d732defb6e2388cda92.tar.gz
gentoo-2-3b034f0c997b4ae2934c6d732defb6e2388cda92.tar.bz2
gentoo-2-3b034f0c997b4ae2934c6d732defb6e2388cda92.zip
Version bump with a new dashboard plugin and various fixes. Always install synctex plugin when USE=python. Modernize ebuild (REQUIRED_USE, python_clean_py-compile_files).
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/ChangeLog10
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.4.0.ebuild93
2 files changed, 102 insertions, 1 deletions
diff --git a/app-editors/gedit-plugins/ChangeLog b/app-editors/gedit-plugins/ChangeLog
index 3b5dd970d8d6..0c4efdb88045 100644
--- a/app-editors/gedit-plugins/ChangeLog
+++ b/app-editors/gedit-plugins/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/gedit-plugins
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.22 2012/01/13 17:41:16 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/ChangeLog,v 1.23 2012/04/22 23:29:49 tetromino Exp $
+
+*gedit-plugins-3.4.0 (22 Apr 2012)
+
+ 22 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gedit-plugins-3.4.0.ebuild:
+ Version bump with a new dashboard plugin and various fixes. Always install
+ synctex plugin when USE=python. Modernize ebuild (REQUIRED_USE,
+ python_clean_py-compile_files).
13 Jan 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
gedit-plugins-3.2.1-r1.ebuild:
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.4.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.4.0.ebuild
new file mode 100644
index 000000000000..ebbc5bafede0
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-3.4.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit-plugins/gedit-plugins-3.4.0.ebuild,v 1.1 2012/04/22 23:29:49 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_DEPEND="python? 2:2.6"
+PYTHON_USE_WITH="xml"
+PYTHON_USE_WITH_OPT="python"
+
+inherit gnome2 multilib python eutils
+
+DESCRIPTION="Offical plugins for gedit"
+HOMEPAGE="http://live.gnome.org/GeditPlugins"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE_plugins="charmap terminal"
+IUSE="+python ${IUSE_plugins}"
+REQUIRED_USE="charmap? ( python ) terminal? ( python )"
+
+RDEPEND=">=app-editors/gedit-3.2.1[python?]
+ >=dev-libs/glib-2.26.0:2
+ >=dev-libs/libpeas-0.7.3[gtk,python?]
+ >=x11-libs/gtk+-3.0.0:3
+ >=x11-libs/gtksourceview-3.0.0:3.0
+ python? (
+ >=app-editors/gedit-3.0.0[introspection]
+ dev-python/dbus-python
+ dev-python/pycairo
+ || (
+ dev-python/pygobject:2[cairo,introspection]
+ dev-python/pygobject:3[cairo] )
+ >=x11-libs/gtk+-3.3.16:3[introspection]
+ >=x11-libs/gtksourceview-3.0.0:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3.0.0:2.90[introspection] )
+ terminal? ( x11-libs/vte:2.90[introspection] )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.0
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ # DEFAULT_PLUGINS from configure.ac
+ local myplugins="bookmarks,drawspaces,wordcompletion,taglist"
+
+ # python plugins with no extra dependencies beyond what USE=python brings
+ use python && myplugins="${myplugins},bracketcompletion,codecomment,colorpicker,commander,dashboard,joinlines,multiedit,textsize,sessionsaver,smartspaces,synctex"
+
+ # python plugins with extra dependencies
+ for plugin in ${IUSE_plugins/+}; do
+ use ${plugin} && myplugins="${myplugins},${plugin}"
+ done
+
+ DOCS="AUTHORS ChangeLog* NEWS README"
+
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ --disable-dependency-tracking
+ --with-plugins=${myplugins}
+ $(use_enable python)"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ use python && python_clean_py-compile_files
+}
+
+src_test() {
+ emake check
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+ python_mod_optimize /usr/{$(get_libdir),share}/gedit/plugins
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/{$(get_libdir),share}/gedit/plugins
+}