summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-27 20:25:59 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-27 20:25:59 +0000
commit55df140088c48d6e2e5ec7c6852d23ec92c36c4f (patch)
treefd865ab6c964ab7736eb26a9a5e8a31c589eca95 /app-editors/gedit/gedit-2.18.0.ebuild
parentStable on amd64 wrt bug 170650 (diff)
downloadgentoo-2-55df140088c48d6e2e5ec7c6852d23ec92c36c4f.tar.gz
gentoo-2-55df140088c48d6e2e5ec7c6852d23ec92c36c4f.tar.bz2
gentoo-2-55df140088c48d6e2e5ec7c6852d23ec92c36c4f.zip
gnome 2.18.0
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-editors/gedit/gedit-2.18.0.ebuild')
-rw-r--r--app-editors/gedit/gedit-2.18.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-editors/gedit/gedit-2.18.0.ebuild b/app-editors/gedit/gedit-2.18.0.ebuild
new file mode 100644
index 000000000000..f4cff7b5632f
--- /dev/null
+++ b/app-editors/gedit/gedit-2.18.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.18.0.ebuild,v 1.1 2007/03/27 20:25:59 dang Exp $
+
+inherit gnome2
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc spell"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=dev-libs/glib-2.12
+ >=x11-libs/gtk+-2.10
+ >=x11-libs/gtksourceview-1.8.0
+ >=gnome-base/libgnomeui-2.16
+ >=gnome-base/libglade-2.5.1
+ >=gnome-base/libgnomeprintui-2.12.1
+ >=gnome-base/gnome-vfs-2.16
+ spell? (
+ >=app-text/enchant-1.2
+ app-text/iso-codes
+ )
+ >=dev-python/pygtk-2.9.7
+ >=dev-python/pygobject-2.11.5
+ >=dev-python/gnome-python-desktop-2.15.90"
+# FIXME: Doesn't build without python
+# FIXME : spell autodetect only
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=app-text/scrollkeeper-0.3.11
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.3.2"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README THANKS TODO"
+
+if [[ "${ARCH}" == "PPC" ]] ; then
+ # HACK HACK HACK: someone fix this garbage
+ MAKEOPTS="${MAKEOPTS} -j1"
+fi
+