summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-07-05 12:35:37 +0000
committerPacho Ramos <pacho@gentoo.org>2010-07-05 12:35:37 +0000
commit196cfd6128794c03821aaf9b4ec23410e16f34ed (patch)
tree1be7a1d1babb1e0f4f56fcb9cd3f6158e7be2308 /app-editors/gedit
parentUpstream patch for #291279 (diff)
downloadgentoo-2-196cfd6128794c03821aaf9b4ec23410e16f34ed.tar.gz
gentoo-2-196cfd6128794c03821aaf9b4ec23410e16f34ed.tar.bz2
gentoo-2-196cfd6128794c03821aaf9b4ec23410e16f34ed.zip
Fix tests: Do not fail if remote mounting is not supported (bug #323659)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/ChangeLog6
-rw-r--r--app-editors/gedit/files/gedit-2.30.2-tests-skip.patch49
-rw-r--r--app-editors/gedit/gedit-2.30.2.ebuild7
3 files changed, 59 insertions, 3 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index 0989835aff3a..7a69c41c0583 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.303 2010/06/13 19:34:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.304 2010/07/05 12:35:36 pacho Exp $
+
+ 05 Jul 2010; Pacho Ramos <pacho@gentoo.org> gedit-2.30.2.ebuild,
+ +files/gedit-2.30.2-tests-skip.patch:
+ Fix tests: Do not fail if remote mounting is not supported (bug #323659)
*gedit-2.30.2 (13 Jun 2010)
diff --git a/app-editors/gedit/files/gedit-2.30.2-tests-skip.patch b/app-editors/gedit/files/gedit-2.30.2-tests-skip.patch
new file mode 100644
index 000000000000..4bec6c9c78d0
--- /dev/null
+++ b/app-editors/gedit/files/gedit-2.30.2-tests-skip.patch
@@ -0,0 +1,49 @@
+From 3c6753513bfafd59f87c192f39a1f1caf7fce47f Mon Sep 17 00:00:00 2001
+From: Ignacio Casal Quinteiro <icq@gnome.org>
+Date: Tue, 29 Jun 2010 14:58:30 +0000
+Subject: Do not fail if remote mounting is not supported. Fixes bug #621764.
+
+---
+diff --git a/tests/document-saver.c b/tests/document-saver.c
+index ef97fe6..c99b678 100644
+--- a/tests/document-saver.c
++++ b/tests/document-saver.c
+@@ -151,6 +151,10 @@ mount_ready_callback (GObject *object,
+ mount_success = TRUE;
+ g_error_free (error);
+ }
++ else if (error && error->code == G_IO_ERROR_NOT_SUPPORTED)
++ {
++ g_error_free (error);
++ }
+ else
+ {
+ g_assert_no_error (error);
+@@ -220,7 +224,11 @@ test_saver (const gchar *filename_or_uri,
+ file = g_file_new_for_commandline_arg (filename_or_uri);
+ existed = g_file_query_exists (file, NULL);
+
+- ensure_mounted (file);
++ if (!ensure_mounted (file))
++ {
++ saver_test_data_free (data);
++ return;
++ }
+
+ gedit_document_save_as (document, file, gedit_encoding_get_utf8 (),
+ newline_type, 0, save_flags);
+@@ -409,6 +417,12 @@ test_permissions (const gchar *uri,
+ g_file_delete (file, NULL, NULL);
+ stream = g_file_create (file, 0, NULL, &error);
+
++ if (error && error->code == G_IO_ERROR_NOT_SUPPORTED)
++ {
++ g_error_free (error);
++ return;
++ }
++
+ g_assert_no_error (error);
+
+ g_output_stream_close (G_OUTPUT_STREAM (stream), NULL, NULL);
+--
+cgit v0.8.3.1
diff --git a/app-editors/gedit/gedit-2.30.2.ebuild b/app-editors/gedit/gedit-2.30.2.ebuild
index fbb38ab06900..a074ff686106 100644
--- a/app-editors/gedit/gedit-2.30.2.ebuild
+++ b/app-editors/gedit/gedit-2.30.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.30.2.ebuild,v 1.1 2010/06/13 19:34:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.30.2.ebuild,v 1.2 2010/07/05 12:35:36 pacho Exp $
GCONF_DEBUG="no"
-inherit gnome2 python
+inherit gnome2 python eutils
DESCRIPTION="A text editor for the GNOME desktop"
HOMEPAGE="http://www.gnome.org/"
@@ -58,6 +58,9 @@ pkg_setup() {
src_unpack() {
gnome2_src_unpack
+ # Do not fail if remote mounting is not supported.
+ epatch "${FILESDIR}/${P}-tests-skip.patch"
+
# disable pyc compiling
mv "${S}"/py-compile "${S}"/py-compile.orig
ln -s $(type -P true) "${S}"/py-compile