summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-01-05 08:17:07 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-01-05 08:17:07 +0000
commit5b644239c77d519fbea702010fe983ef6051a73b (patch)
tree086fa93439a68b1ce1c7e700be6d02b288c8412d /app-editors/gedit
parentFix underlinking failure (bug #497108, thanks to d_dart). (diff)
downloadgentoo-2-5b644239c77d519fbea702010fe983ef6051a73b.tar.gz
gentoo-2-5b644239c77d519fbea702010fe983ef6051a73b.tar.bz2
gentoo-2-5b644239c77d519fbea702010fe983ef6051a73b.zip
Fix underlinking failure (bug #497110, thanks to d_dart).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/ChangeLog8
-rw-r--r--app-editors/gedit/files/gedit-2.30.4-underlinking.patch20
-rw-r--r--app-editors/gedit/gedit-2.30.4.ebuild24
3 files changed, 38 insertions, 14 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index 8ab7f7c7c27a..a76fc2b6ad7e 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/gedit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.361 2013/12/24 15:28:59 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.362 2014/01/05 08:17:07 tetromino Exp $
+
+ 05 Jan 2014; Alexandre Rostovtsev <tetromino@gentoo.org> gedit-2.30.4.ebuild,
+ +files/gedit-2.30.4-underlinking.patch:
+ Fix underlinking failure (bug #497110, thanks to d_dart).
*gedit-3.10.3 (24 Dec 2013)
diff --git a/app-editors/gedit/files/gedit-2.30.4-underlinking.patch b/app-editors/gedit/files/gedit-2.30.4-underlinking.patch
new file mode 100644
index 000000000000..3fb2e727eb6e
--- /dev/null
+++ b/app-editors/gedit/files/gedit-2.30.4-underlinking.patch
@@ -0,0 +1,20 @@
+diff --git a/configure.ac b/configure.ac
+index 78a8055..c80651b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -272,6 +272,7 @@ PKG_CHECK_MODULES(GEDIT, [
+ glib-2.0 >= 2.22.0
+ gthread-2.0 >= 2.13.0
+ gio-2.0 >= 2.23.1
++ gmodule-2.0 >= 2.23.1
+ gtk+-2.0 >= 2.16.0
+ gtksourceview-2.0 >= 2.9.7
+ gconf-2.0 >= 1.1.11
+@@ -320,6 +321,7 @@ if test "$os_osx" = "no" &&
+ test "$os_win32" = "no"; then
+ PKG_CHECK_MODULES(EGG_SMCLIENT, [
+ sm >= 1.0.0
++ ice
+ ])
+ else
+ EGG_SMCLIENT_CFLAGS=
diff --git a/app-editors/gedit/gedit-2.30.4.ebuild b/app-editors/gedit/gedit-2.30.4.ebuild
index 18f6ea34e6a4..8e2161eb42f5 100644
--- a/app-editors/gedit/gedit-2.30.4.ebuild
+++ b/app-editors/gedit/gedit-2.30.4.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.30.4.ebuild,v 1.13 2012/05/03 18:33:00 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.30.4.ebuild,v 1.14 2014/01/05 08:17:07 tetromino Exp $
EAPI="3"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
PYTHON_DEPEND="python? 2:2.5"
-inherit gnome2 multilib python eutils
+inherit autotools gnome2 multilib python eutils
DESCRIPTION="A text editor for the GNOME desktop"
HOMEPAGE="http://live.gnome.org/Gedit"
@@ -58,23 +59,22 @@ pkg_setup() {
}
src_prepare() {
- gnome2_src_prepare
-
# Do not fail if remote mounting is not supported.
epatch "${FILESDIR}/${PN}-2.30.2-tests-skip.patch"
+ # Underlinking for gmodule and libICE, bug #497110
+ epatch "${FILESDIR}/${P}-underlinking.patch"
+
+ rm missing || die # old missing file causes autoreconf warnings
+ eautoreconf
+
+ gnome2_src_prepare
+
# disable pyc compiling
mv "${S}"/py-compile "${S}"/py-compile.orig
ln -s $(type -P true) "${S}"/py-compile
}
-src_install() {
- gnome2_src_install
-
- # Installed for plugins, but they're dlopen()-ed
- find "${D}" -name "*.la" -delete || die "remove of la files failed"
-}
-
pkg_postinst() {
gnome2_pkg_postinst
use python && python_mod_optimize /usr/$(get_libdir)/gedit-2/plugins