summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-17 21:45:24 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-17 21:45:24 +0000
commitdb1dd1557227f09d256f9927f00845ecee4f97bf (patch)
treeebf59482e143e0b2cb205115093b63e095008054 /app-editors/gedit
parentCreate a real new version rather than mucking with the FILESDIR. (diff)
downloadgentoo-2-db1dd1557227f09d256f9927f00845ecee4f97bf.tar.gz
gentoo-2-db1dd1557227f09d256f9927f00845ecee4f97bf.tar.bz2
gentoo-2-db1dd1557227f09d256f9927f00845ecee4f97bf.zip
Bump to 2.26.2. Small bug fixes and translation updates.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/ChangeLog7
-rw-r--r--app-editors/gedit/gedit-2.26.2.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/app-editors/gedit/ChangeLog b/app-editors/gedit/ChangeLog
index c49e684f02b0..0df634b98d0d 100644
--- a/app-editors/gedit/ChangeLog
+++ b/app-editors/gedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gedit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.273 2009/05/14 21:46:45 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.274 2009/05/17 21:45:24 eva Exp $
+
+*gedit-2.26.2 (17 May 2009)
+
+ 17 May 2009; Gilles Dartiguelongue <eva@gentoo.org> +gedit-2.26.2.ebuild:
+ Bump to 2.26.2. Small bug fixes and translation updates.
14 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
-files/gedit-2.18.1-fbsd.patch, -gedit-2.20.3.ebuild,
diff --git a/app-editors/gedit/gedit-2.26.2.ebuild b/app-editors/gedit/gedit-2.26.2.ebuild
new file mode 100644
index 000000000000..e515ebb56fa3
--- /dev/null
+++ b/app-editors/gedit/gedit-2.26.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.26.2.ebuild,v 1.1 2009/05/17 21:45:24 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2 python
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc python spell xattr"
+
+RDEPEND=">=gnome-base/gconf-2
+ xattr? ( sys-apps/attr )
+ >=x11-libs/libSM-1.0
+ >=dev-libs/libxml2-2.5.0
+ >=dev-libs/glib-2.18
+ >=x11-libs/gtk+-2.15
+ >=x11-libs/gtksourceview-2.5
+ spell? (
+ >=app-text/enchant-1.2
+ >=app-text/iso-codes-0.35
+ )
+ python? (
+ >=dev-python/pygobject-2.15.4
+ >=dev-python/pygtk-2.12
+ >=dev-python/pygtksourceview-2.2
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ >=app-text/scrollkeeper-0.3.11
+ >=app-text/gnome-doc-utils-0.3.2
+ ~app-text/docbook-xml-dtd-4.1.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+# gnome-common and gtk-doc-am needed to eautoreconf
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+if [[ "${ARCH}" == "PPC" ]] ; then
+ # HACK HACK HACK: someone fix this garbage
+ MAKEOPTS="${MAKEOPTS} -j1"
+fi
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ $(use_enable python)
+ $(use_enable spell)
+ $(use_enable xattr attr)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use python && python_mod_optimize /usr/$(get_libdir)/gedit-2/plugins
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/gedit-2/plugins
+}