summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-12-02 05:40:50 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-12-02 05:40:50 +0000
commit7c9c0065f82876d1292ee22cdaf2904f8d98234b (patch)
tree9b545e615f77b1eca04b3884d6e7f8d739d19491 /app-editors/leo/leo-4.2.ebuild
parentVersion bump #71588. (Manifest recommit) (diff)
downloadgentoo-2-7c9c0065f82876d1292ee22cdaf2904f8d98234b.tar.gz
gentoo-2-7c9c0065f82876d1292ee22cdaf2904f8d98234b.tar.bz2
gentoo-2-7c9c0065f82876d1292ee22cdaf2904f8d98234b.zip
Initial commit. Closes bug# 69561
Diffstat (limited to 'app-editors/leo/leo-4.2.ebuild')
-rw-r--r--app-editors/leo/leo-4.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-editors/leo/leo-4.2.ebuild b/app-editors/leo/leo-4.2.ebuild
new file mode 100644
index 000000000000..669777d67a30
--- /dev/null
+++ b/app-editors/leo/leo-4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.2.ebuild,v 1.1 2004/12/02 05:40:50 pythonhead Exp $
+
+inherit eutils python
+
+MY_P=${P}-final
+DESCRIPTION="Leo is an outlining editor and literate programming tool."
+HOMEPAGE="http://leo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/leo/${MY_P}.zip"
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/python
+ dev-lang/tk"
+S=${WORKDIR}/${MY_P}
+
+
+src_unpack() {
+ unpack ${A} || die "Failed to unpack ${A}"
+ cd ${S} || die "Failed to cd ${S}"
+ epatch ${FILESDIR}/leoConfig.py.patch || \
+ die "epatch failed on leoConfig.py.patch"
+}
+
+src_install() {
+ python_version
+ INST_DIR=/usr/lib/python${PYVER}/site-packages/leo
+ dodir ${INST_DIR}
+ dodir /usr/bin
+ dodoc ${S}/PKG-INFO MANIFEST doc/*
+ rm -rf PKG-INFO MANIFEST doc/*
+ cp -r * ${D}/${INST_DIR}/
+ echo "#!/bin/bash" > leo
+ echo "exec /usr/bin/python ${INST_DIR}/src/leo.py \"\$1\"" >> leo
+ exeinto /usr/bin
+ doexe leo
+}