summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2007-07-15 15:17:21 +0000
committerPeter Weller <welp@gentoo.org>2007-07-15 15:17:21 +0000
commit4ba661063b4927aec7b6cc12e951be7394403028 (patch)
treeeb5013d5cb3b3e444977665037412ad0e2dd6800 /app-editors/tea
parentStable on ppc wrt bug 184561 (diff)
downloadgentoo-2-4ba661063b4927aec7b6cc12e951be7394403028.tar.gz
gentoo-2-4ba661063b4927aec7b6cc12e951be7394403028.tar.bz2
gentoo-2-4ba661063b4927aec7b6cc12e951be7394403028.zip
Bump
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/files/digest-tea-17.0.23
-rw-r--r--app-editors/tea/tea-17.0.2.ebuild66
2 files changed, 69 insertions, 0 deletions
diff --git a/app-editors/tea/files/digest-tea-17.0.2 b/app-editors/tea/files/digest-tea-17.0.2
new file mode 100644
index 000000000000..5e356fa99cf9
--- /dev/null
+++ b/app-editors/tea/files/digest-tea-17.0.2
@@ -0,0 +1,3 @@
+MD5 846a9af42472ad498dadbb38867e5639 tea-17.0.2.tar.bz2 436862
+RMD160 9d2e0e11126ed501e3fca62c19e40d9d9f4d9f37 tea-17.0.2.tar.bz2 436862
+SHA256 6b5f55850eb10744dc1bcedbefee2c81fa38520433579a87c35c9784b566ac39 tea-17.0.2.tar.bz2 436862
diff --git a/app-editors/tea/tea-17.0.2.ebuild b/app-editors/tea/tea-17.0.2.ebuild
new file mode 100644
index 000000000000..8d698296190f
--- /dev/null
+++ b/app-editors/tea/tea-17.0.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-17.0.2.ebuild,v 1.1 2007/07/15 15:17:21 welp Exp $
+
+inherit eutils
+
+DESCRIPTION="Small, lightweight GTK+ text editor"
+HOMEPAGE="http://tea-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="enchant gnome hacking ipv6 sounds spell"
+
+RDEPEND="x11-libs/gtk+
+ gnome? ( x11-libs/gtksourceview
+ gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+ sounds? ( media-libs/gstreamer )
+ spell? ( app-text/aspell )
+ enchant? ( app-text/enchant )
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf
+
+ if use sounds; then
+ myconf="${myconf} --enable-sounds"
+ fi
+ if use hacking; then
+ myconf="${myconf} --enable-hacking"
+ fi
+ if ! use gnome; then
+ myconf="${myconf} --enable-legacy"
+ fi
+ if use enchant; then
+ myconf="${myconf} --enable-enchant"
+ fi
+
+ econf \
+ $(use_enable ipv6) \
+ ${myconf} || die "econf failed!"
+
+ emake || die "emake failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed!"
+
+ make_desktop_entry tea Tea /usr/share/tea/pixmaps/tea_icon_v2.png Development
+
+# insinto /usr/share/doc/tea/
+# doins AUTHORS COPYING NEWS README TODO ChangeLog doc/*
+
+# insinto /usr/share/pixmaps/
+# doins pixmaps/*
+}
+
+pkg_postinst() {
+ if use spell ; then
+ elog "To get full spellchecking functuality, ensure that you install"
+ elog "the relevant language pack(s)"
+ fi
+}