summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-16 12:20:28 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-16 12:20:28 +0000
commit9b9eef4b1a456fb9e919a15b567be1a5758ea40a (patch)
treeeee0488173b4d20e2460da616330f4fe7ab9ea6e /app-editors/vim-qt
parentCall python_fix_shebang only when python_setup was called (diff)
downloadgentoo-2-9b9eef4b1a456fb9e919a15b567be1a5758ea40a.tar.gz
gentoo-2-9b9eef4b1a456fb9e919a15b567be1a5758ea40a.tar.bz2
gentoo-2-9b9eef4b1a456fb9e919a15b567be1a5758ea40a.zip
Fix Python support, use python-single-r1 since the package links to a specific version of Python.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-editors/vim-qt')
-rw-r--r--app-editors/vim-qt/ChangeLog10
-rw-r--r--app-editors/vim-qt/vim-qt-20130201-r1.ebuild (renamed from app-editors/vim-qt/vim-qt-20130201.ebuild)8
-rw-r--r--app-editors/vim-qt/vim-qt-20130220-r1.ebuild (renamed from app-editors/vim-qt/vim-qt-20130220.ebuild)8
3 files changed, 19 insertions, 7 deletions
diff --git a/app-editors/vim-qt/ChangeLog b/app-editors/vim-qt/ChangeLog
index 552fb65c85e0..56bfac12fd6e 100644
--- a/app-editors/vim-qt/ChangeLog
+++ b/app-editors/vim-qt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/vim-qt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/ChangeLog,v 1.4 2013/09/05 18:18:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/ChangeLog,v 1.5 2013/10/16 12:20:28 mgorny Exp $
+
+*vim-qt-20130201-r1 (16 Oct 2013)
+*vim-qt-20130220-r1 (16 Oct 2013)
+
+ 16 Oct 2013; Michał Górny <mgorny@gentoo.org> +vim-qt-20130201-r1.ebuild,
+ +vim-qt-20130220-r1.ebuild, -vim-qt-20130201.ebuild, -vim-qt-20130220.ebuild:
+ Fix Python support, use python-single-r1 since the package links to a specific
+ version of Python.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> vim-qt-20130201.ebuild,
vim-qt-20130220.ebuild:
diff --git a/app-editors/vim-qt/vim-qt-20130201.ebuild b/app-editors/vim-qt/vim-qt-20130201-r1.ebuild
index 4d26c04d5f0c..c07d68823d44 100644
--- a/app-editors/vim-qt/vim-qt-20130201.ebuild
+++ b/app-editors/vim-qt/vim-qt-20130201-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/vim-qt-20130201.ebuild,v 1.3 2013/09/05 18:18:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/vim-qt-20130201-r1.ebuild,v 1.1 2013/10/16 12:20:28 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
PYTHON_REQ_USE="threads"
-inherit eutils fdo-mime flag-o-matic python-any-r1
+inherit eutils fdo-mime flag-o-matic python-single-r1
DESCRIPTION="Qt GUI version of the Vim text editor"
HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/wiki/Home"
@@ -40,9 +40,11 @@ RDEPEND="app-admin/eselect-vi
ruby? ( || ( dev-lang/ruby:1.9 dev-lang/ruby:1.8 ) )"
DEPEND="${RDEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
pkg_setup() {
export LC_COLLATE="C" # prevent locale brokenness bug #82186
- use python && python-any-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
}
src_configure() {
diff --git a/app-editors/vim-qt/vim-qt-20130220.ebuild b/app-editors/vim-qt/vim-qt-20130220-r1.ebuild
index bd247cfe2659..840a3125767e 100644
--- a/app-editors/vim-qt/vim-qt-20130220.ebuild
+++ b/app-editors/vim-qt/vim-qt-20130220-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/vim-qt-20130220.ebuild,v 1.3 2013/09/05 18:18:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/vim-qt-20130220-r1.ebuild,v 1.1 2013/10/16 12:20:28 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
PYTHON_REQ_USE="threads"
-inherit eutils fdo-mime flag-o-matic python-any-r1
+inherit eutils fdo-mime flag-o-matic python-single-r1
DESCRIPTION="Qt GUI version of the Vim text editor"
HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/wiki/Home"
@@ -40,9 +40,11 @@ RDEPEND="app-admin/eselect-vi
ruby? ( || ( dev-lang/ruby:1.9 dev-lang/ruby:1.8 ) )"
DEPEND="${RDEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
pkg_setup() {
export LC_COLLATE="C" # prevent locale brokenness bug #82186
- use python && python-any-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
}
src_configure() {