summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-06-27 03:54:39 +0000
committerBen de Groot <yngwin@gentoo.org>2015-06-27 03:54:39 +0000
commit28e69bd649c597aef52849b493779e03d9463e4e (patch)
treef38338bb14aa8b2e532dd77ef578927e2f375fd7 /app-editors
parentversion bump (diff)
downloadgentoo-2-28e69bd649c597aef52849b493779e03d9463e4e.tar.gz
gentoo-2-28e69bd649c597aef52849b493779e03d9463e4e.tar.bz2
gentoo-2-28e69bd649c597aef52849b493779e03d9463e4e.zip
new development snapshot
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/ChangeLog8
-rw-r--r--app-editors/neovim/neovim-0.0.0_pre20150627.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/app-editors/neovim/ChangeLog b/app-editors/neovim/ChangeLog
index 0459271695c5..b95b2bb82fd4 100644
--- a/app-editors/neovim/ChangeLog
+++ b/app-editors/neovim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/neovim
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/neovim/ChangeLog,v 1.4 2015/06/05 12:13:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/neovim/ChangeLog,v 1.5 2015/06/27 03:54:39 yngwin Exp $
+
+*neovim-0.0.0_pre20150627 (27 Jun 2015)
+
+ 27 Jun 2015; Ben de Groot <yngwin@gentoo.org>
+ +neovim-0.0.0_pre20150627.ebuild:
+ new development snapshot
05 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/app-editors/neovim/neovim-0.0.0_pre20150627.ebuild b/app-editors/neovim/neovim-0.0.0_pre20150627.ebuild
new file mode 100644
index 000000000000..a4aa850da23d
--- /dev/null
+++ b/app-editors/neovim/neovim-0.0.0_pre20150627.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/neovim/neovim-0.0.0_pre20150627.ebuild,v 1.1 2015/06/27 03:54:39 yngwin Exp $
+
+EAPI=5
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Vim's rebirth for the 21st century"
+HOMEPAGE="https://github.com/neovim/neovim"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/neovim/neovim.git"
+else
+ SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="perl python"
+
+CDEPEND="dev-lang/luajit:2
+ >=dev-libs/libtermkey-0.17
+ dev-libs/libvterm-neovim
+ >=dev-libs/unibilium-1.1.1
+ >=dev-libs/libuv-1.2.0
+ >=dev-libs/msgpack-0.6.0_pre20150220
+ dev-lua/lpeg
+ dev-lua/messagepack"
+DEPEND="${CDEPEND}
+ virtual/libiconv
+ virtual/libintl"
+RDEPEND="${CDEPEND}
+ perl? ( dev-lang/perl )
+ python? ( dev-python/neovim-python-client )"
+
+src_prepare() {
+ # use our system vim dir
+ sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
+ -i src/nvim/os_unix_defs.h || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ export USE_BUNDLED_DEPS=OFF
+ append-cflags "-Wno-error"
+ append-cppflags "-DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DLIBUNIBILIUM_USE_STATIC=OFF
+ -DLIBTERMKEY_USE_STATIC=OFF
+ -DLIBVTERM_USE_STATIC=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ # install a default configuration file
+ insinto /etc/vim
+ doins "${FILESDIR}"/nvimrc
+}