summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-01-30 06:18:40 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-01-30 06:18:40 +0000
commit3eba18101dc96d86960ec27677ef3528634d531c (patch)
treea24cbfa9d72ffcb48cc48dd01492d067809824ca /app-editors
parentchanged a = to a ~ (diff)
downloadgentoo-2-3eba18101dc96d86960ec27677ef3528634d531c.tar.gz
gentoo-2-3eba18101dc96d86960ec27677ef3528634d531c.tar.bz2
gentoo-2-3eba18101dc96d86960ec27677ef3528634d531c.zip
revision bump:
more USE flags: alsa gnome better calling of configure options slightly modified some output added a lot of quotes to prevent directory names with spaces from breaking the emerge process .93-r1 does not checkout a live CVS tag, but downloads a prepared snapshot based on the ideas of ArYiX <aryixb@gmail.com> in bug #164164 (Portage version: 2.1.1-r2)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-cvs/ChangeLog13
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.93-r1.ebuild193
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.9999-r1.ebuild199
-rw-r--r--app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.93-r13
-rw-r--r--app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.9999-r11
5 files changed, 408 insertions, 1 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index a14e011d93af..60705b0604b4 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.66 2007/01/29 14:54:05 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.67 2007/01/30 06:18:40 opfer Exp $
+
+*emacs-cvs-22.0.9999-r1 (30 Jan 2007)
+*emacs-cvs-22.0.93-r1 (30 Jan 2007)
+
+ 30 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
+ +emacs-cvs-22.0.93-r1.ebuild, +emacs-cvs-22.0.9999-r1.ebuild:
+ revision bump: more USE flags: alsa gnome better calling of configure
+ options slightly modified some output added a lot of quotes to prevent
+ directory names with spaces from breaking the emerge process .93-r1 does not
+ checkout a live CVS tag, but downloads a prepared snapshot based on the
+ ideas of ArYiX <aryixb@gmail.com> in bug #164164
29 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
-emacs-cvs-22.0.91.ebuild, -emacs-cvs-22.0.92.ebuild:
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.93-r1.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.93-r1.ebuild
new file mode 100644
index 000000000000..55577118de1b
--- /dev/null
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.93-r1.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.93-r1.ebuild,v 1.1 2007/01/30 06:18:40 opfer Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit alternatives autotools elisp-common eutils flag-o-matic
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+SRC_URI="ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-${PV}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+IUSE="alsa aqua gif gnome gtk gzip-el jpeg lesstif motif nls png spell source tiff toolkit-scroll-bars X Xaw3d "
+
+RESTRICT="$RESTRICT nostrip"
+
+X_DEPEND="x11-libs/libXmu x11-libs/libXpm x11-libs/libXt x11-misc/xbitmaps || ( media-fonts/font-adobe-100dpi media-fonts/font-adobe-75dpi )"
+
+DEPEND="sys-libs/ncurses
+ sys-libs/zlib
+ spell? ( || ( app-text/ispell app-text/aspell ) )
+ X? ( || ( ( $X_DEPEND ) virtual/x11 ) )
+ X? ( gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ gtk? ( =x11-libs/gtk+-2* )
+ !gtk? ( Xaw3d? ( x11-libs/Xaw3d ) )
+ !Xaw3d? ( motif? ( x11-libs/openmotif ) )
+ !motif? ( lesstif? ( x11-libs/lesstif ) )
+ gnome? ( gnome-base/gnome-desktop ) )
+ alsa? ( media-sound/alsa-headers )
+ gzip-el? ( app-arch/gzip )
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/emacs virtual/editor"
+
+SLOT="22.0.93"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+S="${WORKDIR}/emacs-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/emacs-subdirs-el-gentoo.diff"
+ use ppc-macos && epatch "${FILESDIR}/emacs-cvs-21.3.50-nofink.diff"
+ sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+ epatch "${FILESDIR}/${PN}-freebsd-sparc.patch"
+ eautoreconf
+}
+
+src_compile() {
+ export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ ALLOWED_FLAGS=""
+ strip-flags
+ unset LDFLAGS
+ replace-flags -O[3-9] -O2
+ sed -i -e "s/-lungif/-lgif/g" configure* src/Makefile* || die
+
+ local myconf
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ myconf="${myconf} --with-xpm"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
+ myconf="${myconf} $(use_with gif) $(use_with png)"
+ if use gtk; then
+ einfo "Configuring to build with GTK support"
+ myconf="${myconf} --with-x-toolkit=gtk"
+ myconf="${myconf} --with-x-toolkit=athena"
+ elif use Xaw3d; then
+ einfo "Configuring to build with Xaw3d(athena) support"
+
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=lucid"
+ elif use motif; then
+ einfo "Configuring to build with motif toolkit support"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=motif"
+ else use lesstif;
+ einfo "Configuring to build with lesstif toolkit support"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=motif"
+ fi
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ if use aqua; then
+ einfo "Configuring to build with Carbon Emacs"
+ econf \
+ --enable-carbon-app=/Applications/Gentoo \
+ --without-x \
+ $(use_with jpeg) $(use_with tiff) \
+ $(use_with gif) $(use_with png) \
+ || die "econf carbon emacs failed"
+ else
+ econf \
+ --program-suffix=.emacs-${SLOT} \
+ --without-carbon \
+ ${myconf} || die "econf emacs failed"
+ fi
+
+ emake CC="$(tc-getCC) " bootstrap \
+ || die "make bootstrap failed."
+}
+
+src_install () {
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm "${D}"/usr/bin/emacs-${SLOT}.emacs-${SLOT} || die "removing duplicate emacs executable failed"
+ dohard /usr/bin/emacs.emacs-${SLOT} /usr/bin/emacs-${SLOT} || die
+
+ if use aqua ; then
+ einfo "Installing Carbon Emacs..."
+ dodir /Applications/Gentoo/Emacs.app
+ pushd mac/Emacs.app
+ tar -chf - . | ( cd "${D}/Applications/Gentoo/Emacs.app"; tar -xf -)
+ popd
+ fi
+
+ # fix info documentation
+ einfo "Fixing info documentation..."
+ dodir /usr/share/info/emacs-${SLOT}
+ mv "${D}"/usr/share/info/{,emacs-${SLOT}/}dir || die "mv dir failed"
+ for i in "${D}"/usr/share/info/*
+ do
+ if [ "${i##*/}" != emacs-${SLOT} ] ; then
+ mv ${i} ${i/info/info/emacs-${SLOT}}.info
+ fi
+ done
+
+ if has_version 'app-text/aspell' ; then
+ # defaults to aspell if installed
+ elisp-site-file-install "${FILESDIR}/40aspell-gentoo.el"
+ fi
+ insinto /etc/env.d
+ cat >"${D}"/etc/env.d/50emacs-cvs-${SLOT} <<EOF
+INFOPATH=/usr/share/info/emacs-${SLOT}
+EOF
+ einfo "Fixing manpages..."
+ for m in "${D}"/usr/share/man/man1/* ; do
+ mv ${m} ${m/.1/.emacs-${SLOT}.1} || die "mv man failed"
+ done
+
+ if use source; then
+ insinto /usr/share/emacs/${SLOT}/src
+ # This is not meant to install all the source -- just the
+ # C source you might find via find-function
+ doins src/*.[ch]
+ cat >00emacs-cvs-${SLOT}-gentoo.el <<EOF
+(when (substring emacs-version 0 (length "${SLOT}"))
+ (setq find-function-C-source-directory "/usr/share/emacs/${SLOT}/src"))
+EOF
+ elisp-site-file-install 00emacs-cvs-${SLOT}-gentoo.el
+ fi
+
+ if ! use gzip-el; then
+ find ${D} -type f -name \*.el.gz -print0 |xargs -0 gunzip
+ fi
+ dodoc BUGS ChangeLog README
+
+ make_desktop_entry /usr/bin/emacs Emacs /usr/share/emacs/${SLOT}/etc/images/icons/emacs_48.png editors
+}
+
+update-alternatives() {
+ for i in emacs emacsclient etags ctags b2m ebrowse \
+ rcs-checkin grep-changelog ;
+ do
+ alternatives_auto_makesym "/usr/bin/$i" "/usr/bin/$i.emacs-*"
+ done
+}
+
+pkg_postinst() {
+ use ppc-macos || update-alternatives
+ elisp-site-regen
+ if use X; then
+ elog "You need to install some fonts for Emacs. Under monolithic"
+ elog "XFree86/Xorg you typically had such fonts installed by default."
+ elog "With modular Xorg, you will have to perform this step yourself."
+ elog "Installing media-fonts/font-adobe-{75,100}dpi would satisfy basic"
+ elog "Emacs requirements under X11."
+ fi
+}
+
+pkg_postrm() {
+ use ppc-macos || update-alternatives
+ elisp-site-regen
+}
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r1.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r1.ebuild
new file mode 100644
index 000000000000..cd3bb48fa403
--- /dev/null
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r1.ebuild
@@ -0,0 +1,199 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r1.ebuild,v 1.1 2007/01/30 06:18:40 opfer Exp $
+
+ECVS_AUTH="pserver"
+ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
+ECVS_MODULE="emacs"
+ECVS_BRANCH="HEAD"
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit alternatives autotools cvs elisp-common eutils flag-o-matic
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+SRC_URI=""
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+IUSE="alsa aqua gif gnome gtk gzip-el jpeg lesstif motif nls png spell source tiff toolkit-scroll-bars X Xaw3d "
+
+RESTRICT="$RESTRICT nostrip"
+
+X_DEPEND="x11-libs/libXmu x11-libs/libXpm x11-libs/libXt x11-misc/xbitmaps || ( media-fonts/font-adobe-100dpi media-fonts/font-adobe-75dpi )"
+
+DEPEND="sys-libs/ncurses
+ sys-libs/zlib
+ spell? ( || ( app-text/ispell app-text/aspell ) )
+ X? ( || ( ( $X_DEPEND ) virtual/x11 ) )
+ X? ( gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ gtk? ( =x11-libs/gtk+-2* )
+ !gtk? ( Xaw3d? ( x11-libs/Xaw3d ) )
+ !Xaw3d? ( motif? ( x11-libs/openmotif ) )
+ !motif? ( lesstif? ( x11-libs/lesstif ) )
+ gnome? ( gnome-base/gnome-desktop ) )
+ alsa? ( media-sound/alsa-headers )
+ gzip-el? ( app-arch/gzip )
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/emacs virtual/editor"
+
+SLOT="22.0.93"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+S="${WORKDIR}/emacs-${PV}"
+
+src_unpack() {
+ cvs_src_unpack
+ cd ${S}
+ epatch "${FILESDIR}/emacs-subdirs-el-gentoo.diff"
+ use ppc-macos && epatch "${FILESDIR}/emacs-cvs-21.3.50-nofink.diff"
+ sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+ epatch "${FILESDIR}/${PN}-freebsd-sparc.patch"
+ eautoreconf
+}
+
+src_compile() {
+ export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ ALLOWED_FLAGS=""
+ strip-flags
+ unset LDFLAGS
+ replace-flags -O[3-9] -O2
+ sed -i -e "s/-lungif/-lgif/g" configure* src/Makefile* || die
+
+ local myconf
+
+ myconf="${myconf} $(use_enable mudflap multilib)"
+ if use X; then
+ myconf="${myconf} --with-x"
+ myconf="${myconf} --with-xpm"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
+ myconf="${myconf} $(use_with gif) $(use_with png)"
+ if use gtk; then
+ einfo "Configuring to build with GTK support"
+ myconf="${myconf} --with-x-toolkit=gtk"
+ myconf="${myconf} --with-x-toolkit=athena"
+ elif use Xaw3d; then
+ einfo "Configuring to build with Xaw3d(athena) support"
+
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=lucid"
+ elif use motif; then
+ einfo "Configuring to build with motif toolkit support"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=motif"
+ else use lesstif;
+ einfo "Configuring to build with lesstif toolkit support"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=motif"
+ fi
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ if use aqua; then
+ einfo "Configuring to build with Carbon Emacs"
+ econf \
+ --enable-carbon-app=/Applications/Gentoo \
+ --without-x \
+ $(use_with jpeg) $(use_with tiff) \
+ $(use_with gif) $(use_with png) \
+ || die "econf carbon emacs failed"
+ else
+ econf \
+ --program-suffix=.emacs-${SLOT} \
+ --without-carbon \
+ ${myconf} || die "econf emacs failed"
+ fi
+
+ emake CC="$(tc-getCC) " bootstrap \
+ || die "make bootstrap failed."
+}
+
+src_install () {
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm "${D}"/usr/bin/emacs-${SLOT}.emacs-${SLOT} || die "removing duplicate emacs executable failed"
+ dohard /usr/bin/emacs.emacs-${SLOT} /usr/bin/emacs-${SLOT} || die
+
+ if use aqua ; then
+ einfo "Installing Carbon Emacs..."
+ dodir /Applications/Gentoo/Emacs.app
+ pushd mac/Emacs.app
+ tar -chf - . | ( cd "${D}/Applications/Gentoo/Emacs.app"; tar -xf -)
+ popd
+ fi
+
+ # fix info documentation
+ einfo "Fixing info documentation..."
+ dodir /usr/share/info/emacs-${SLOT}
+ mv "${D}"/usr/share/info/{,emacs-${SLOT}/}dir || die "mv dir failed"
+ for i in "${D}"/usr/share/info/*
+ do
+ if [ "${i##*/}" != emacs-${SLOT} ] ; then
+ mv ${i} ${i/info/info/emacs-${SLOT}}.info
+ fi
+ done
+
+ if has_version 'app-text/aspell' ; then
+ # defaults to aspell if installed
+ elisp-site-file-install "${FILESDIR}/40aspell-gentoo.el"
+ fi
+ insinto /etc/env.d
+ cat >"${D}"/etc/env.d/50emacs-cvs-${SLOT} <<EOF
+INFOPATH=/usr/share/info/emacs-${SLOT}
+EOF
+ einfo "Fixing manpages..."
+ for m in "${D}"/usr/share/man/man1/* ; do
+ mv ${m} ${m/.1/.emacs-${SLOT}.1} || die "mv man failed"
+ done
+
+ if use source; then
+ insinto /usr/share/emacs/${SLOT}/src
+ # This is not meant to install all the source -- just the
+ # C source you might find via find-function
+ doins src/*.[ch]
+ cat >00emacs-cvs-${SLOT}-gentoo.el <<EOF
+(when (substring emacs-version 0 (length "${SLOT}"))
+ (setq find-function-C-source-directory "/usr/share/emacs/${SLOT}/src"))
+EOF
+ elisp-site-file-install 00emacs-cvs-${SLOT}-gentoo.el
+ fi
+
+ if ! use gzip-el; then
+ find ${D} -type f -name \*.el.gz -print0 |xargs -0 gunzip
+ fi
+ dodoc BUGS ChangeLog README
+
+ make_desktop_entry /usr/bin/emacs Emacs /usr/share/emacs/${SLOT}/etc/images/icons/emacs_48.png editors
+}
+
+update-alternatives() {
+ for i in emacs emacsclient etags ctags b2m ebrowse \
+ rcs-checkin grep-changelog ;
+ do
+ alternatives_auto_makesym "/usr/bin/$i" "/usr/bin/$i.emacs-*"
+ done
+}
+
+pkg_postinst() {
+ use ppc-macos || update-alternatives
+ elisp-site-regen
+ if use X; then
+ elog "You need to install some fonts for Emacs. Under monolithic"
+ elog "XFree86/Xorg you typically had such fonts installed by default."
+ elog "With modular Xorg, you will have to perform this step yourself."
+ elog "Installing media-fonts/font-adobe-{75,100}dpi would satisfy basic"
+ elog "Emacs requirements under X11."
+ fi
+}
+
+pkg_postrm() {
+ use ppc-macos || update-alternatives
+ elisp-site-regen
+} \ No newline at end of file
diff --git a/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.93-r1 b/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.93-r1
new file mode 100644
index 000000000000..f366c32d3a9d
--- /dev/null
+++ b/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.93-r1
@@ -0,0 +1,3 @@
+MD5 4e768a1489e514fbb78d1a5f9c512846 emacs-22.0.93.tar.gz 37118034
+RMD160 c70a745662495c68470f2b483f61d68d09e8ed73 emacs-22.0.93.tar.gz 37118034
+SHA256 44dd612b521a47d923c759525b1134bbc571350cae80bdc543c31f30acc7739e emacs-22.0.93.tar.gz 37118034
diff --git a/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.9999-r1 b/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.9999-r1
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/app-editors/emacs-cvs/files/digest-emacs-cvs-22.0.9999-r1
@@ -0,0 +1 @@
+