summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-09-03 16:48:02 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-09-03 16:48:02 +0000
commit47b55df8578d54327f15a4f5ea066be8fd951620 (patch)
tree234cb9d785d7d8d08a7126e878569c55a064bd75 /app-editors
parentStable on ia64. (diff)
downloadgentoo-2-47b55df8578d54327f15a4f5ea066be8fd951620.tar.gz
gentoo-2-47b55df8578d54327f15a4f5ea066be8fd951620.tar.bz2
gentoo-2-47b55df8578d54327f15a4f5ea066be8fd951620.zip
Version bump, see bug #145494.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog9
-rw-r--r--app-editors/scite/files/digest-scite-1.713
-rw-r--r--app-editors/scite/metadata.xml9
-rw-r--r--app-editors/scite/scite-1.71.ebuild70
4 files changed, 88 insertions, 3 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index 10ff088bcda0..8111d4127d31 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/scite
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.45 2006/06/26 19:47:13 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.46 2006/09/03 16:48:02 nelchael Exp $
+
+*scite-1.71 (03 Sep 2006)
+
+ 03 Sep 2006; Krzysiek Pawlik <nelchael@gentoo.org> metadata.xml,
+ -scite-1.66.ebuild, -scite-1.67.ebuild, -scite-1.68.ebuild,
+ -scite-1.69.ebuild, +scite-1.71.ebuild:
+ Version bump, see bug #145494.
*scite-1.70 (26 Jun 2006)
*scite-1.69 (26 Jun 2006)
diff --git a/app-editors/scite/files/digest-scite-1.71 b/app-editors/scite/files/digest-scite-1.71
new file mode 100644
index 000000000000..488a48bfa82c
--- /dev/null
+++ b/app-editors/scite/files/digest-scite-1.71
@@ -0,0 +1,3 @@
+MD5 b62946c770686909a4d4d0e42de3754c scite171.tgz 1300416
+RMD160 05a56af15b0c4e4a9c33b62d8bde4ea9feef4208 scite171.tgz 1300416
+SHA256 c84ba2fc252345e3d36d36f14b3ab43c6f20e0e7ee5c30d8560f938d505116e3 scite171.tgz 1300416
diff --git a/app-editors/scite/metadata.xml b/app-editors/scite/metadata.xml
index c10a79b7cd27..afbf14dbf0be 100644
--- a/app-editors/scite/metadata.xml
+++ b/app-editors/scite/metadata.xml
@@ -1,6 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
-<maintainer><email>pythonhead@gentoo.org</email></maintainer>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>nelchael@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>pythonhead@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/app-editors/scite/scite-1.71.ebuild b/app-editors/scite/scite-1.71.ebuild
new file mode 100644
index 000000000000..28850d49259b
--- /dev/null
+++ b/app-editors/scite/scite-1.71.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.71.ebuild,v 1.1 2006/09/03 16:48:02 nelchael Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://www.scintilla.org"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86 ~amd64"
+IUSE="lua"
+
+RDEPEND=">=x11-libs/gtk+-2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}/gtk
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/scintilla/gtk
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ || die "error patching makefile"
+
+ cd ${S}
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ || die "error patching makefile"
+}
+
+src_compile() {
+ make -C ../../scintilla/gtk || die "prep make failed"
+ if use lua; then
+ emake || die "make failed"
+ else
+ emake NO_LUA=1 || die "make failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ make prefix=${D}/usr install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv ${D}/usr/bin/SciTE ${D}/usr/bin/scite
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f ${D}/usr/share/applications/SciTE.desktop
+ doins ${FILESDIR}/scite.desktop
+
+ doman ../doc/scite.1
+ dodoc ../README
+}