summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2006-12-26 19:31:57 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2006-12-26 19:31:57 +0000
commit51e309a3bab71bb276d3e39b6572c5cf64328b49 (patch)
treeb61e2b88a456fbe8eaf3c1b8b4b9caf0ede193b4 /app-editors
parentFix ibmtr compile error. Add some minor corruption fixes for ext2, ext3, squa... (diff)
downloadgentoo-2-51e309a3bab71bb276d3e39b6572c5cf64328b49.tar.gz
gentoo-2-51e309a3bab71bb276d3e39b6572c5cf64328b49.tar.bz2
gentoo-2-51e309a3bab71bb276d3e39b6572c5cf64328b49.zip
Bump to 2.5 and add doc support. Bug 154963; thanks to Gioele Barabucci
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xxe/ChangeLog8
-rw-r--r--app-editors/xxe/files/digest-xxe-3.5.03
-rw-r--r--app-editors/xxe/xxe-3.5.0.ebuild51
3 files changed, 61 insertions, 1 deletions
diff --git a/app-editors/xxe/ChangeLog b/app-editors/xxe/ChangeLog
index d811c029b290..23e66a5035aa 100644
--- a/app-editors/xxe/ChangeLog
+++ b/app-editors/xxe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/xxe
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xxe/ChangeLog,v 1.28 2006/08/15 15:12:12 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xxe/ChangeLog,v 1.29 2006/12/26 19:31:57 masterdriverz Exp $
+
+*xxe-3.5.0 (26 Dec 2006)
+
+ 26 Dec 2006; Charlie Shepherd <masterdriverz@gentoo.org>
+ +xxe-3.5.0.ebuild:
+ Bump to 2.5 and add doc support. Bug 154963; thanks to Gioele Barabucci
*xxe-3.4.0 (15 Aug 2006)
diff --git a/app-editors/xxe/files/digest-xxe-3.5.0 b/app-editors/xxe/files/digest-xxe-3.5.0
new file mode 100644
index 000000000000..86be0cb88c02
--- /dev/null
+++ b/app-editors/xxe/files/digest-xxe-3.5.0
@@ -0,0 +1,3 @@
+MD5 de90476346c363017f4e6276de548872 xxe-std-3_5_0.tar.gz 12592395
+RMD160 c33b704f4df5354f73919acf43981555dbc1c010 xxe-std-3_5_0.tar.gz 12592395
+SHA256 97b6096fd51dca12e7b160eceb2154b96222df3469c26a1f7789868f21872322 xxe-std-3_5_0.tar.gz 12592395
diff --git a/app-editors/xxe/xxe-3.5.0.ebuild b/app-editors/xxe/xxe-3.5.0.ebuild
new file mode 100644
index 000000000000..a7a0045e5a05
--- /dev/null
+++ b/app-editors/xxe/xxe-3.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xxe/xxe-3.5.0.ebuild,v 1.1 2006/12/26 19:31:57 masterdriverz Exp $
+
+MY_PV="${PV//./_}"
+
+DESCRIPTION="The XMLmind XML Editor"
+SRC_URI="http://www.xmlmind.net/xmleditor/_download/${PN}-std-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.xmlmind.com/xmleditor/index.html"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="doc"
+
+RESTRICT="nostrip nomirror"
+
+DEPEND=""
+RDEPEND=">=virtual/jre-1.4.1"
+
+S="${WORKDIR}/${PN}-std-${MY_PV}"
+INSTALLDIR="/opt/${PN}"
+
+src_install() {
+ dodir "${INSTALLDIR}"
+ dirs="bin addon demo"
+ use doc && dirs="${dirs} doc"
+ for d in $dirs; do
+ cp -pPR "${S}/${d}" "${D}/${INSTALLDIR}"
+ done
+
+ chmod -x "${D}/${INSTALLDIR}"/bin/*.bat
+ chmod -x "${D}/${INSTALLDIR}"/bin/*.exe
+ chmod -x "${D}/${INSTALLDIR}"/bin/mac/{mkapp,JavaApplicationStub}
+
+ echo -e "PATH=${INSTALLDIR}/bin\nROOTPATH=${INSTALLDIR}" > "${T}/10xxe"
+ doenvd "${T}/10xxe"
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}/xxe.desktop"
+}
+
+pkg_postinst() {
+ einfo "XXE has been installed in /opt/xxe, to include this"
+ einfo "in your path, run the following:"
+ einfo " /usr/sbin/env-update && source /etc/profile"
+ echo
+ ewarn "If you need special/accented characters, you'll need to export LANG"
+ ewarn "to your locale. Example: export LANG=es_ES.ISO8859-1"
+ ewarn "See http://www.xmlmind.com/xmleditor/user_faq.html#linuxlocale"
+}