summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-11-08 19:21:37 +0000
committerJim Ramsay <lack@gentoo.org>2010-11-08 19:21:37 +0000
commit59e041a069058fdf5096676c2aab48d9b2c96885 (patch)
tree73761d09088ba07e2a039d3396c0f8a8454d2b31 /app-editors
parentVersion Bump: 7.3.50 is released (diff)
downloadgentoo-2-59e041a069058fdf5096676c2aab48d9b2c96885.tar.gz
gentoo-2-59e041a069058fdf5096676c2aab48d9b2c96885.tar.bz2
gentoo-2-59e041a069058fdf5096676c2aab48d9b2c96885.zip
Version Bump: 7.3.50 is released
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/ChangeLog7
-rw-r--r--app-editors/gvim/gvim-7.3.50.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index 4f13e791e630..f349611fa253 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gvim
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.323 2010/10/10 17:26:19 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.324 2010/11/08 19:21:37 lack Exp $
+
+*gvim-7.3.50 (08 Nov 2010)
+
+ 08 Nov 2010; Jim Ramsay <lack@gentoo.org> +gvim-7.3.50.ebuild:
+ Version Bump: 7.3.50 is released
10 Oct 2010; Ulrich Mueller <ulm@gentoo.org> gvim-7.0.235.ebuild,
gvim-7.0.243.ebuild, gvim-7.1.123.ebuild, gvim-7.1.330.ebuild:
diff --git a/app-editors/gvim/gvim-7.3.50.ebuild b/app-editors/gvim/gvim-7.3.50.ebuild
new file mode 100644
index 000000000000..56d2e99939b8
--- /dev/null
+++ b/app-editors/gvim/gvim-7.3.50.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.3.50.ebuild,v 1.1 2010/11/08 19:21:37 lack Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.bz2"
+GVIMRC_FILE_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r2"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.1-interix-link.patch
+ epatch "${FILESDIR}"/${PN}-7.1.319-interix-cflags.patch
+ fi
+}