summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-31 11:06:06 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-31 11:06:06 +0000
commit60b4f63f6132b35a4b311de747fa3eef79757a54 (patch)
treedcb04409dde72f265e8dc234d828633e56dd7b77 /app-editors
parentSecurity update (diff)
downloadgentoo-2-60b4f63f6132b35a4b311de747fa3eef79757a54.tar.gz
gentoo-2-60b4f63f6132b35a4b311de747fa3eef79757a54.tar.bz2
gentoo-2-60b4f63f6132b35a4b311de747fa3eef79757a54.zip
housekeeping
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jedit/files/digest-jedit-4.0.31
-rw-r--r--app-editors/jedit/files/digest-jedit-4.0.3-r11
-rw-r--r--app-editors/jedit/jedit-4.0.3-r1.ebuild67
-rw-r--r--app-editors/jedit/jedit-4.0.3.ebuild67
4 files changed, 0 insertions, 136 deletions
diff --git a/app-editors/jedit/files/digest-jedit-4.0.3 b/app-editors/jedit/files/digest-jedit-4.0.3
deleted file mode 100644
index 05e5e28f8719..000000000000
--- a/app-editors/jedit/files/digest-jedit-4.0.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 95a26ccc1ab89257a467ef159f5dad05 jedit403source.tar.gz 1283199
diff --git a/app-editors/jedit/files/digest-jedit-4.0.3-r1 b/app-editors/jedit/files/digest-jedit-4.0.3-r1
deleted file mode 100644
index 05e5e28f8719..000000000000
--- a/app-editors/jedit/files/digest-jedit-4.0.3-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 95a26ccc1ab89257a467ef159f5dad05 jedit403source.tar.gz 1283199
diff --git a/app-editors/jedit/jedit-4.0.3-r1.ebuild b/app-editors/jedit/jedit-4.0.3-r1.ebuild
deleted file mode 100644
index e7abff8fc3e5..000000000000
--- a/app-editors/jedit/jedit-4.0.3-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r1.ebuild,v 1.7 2003/02/13 06:42:05 vapier Exp $
-
-MY_PV=${PV//.}
-S="${WORKDIR}/jEdit"
-DESCRIPTION="Programmer's editor written in Java"
-HOMEPAGE="http://www.jedit.org"
-SRC_URI="mirror://sourceforge/jedit/${PN}${MY_PV}source.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="jikes"
-
-RDEPEND=">=virtual/jdk-1.3"
-DEPEND="${RDEPEND}
- >=dev-java/ant-1.4.1
- jikes? ( >=dev-java/jikes-1.17 )"
-
-src_compile() {
- local antflags
-
- antflags=""
- if [ `use jikes` ] ; then
- einfo "Please ignore the following compiler warnings."
- einfo "Jikes is just too pedantic..."
- antflags="${antflags} -Dbuild.compiler=jikes"
- fi
-
- ant ${antflags} || die "compile problem"
-}
-
-src_install () {
- dodir /usr/share/jedit
- dodir /usr/bin
-
- cp -R jedit.jar jars doc macros modes properties startup ${D}/usr/share/jedit
- cd ${D}/usr/share/jedit
- chmod -R u+rw,ug-s,go+u,go-w \
- jedit.jar jars macros modes properties startup
-
- cat >${D}/usr/share/jedit/jedit.sh <<-EOF
- #!/bin/bash
-
- cd /usr/share/jedit
- java -jar /usr/share/jedit/jedit.jar $@
- EOF
- chmod 755 ${D}/usr/share/jedit/jedit.sh
-
- ln -s ../share/jedit/jedit.sh ${D}/usr/bin/jedit
-}
-
-pkg_postinst() {
- touch /usr/share/jedit/jars/.keep
-
- einfo "The system directory for jEdit plugins is"
- einfo "/usr/share/jedit/jars"
-}
-
-pkg_postrm() {
- einfo "jEdit plugins installed into /usr/share/jedit/jars"
- einfo "(after installation of jEdit itself) haven't been"
- einfo "removed. To get rid of jEdit completely, you may"
- einfo "want to run"
- einfo ""
- einfo "\trm -r /usr/share/jedit"
-}
diff --git a/app-editors/jedit/jedit-4.0.3.ebuild b/app-editors/jedit/jedit-4.0.3.ebuild
deleted file mode 100644
index 2a3fec9012bc..000000000000
--- a/app-editors/jedit/jedit-4.0.3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3.ebuild,v 1.8 2003/02/13 06:42:16 vapier Exp $
-
-MY_PV=${PV//.}
-S="${WORKDIR}/jEdit"
-DESCRIPTION="Programmer's editor written in Java"
-HOMEPAGE="http://www.jedit.org"
-SRC_URI="mirror://sourceforge/jedit/${PN}${MY_PV}source.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="jikes"
-
-RDEPEND=">=virtual/jdk-1.3"
-DEPEND="${RDEPEND}
- >=dev-java/ant-1.4.1
- jikes? ( >=dev-java/jikes-1.17 )"
-
-src_compile() {
- local antflags
-
- antflags=""
- if [ `use jikes` ] ; then
- einfo "Please ignore the following compiler warnings."
- einfo "Jikes is just too pedantic..."
- antflags="${antflags} -Dbuild.compiler=jikes"
- fi
-
- ant ${antflags} || die "compile problem"
-}
-
-src_install () {
- dodir /usr/share/jedit
- dodir /usr/bin
-
- cp -R jedit.jar jars macros modes properties startup ${D}/usr/share/jedit
- cd ${D}/usr/share/jedit
- chmod -R u+rw,ug-s,go+u,go-w \
- jedit.jar jars macros modes properties startup
-
- cat >${D}/usr/share/jedit/jedit.sh <<-EOF
- #!/bin/bash
-
- cd /usr/share/jedit
- java -jar /usr/share/jedit/jedit.jar $@
- EOF
- chmod 755 ${D}/usr/share/jedit/jedit.sh
-
- ln -s ../share/jedit/jedit.sh ${D}/usr/bin/jedit
-}
-
-pkg_postinst() {
- touch /usr/share/jedit/jars/.keep
-
- einfo "The system directory for jEdit plugins is"
- einfo "/usr/share/jedit/jars"
-}
-
-pkg_postrm() {
- einfo "jEdit plugins installed into /usr/share/jedit/jars"
- einfo "(after installation of jEdit itself) haven't been"
- einfo "removed. To get rid of jEdit completely, you may"
- einfo "want to run"
- einfo ""
- einfo "\trm -r /usr/share/jedit"
-}