summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2004-10-26 16:11:36 +0000
committerCarsten Lohrke <carlo@gentoo.org>2004-10-26 16:11:36 +0000
commit699219ae514f68f3ecd4683767270ed8ea8ac839 (patch)
tree4dc1b83869b734772d5134b5795ebe93dd466c7a /app-editors
parentRemoved non-existend 'COPYING.LIB' dodoc entry in dev-db/mysql-4.0.21... (Man... (diff)
downloadgentoo-2-699219ae514f68f3ecd4683767270ed8ea8ac839.tar.gz
gentoo-2-699219ae514f68f3ecd4683767270ed8ea8ac839.tar.bz2
gentoo-2-699219ae514f68f3ecd4683767270ed8ea8ac839.zip
missing i18n (seperate tarball now)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/kile/ChangeLog5
-rw-r--r--app-editors/kile/kile-1.7.1.ebuild48
2 files changed, 47 insertions, 6 deletions
diff --git a/app-editors/kile/ChangeLog b/app-editors/kile/ChangeLog
index 0478e2ede9ba..ef4d2935e902 100644
--- a/app-editors/kile/ChangeLog
+++ b/app-editors/kile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/kile
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.40 2004/10/19 14:48:38 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.41 2004/10/26 16:11:36 carlo Exp $
+
+ 26 Oct 2004; Carsten Lohrke <carlo@gentoo.org> kile-1.7.1.ebuild:
+ missing i18n (seperate tarball now), #68085
*kile-1.7.1 (19 Oct 2004)
diff --git a/app-editors/kile/kile-1.7.1.ebuild b/app-editors/kile/kile-1.7.1.ebuild
index 214d9190d982..621e5194cc06 100644
--- a/app-editors/kile/kile-1.7.1.ebuild
+++ b/app-editors/kile/kile-1.7.1.ebuild
@@ -1,15 +1,12 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-1.7.1.ebuild,v 1.1 2004/10/19 14:48:38 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-1.7.1.ebuild,v 1.2 2004/10/26 16:11:36 carlo Exp $
inherit kde
-MY_P=${P/_beta/b}
-S=${WORKDIR}/${MY_P}
-
DESCRIPTION="A Latex Editor and TeX shell for kde"
-SRC_URI="mirror://sourceforge/kile/${MY_P}.tar.bz2"
HOMEPAGE="http://kile.sourceforge.net"
+SRC_URI="mirror://sourceforge/kile/${P}.tar.bz2"
IUSE="kde"
SLOT=0
@@ -21,3 +18,44 @@ DEPEND="dev-lang/perl"
RDEPEND="virtual/tetex
kde? ( kde-base/kdegraphics )"
need-kde 3.2
+
+I18N="${PN}-i18n-${PV%.*}"
+
+# These are the languages and translated documentation supported by the Kile
+# i18n package as of version 1.7. If you are using this ebuild as a model for another
+# ebuild for another version of Kile, DO check whether these values are different.
+# Check the {po,doc}/Makefile.am files in kile-i18n package.
+LANGS="da de en_GB es et fr hu it nl pt pt_BR sr sv ta"
+LANGS_DOC="da es et fr it nl pt pt_BR sv"
+
+MAKE_PO=$(echo "${LINGUAS} ${LANGS}" | fmt -w 1 | sort | uniq -d | fmt -w 10000)
+MAKE_DOC=$(echo "${LINGUAS} ${LANGS_DOC}" | fmt -w 1 | sort | uniq -d | fmt -w 10000)
+
+if [ -n "$MAKE_PO" ] ; then
+ SRC_URI="${SRC_URI} mirror://sourceforge/kile/${I18N}.tar.bz2"
+fi
+
+src_compile() {
+ local _S=${S}
+
+ # Build process of Kile
+ kde_src_compile
+
+ # Build process of Kile-i18n, select LINGUAS elements
+ S=${WORKDIR}/${I18N}
+ if [ -n "${LINGUAS}" -a -d "${S}" ] ; then
+ sed -i -e "s:^SUBDIRS = .*:SUBDIRS = ${MAKE_PO}:" ${S}/po/Makefile.in
+ sed -i -e "s:^SUBDIRS = .*:SUBDIRS = ${MAKE_DOC}:" ${S}/doc/Makefile.in
+ kde_src_compile
+ fi
+ S=${_S}
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if [ -n "${LINGUAS}" -a -d "${WORKDIR}/${I18N}" ]; then
+ cd ${WORKDIR}/${I18N}
+ make DESTDIR=${D} install || die
+ fi
+}