summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-03-17 13:46:44 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-03-17 13:46:44 +0000
commitb6dd3b302650bcd35d2e8cd190cd15fb8770cccb (patch)
treeebe2fa086af4c87f985cbc777be4814ae24854ff /app-editors
parentRemove unneeded files. (diff)
downloadgentoo-2-b6dd3b302650bcd35d2e8cd190cd15fb8770cccb.tar.gz
gentoo-2-b6dd3b302650bcd35d2e8cd190cd15fb8770cccb.tar.bz2
gentoo-2-b6dd3b302650bcd35d2e8cd190cd15fb8770cccb.zip
Added workaround to prevent segfaults on ppc.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/qemacs/ChangeLog7
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch2
-rw-r--r--app-editors/qemacs/files/qemacs-ppc-segfault.patch39
-rw-r--r--app-editors/qemacs/qemacs-0.3.1-r1.ebuild5
-rw-r--r--app-editors/qemacs/qemacs-0.3.1.ebuild5
5 files changed, 54 insertions, 4 deletions
diff --git a/app-editors/qemacs/ChangeLog b/app-editors/qemacs/ChangeLog
index d77b333450a0..4d3f4b654cab 100644
--- a/app-editors/qemacs/ChangeLog
+++ b/app-editors/qemacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/qemacs
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.13 2005/03/06 02:49:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.14 2005/03/17 13:46:43 josejx Exp $
+
+ 17 Mar 2005; Joseph Jezak <josejx@gentoo.org>
+ files/qemacs-0.3.1-gcc-3.4.patch, +files/qemacs-ppc-segfault.patch,
+ qemacs-0.3.1.ebuild, qemacs-0.3.1-r1.ebuild:
+ Added workaround to prevent segfaults on ppc.
06 Mar 2005; Joseph Jezak <josejx@gentoo.org>
+files/qemacs-0.3.1-gcc-3.4.patch, qemacs-0.3.1-r1.ebuild,
diff --git a/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch b/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch
index 121988feec24..4506b9e3ab5a 100644
--- a/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch
+++ b/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch
@@ -4,7 +4,7 @@
*q++ = l1;
i++;
found:
-+ ;
++ break;
}
}
return q - buf_out;
diff --git a/app-editors/qemacs/files/qemacs-ppc-segfault.patch b/app-editors/qemacs/files/qemacs-ppc-segfault.patch
new file mode 100644
index 000000000000..de6c420c5d3b
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-ppc-segfault.patch
@@ -0,0 +1,39 @@
+--- qe.c.old 2005-03-13 14:37:22.967682048 +1100
++++ qe.c 2005-03-13 14:37:56.866528640 +1100
+@@ -6165,16 +6165,16 @@
+ { NULL },
+ };
+
+-#if defined(__GNUC__) || defined(__TINYC__)
++/*#if defined(__GNUC__) || defined(__TINYC__)
+ static inline void init_all_modules(void)
+ {
+ int (*initcall)(void);
+ void **ptr;
+
+ ptr = (void **)&__initcall_first;
+- for(;;) {
++ for(;;) {*/
+ /* NOTE: if bound checking is on, a '\0' is inserted between
+- each initialized 'void *' */
++ each initialized 'void *' *//*
+ #if defined(__BOUNDS_CHECKING_ON)
+ ptr = (void **)((long)ptr + (2 * sizeof(void *)));
+ #else
+@@ -6186,14 +6186,14 @@
+ initcall();
+ }
+ }
+-#else
++#else*/
+ /* cannot use elf sections, so we initialize the modules manually */
+ static inline void init_all_modules(void)
+ {
+ x11_init();
+ c_init();
+ }
+-#endif
++//#endif
+
+ #ifdef CONFIG_DLL
+
diff --git a/app-editors/qemacs/qemacs-0.3.1-r1.ebuild b/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
index dbc68c98b1fc..4cf38995791f 100644
--- a/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
+++ b/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1-r1.ebuild,v 1.2 2005/03/06 02:49:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1-r1.ebuild,v 1.3 2005/03/17 13:46:43 josejx Exp $
inherit eutils
@@ -23,6 +23,9 @@ src_unpack() {
epatch ${FILESDIR}/${P}-configure-gentoo.patch
epatch ${FILESDIR}/${P}-make_backup.patch
epatch ${FILESDIR}/${PN}-0.3.1-gcc-3.4.patch
+ if use ppc; then
+ epatch ${FILESDIR}/${PN}-ppc-segfault.patch
+ fi
use unicode && epatch ${FILESDIR}/${P}-tty_utf8.patch
}
diff --git a/app-editors/qemacs/qemacs-0.3.1.ebuild b/app-editors/qemacs/qemacs-0.3.1.ebuild
index 9a71686a97b3..ae54874f794b 100644
--- a/app-editors/qemacs/qemacs-0.3.1.ebuild
+++ b/app-editors/qemacs/qemacs-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.15 2005/03/06 02:49:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.16 2005/03/17 13:46:43 josejx Exp $
inherit eutils
@@ -22,6 +22,9 @@ src_unpack() {
epatch ${FILESDIR}/qemacs-Makefile-gentoo.patch
epatch ${FILESDIR}/qemacs-${PV}-configure-gentoo.patch
epatch ${FILESDIR}/${P}-gcc-3.4.patch
+ if use ppc; then
+ epatch ${FILESDIR}/${PN}-ppc-segfault.patch
+ fi
use unicode && epatch ${FILESDIR}/${P}-tty_utf8.patch
}