summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2009-09-26 08:47:52 +0000
committerHarald van Dijk <truedfx@gentoo.org>2009-09-26 08:47:52 +0000
commitdeefa0246462ba7df40f9664a08f30e4dde13e93 (patch)
tree328e3b391fa2bc116b79340cdec39352abddfbb4 /app-editors
parentFix the installed fontconfig file; 2.6-r1 installed the mikachan file instead... (diff)
downloadgentoo-2-deefa0246462ba7df40f9664a08f30e4dde13e93.tar.gz
gentoo-2-deefa0246462ba7df40f9664a08f30e4dde13e93.tar.bz2
gentoo-2-deefa0246462ba7df40f9664a08f30e4dde13e93.zip
Don't try to build against db 4.8 (#286352 by Max Kresch), plus make page size always a multiple of 2 as required by db; remove older versions
(Portage version: 2.2_rc41/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nvi/ChangeLog9
-rw-r--r--app-editors/nvi/files/nvi-1.81.6-db.patch26
-rw-r--r--app-editors/nvi/nvi-1.81.6-r3.ebuild (renamed from app-editors/nvi/nvi-1.81.6-r1.ebuild)17
-rw-r--r--app-editors/nvi/nvi-1.81.6.ebuild62
4 files changed, 48 insertions, 66 deletions
diff --git a/app-editors/nvi/ChangeLog b/app-editors/nvi/ChangeLog
index 05f87eabdac2..67a7c487bd93 100644
--- a/app-editors/nvi/ChangeLog
+++ b/app-editors/nvi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/nvi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/ChangeLog,v 1.71 2009/06/07 23:57:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/ChangeLog,v 1.72 2009/09/26 08:47:51 truedfx Exp $
+
+*nvi-1.81.6-r3 (26 Sep 2009)
+
+ 26 Sep 2009; Harald van Dijk <truedfx@gentoo.org> -nvi-1.81.6.ebuild,
+ -nvi-1.81.6-r1.ebuild, +nvi-1.81.6-r3.ebuild, +files/nvi-1.81.6-db.patch:
+ Don't try to build against db 4.8 (#286352 by Max Kresch), plus make page
+ size always a multiple of 2 as required by db; remove older versions
07 Jun 2009; Jeroen Roovers <jer@gentoo.org> nvi-1.81.6-r2.ebuild:
Stable for HPPA (bug #271937).
diff --git a/app-editors/nvi/files/nvi-1.81.6-db.patch b/app-editors/nvi/files/nvi-1.81.6-db.patch
new file mode 100644
index 000000000000..6fc9926c0364
--- /dev/null
+++ b/app-editors/nvi/files/nvi-1.81.6-db.patch
@@ -0,0 +1,26 @@
+--- ../common/exf.c
++++ ../common/exf.c
+@@ -228,13 +228,18 @@
+ /*
+ * XXX
+ * A seat of the pants calculation: try to keep the file in
+- * 15 pages or less. Don't use a page size larger than 10K
++ * 15 pages or less. Don't use a page size larger than 8K
+- * (vi should have good locality) or smaller than 1K.
++ * (vi should have good locality) or smaller than 1K. DB asks
++ * for a power of two, so give it one.
+ */
+ psize = ((sb.st_size / 15) + 1023) / 1024;
+- if (psize > 10)
++ if (psize >= 8)
+- psize = 10;
++ psize = 8;
++ else if (psize >= 4)
++ psize = 4;
++ else if (psize >= 2)
++ psize = 2;
+- if (psize == 0)
++ else
+ psize = 1;
+ psize *= 1024;
+
diff --git a/app-editors/nvi/nvi-1.81.6-r1.ebuild b/app-editors/nvi/nvi-1.81.6-r3.ebuild
index 6e6206620c66..e71dac4a2c03 100644
--- a/app-editors/nvi/nvi-1.81.6-r1.ebuild
+++ b/app-editors/nvi/nvi-1.81.6-r3.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.6-r1.ebuild,v 1.1 2008/10/05 14:52:40 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.6-r3.ebuild,v 1.1 2009/09/26 08:47:51 truedfx Exp $
+
+inherit db-use eutils flag-o-matic
+
+DBVERS="4.7 4.6 4.5 4.4 4.3 4.2"
DESCRIPTION="Vi clone"
HOMEPAGE="http://www.bostic.com/vi/"
@@ -11,7 +15,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="perl tcl unicode"
-DEPEND="=sys-libs/db-4*
+DEPEND="|| ( $(printf "=sys-libs/db-%s*\n" ${DBVERS}) )
perl? ( dev-lang/perl )
tcl? ( !unicode? ( >=dev-lang/tcl-8.5 ) )"
RDEPEND="${DEPEND}
@@ -30,7 +34,12 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-db44.patch
+ epatch "${FILESDIR}"/${P}-db.patch
chmod +x ../dist/findconfig
+
+ append-flags -I"$(db_includedir ${DBVERS})"
+ sed -i -e "s@-ldb@-l$(db_libname ${DBVERS})@" ../dist/configure
}
src_compile() {
@@ -40,6 +49,8 @@ src_compile() {
use tcl && ! use unicode && myconf="${myconf} --enable-tclinterp"
use unicode && myconf="${myconf} --enable-widechar"
+ append-flags '-D_PATH_MSGCAT="\"/usr/share/vi/catalog/\""'
+
ECONF_SOURCE=../dist econf \
--program-prefix=n \
${myconf} \
diff --git a/app-editors/nvi/nvi-1.81.6.ebuild b/app-editors/nvi/nvi-1.81.6.ebuild
deleted file mode 100644
index 8c08bf9fc3f6..000000000000
--- a/app-editors/nvi/nvi-1.81.6.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.6.ebuild,v 1.8 2008/06/22 09:56:23 bluebird Exp $
-
-DESCRIPTION="Vi clone"
-HOMEPAGE="http://www.bostic.com/vi/"
-SRC_URI="http://www.kotnet.org/~skimo/nvi/devel/${P}.tar.bz2"
-
-LICENSE="Sleepycat"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ~mips ppc ppc64 sparc x86"
-IUSE="perl tcl unicode"
-
-DEPEND="=sys-libs/db-4*
- perl? ( dev-lang/perl )
- tcl? ( !unicode? ( >=dev-lang/tcl-8.5 ) )"
-RDEPEND="${DEPEND}
- app-admin/eselect-vi"
-
-S=${WORKDIR}/${P}/build.unix
-
-pkg_setup() {
- if use tcl && use unicode
- then
- ewarn "nvi does not support tcl+unicode. tcl support will not be included."
- ewarn "If you need tcl support, please disable the unicode flag."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- chmod +x ../dist/findconfig
-}
-
-src_compile() {
- local myconf
-
- use perl && myconf="${myconf} --enable-perlinterp"
- use tcl && ! use unicode && myconf="${myconf} --enable-tclinterp"
- use unicode && myconf="${myconf} --enable-widechar"
-
- ECONF_SOURCE=../dist econf \
- --program-prefix=n \
- ${myconf} \
- || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install || die "install failed"
-}
-
-pkg_postinst() {
- einfo "Setting /usr/bin/vi symlink"
- eselect vi update --if-unset
-}
-
-pkg_postrm() {
- einfo "Updating /usr/bin/vi symlink"
- eselect vi update --if-unset
-}