summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-11-06 15:46:52 +0000
committerBen de Groot <yngwin@gentoo.org>2008-11-06 15:46:52 +0000
commite0d2d2714e77d498a2f0d4451f582e7d19872c5d (patch)
treedf6b4976b0a9d1588c375c97be49625305e2a6dd /app-editors
parentstable amd64, regression from 1.2.28. See bug #245331 (diff)
downloadgentoo-2-e0d2d2714e77d498a2f0d4451f582e7d19872c5d.tar.gz
gentoo-2-e0d2d2714e77d498a2f0d4451f582e7d19872c5d.tar.bz2
gentoo-2-e0d2d2714e77d498a2f0d4451f582e7d19872c5d.zip
Version bump
(Portage version: 2.2_rc13/cvs/Linux 2.6.26-hh3 i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/juffed/ChangeLog7
-rw-r--r--app-editors/juffed/juffed-0.4.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-editors/juffed/ChangeLog b/app-editors/juffed/ChangeLog
index 766e6f05e910..f3deb4c95e7d 100644
--- a/app-editors/juffed/ChangeLog
+++ b/app-editors/juffed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/juffed
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/ChangeLog,v 1.5 2008/10/25 22:07:03 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/ChangeLog,v 1.6 2008/11/06 15:46:52 yngwin Exp $
+
+*juffed-0.4 (06 Nov 2008)
+
+ 06 Nov 2008; Ben de Groot <yngwin@gentoo.org> +juffed-0.4.ebuild:
+ Version bump
*juffed-0.3 (05 Aug 2008)
diff --git a/app-editors/juffed/juffed-0.4.ebuild b/app-editors/juffed/juffed-0.4.ebuild
new file mode 100644
index 000000000000..a21a51fc552e
--- /dev/null
+++ b/app-editors/juffed/juffed-0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/juffed/juffed-0.4.ebuild,v 1.1 2008/11/06 15:46:52 yngwin Exp $
+
+EAPI=1
+inherit qt4
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/JuffEd?content=59940"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/qscintilla-2.1
+ || ( x11-libs/qt-gui:4 =x11-libs/qt-4.3*:4 )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # force our current cxxflags and ldflags, and turn off warnings in tests, bug 231921
+ epatch "${FILESDIR}"/${PN}-0.3-configure.patch
+}
+
+src_compile() {
+ # with econf it chokes on Unrecognized option: --host=...
+ ./configure --qmake=qmake --prefix=/usr
+ emake || die "Make failed!"
+}
+
+src_install() {
+ emake FAKE_ROOT="${D}" install || die "Make install failed!"
+ dodoc ChangeLog README
+ rm "${D}"/usr/share/juffed/{COPYING,README}
+}