summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-07-28 16:33:41 +0000
committerUlrich Müller <ulm@gentoo.org>2014-07-28 16:33:41 +0000
commitf7636f323eaf49dce95ec081d2fe18a5649dcfdb (patch)
tree4ea044c7ca0bf14f3d988d03a1fb105253431401 /app-emacs/bbdb
parentamd64 stable wrt bug #381424 (diff)
downloadgentoo-2-f7636f323eaf49dce95ec081d2fe18a5649dcfdb.tar.gz
gentoo-2-f7636f323eaf49dce95ec081d2fe18a5649dcfdb.tar.bz2
gentoo-2-f7636f323eaf49dce95ec081d2fe18a5649dcfdb.zip
Version bump, bug 511572.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs/bbdb')
-rw-r--r--app-emacs/bbdb/ChangeLog10
-rw-r--r--app-emacs/bbdb/bbdb-3.1.2.ebuild60
-rw-r--r--app-emacs/bbdb/files/50bbdb-gentoo-3.1.2.el2
-rw-r--r--app-emacs/bbdb/files/bbdb-3.1.2-no-init.patch126
-rw-r--r--app-emacs/bbdb/metadata.xml1
5 files changed, 197 insertions, 2 deletions
diff --git a/app-emacs/bbdb/ChangeLog b/app-emacs/bbdb/ChangeLog
index 582bf5a1df95..5a975566c87f 100644
--- a/app-emacs/bbdb/ChangeLog
+++ b/app-emacs/bbdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/bbdb
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/ChangeLog,v 1.42 2012/09/25 19:22:48 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/ChangeLog,v 1.43 2014/07/28 16:33:40 ulm Exp $
+
+*bbdb-3.1.2 (28 Jul 2014)
+
+ 28 Jul 2014; Ulrich Müller <ulm@gentoo.org> +bbdb-3.1.2.ebuild,
+ +files/bbdb-3.1.2-no-init.patch, +files/50bbdb-gentoo-3.1.2.el, metadata.xml:
+ Version bump, bug 511572.
25 Sep 2012; Ulrich Müller <ulm@gentoo.org> bbdb-2.35-r1.ebuild:
Specify LICENSE more precisely. Bump ebuild to EAPI 4.
diff --git a/app-emacs/bbdb/bbdb-3.1.2.ebuild b/app-emacs/bbdb/bbdb-3.1.2.ebuild
new file mode 100644
index 000000000000..6c377ac99f17
--- /dev/null
+++ b/app-emacs/bbdb/bbdb-3.1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/bbdb-3.1.2.ebuild,v 1.1 2014/07/28 16:33:40 ulm Exp $
+
+EAPI=5
+
+inherit elisp autotools
+
+DESCRIPTION="The Insidious Big Brother Database"
+HOMEPAGE="http://savannah.nongnu.org/projects/bbdb/"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ GPL-1+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="tex vm"
+
+DEPEND="tex? ( virtual/tex-base )
+ vm? ( app-emacs/vm )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo-${PV}.el"
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-init.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ "$(use_with vm vm-dir "${EPREFIX}${SITELISP}/vm")"
+}
+
+src_compile() {
+ emake -C lisp
+}
+
+src_install() {
+ emake -C lisp DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo doc/*.info*
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use tex; then
+ insinto "${TEXMF}"/tex/plain/${PN}
+ doins tex/*.tex
+ fi
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ use tex && texconfig rehash
+}
+
+pkg_postrm() {
+ elisp-site-regen
+ use tex && texconfig rehash
+}
diff --git a/app-emacs/bbdb/files/50bbdb-gentoo-3.1.2.el b/app-emacs/bbdb/files/50bbdb-gentoo-3.1.2.el
new file mode 100644
index 000000000000..45a7cc208e0d
--- /dev/null
+++ b/app-emacs/bbdb/files/50bbdb-gentoo-3.1.2.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'bbdb-loaddefs)
diff --git a/app-emacs/bbdb/files/bbdb-3.1.2-no-init.patch b/app-emacs/bbdb/files/bbdb-3.1.2-no-init.patch
new file mode 100644
index 000000000000..85dbc0374e32
--- /dev/null
+++ b/app-emacs/bbdb/files/bbdb-3.1.2-no-init.patch
@@ -0,0 +1,126 @@
+Patch from upstream, backported to bbdb-3.1.2.
+
+From e028f4d8f04c3db663db023cf5a630461cfda2bd Mon Sep 17 00:00:00 2001
+From: Roland Winkler <winkler@gnu.org>
+Date: Wed, 23 Jul 2014 03:27:09 +0000
+Subject: Do not load init file or site file for byte compilation
+
+--- bbdb-3.1.2-orig/lisp/Makefile.am
++++ bbdb-3.1.2/lisp/Makefile.am
+@@ -20,6 +20,9 @@
+ # You should have received a copy of the GNU General Public License
+ # along with BBDB. If not, see <http://www.gnu.org/licenses/>.
+
++# --batch implies --no-init-file, yet let's be explicit about what we want
++AM_ELCFLAGS += --no-init-file --no-site-file
++
+ dist_lisp_LISP = \
+ bbdb.el \
+ bbdb-anniv.el \
+@@ -70,10 +73,11 @@
+ @echo " " >> $@;
+ # Generated autoload-file must have an absolute path,
+ # $srcdir can be relative.
+- $(EMACS) -batch -l autoload \
++ $(EMACS) --batch $(AM_ELCFLAGS) $(ELCFLAGS) \
++ --load autoload \
+ --eval '(setq generated-autoload-file "'$(abs_builddir)/$@'")' \
+ --eval '(setq make-backup-files nil)' \
+- -f batch-update-autoloads $(srcdir)
++ --funcall batch-update-autoloads $(srcdir)
+
+ # Generate bbdb-site.el here as pkgdatadir is only known at "make" time.
+ # We protect the autoconf variables in the sed regular expressions
+--- bbdb-3.1.2-orig/lisp/makefile-temp
++++ bbdb-3.1.2/lisp/makefile-temp
+@@ -43,13 +43,16 @@
+ EMACSOPT =
+
+ # The actual Emacs command run in the targets below.
+-emacs = LC_ALL=C $(EMACS) --batch --directory=./ $(EMACSOPT)
++# --batch implies --no-init-file, yet let's be explicit about what we want
++emacs = LC_ALL=C $(EMACS) --batch --no-init-file --no-site-file \
++ --directory=./ $(EMACSOPT)
++emacs_compile = $(emacs) --funcall batch-byte-compile
+
+-# If you want to use BBDB with VM this should point to your vm/lisp directory.
+-# See also the target all below.
++# VM is not part of GNU Emacs. If you want to use BBDB with VM
++# then the variable VMDIR should point to your vm/lisp directory.
+ VMDIR =
+
+-VM = -eval '(unless (string-match "$(VMDIR)" "") (push "$(VMDIR)" load-path))'
++VM = -eval '(unless (string= "$(VMDIR)" "") (push "$(VMDIR)" load-path))'
+
+ .SUFFIXES: .elc .el .tar .Z .gz .uu
+
+@@ -89,51 +92,50 @@
+ @echo " " >> $@;
+ # Generated autoload-file must have an absolute path,
+ # $(srcdir) can be relative.
+- $(emacs) -l autoload \
++ $(emacs) --load autoload \
+ --eval '(setq generated-autoload-file "'`pwd`/$@'")' \
+ --eval '(setq make-backup-files nil)' \
+- -f batch-update-autoloads `pwd`
++ --funcall batch-update-autoloads `pwd`
+
+ .el.elc:
+- $(emacs) -f batch-byte-compile $<
++ $(emacs_compile) $<
+
+ # Not perfect, but better than nothing: If we do not have / do not use
+ # autotools, we simply copy bbdb-site.el.in to bbdb-site.el.
+ bbdb-site.el: bbdb-site.el.in
+ $(CP) $< $@
+ bbdb-site.elc: bbdb-site.el
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+
+ bbdb.elc: bbdb.el bbdb-site.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+
+ bbdb-com.elc: bbdb-com.el bbdb.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-mua.elc: bbdb-mua.el bbdb-com.elc
+- $(emacs) -eval '(unless (string= "$(VMDIR)" "") (push "$(VMDIR)" load-path) (load "vm" t t))' \
+- -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) -eval '(unless (string= "$(VMDIR)" "") (push "$(VMDIR)" load-path) (load "vm" t t))' \
++ $(@:.elc=.el)
+ bbdb-rmail.elc: bbdb-rmail.el bbdb-mua.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-gnus.elc: bbdb-gnus.el bbdb-mua.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-mhe.elc: bbdb-mhe.el bbdb-mua.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+-# VM is not part of GNU Emacs
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-vm.elc: bbdb-vm.el bbdb-mua.elc
+- $(emacs) $(VM) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(VM) $(@:.elc=.el)
+ bbdb-sc.elc: bbdb-sc.el bbdb-mua.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+
+ bbdb-print.elc: bbdb-print.el bbdb-com.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-migrate.elc: bbdb-migrate.el bbdb.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-anniv.elc: bbdb-anniv.el bbdb-com.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-ispell.elc: bbdb-ispell.el bbdb.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+ bbdb-snarf.elc: bbdb-snarf.el bbdb-com.elc
+- $(emacs) -f batch-byte-compile $(@:.elc=.el)
++ $(emacs_compile) $(@:.elc=.el)
+
+ install-el: all
+ $(INSTALL) -d -m 0755 "$(lispdir)/"
diff --git a/app-emacs/bbdb/metadata.xml b/app-emacs/bbdb/metadata.xml
index f677915e8de0..f7806e7da78b 100644
--- a/app-emacs/bbdb/metadata.xml
+++ b/app-emacs/bbdb/metadata.xml
@@ -9,5 +9,6 @@
</longdescription>
<use>
<flag name='tex'>Install plain TeX support files</flag>
+ <flag name='vm'>Add support for <pkg>app-emacs/vm</pkg></flag>
</use>
</pkgmetadata>