summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-09-12 15:24:15 +0000
committerUlrich Müller <ulm@gentoo.org>2007-09-12 15:24:15 +0000
commit24e51bd387bf6a073f053df2f9f77b5fddb87f1d (patch)
treef9af1013e754e87876cc39cfe680415ccef3b4a3 /app-emacs/cedet
parentscons blah (diff)
downloadgentoo-2-24e51bd387bf6a073f053df2f9f77b5fddb87f1d.tar.gz
gentoo-2-24e51bd387bf6a073f053df2f9f77b5fddb87f1d.tar.bz2
gentoo-2-24e51bd387bf6a073f053df2f9f77b5fddb87f1d.zip
Don't require ede while building semantic, fixes bug #191341.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-emacs/cedet')
-rw-r--r--app-emacs/cedet/ChangeLog8
-rw-r--r--app-emacs/cedet/cedet-1.0_pre4-r2.ebuild68
-rw-r--r--app-emacs/cedet/files/1.0_pre4-semantic-build.patch23
-rw-r--r--app-emacs/cedet/files/digest-cedet-1.0_pre4-r23
4 files changed, 101 insertions, 1 deletions
diff --git a/app-emacs/cedet/ChangeLog b/app-emacs/cedet/ChangeLog
index 664a6fd245df..c394c6580894 100644
--- a/app-emacs/cedet/ChangeLog
+++ b/app-emacs/cedet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/cedet
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.30 2007/09/02 20:11:16 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.31 2007/09/12 15:24:14 ulm Exp $
+
+*cedet-1.0_pre4-r2 (12 Sep 2007)
+
+ 12 Sep 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/1.0_pre4-semantic-build.patch, +cedet-1.0_pre4-r2.ebuild:
+ Don't require ede while building semantic, fixes bug #191341.
02 Sep 2007; Ulrich Mueller <ulm@gentoo.org> files/60cedet-gentoo.el:
Suppress startup message.
diff --git a/app-emacs/cedet/cedet-1.0_pre4-r2.ebuild b/app-emacs/cedet/cedet-1.0_pre4-r2.ebuild
new file mode 100644
index 000000000000..8dab686aaa6f
--- /dev/null
+++ b/app-emacs/cedet/cedet-1.0_pre4-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0_pre4-r2.ebuild,v 1.1 2007/09/12 15:24:14 ulm Exp $
+
+inherit elisp eutils versionator
+
+MY_PV=$(delete_version_separator 2)
+DESCRIPTION="CEDET: Collection of Emacs Development Tools"
+HOMEPAGE="http://cedet.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cedet/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="!app-emacs/semantic
+ !app-emacs/eieio
+ !app-emacs/speedbar"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+SITEFILE=60${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/1.0_pre3-eieio-tests-gentoo.patch" # bug 124598
+ epatch "${FILESDIR}/1.0_pre4-semantic-build.patch" # bugs 183205/191341
+}
+
+src_compile() {
+ emake EMACS=/usr/bin/emacs || die "emake failed"
+}
+
+src_install() {
+ find "${S}" -type f -print | while read target; do
+ local directory=$(dirname ${target}) file=$(basename ${target})
+ local sub_directory=$(echo ${directory} | sed "s%^${S}/*%%;s/^$/./")
+ case $file in
+ *~ | Makefile | *.texi | *-script | PRERELEASE_CHECKLIST \
+ | Project.ede | IMPLICIT_TARGETS)
+ ;;
+ ChangeLog | README | AUTHORS | *NEWS | INSTALL)
+ docinto ${sub_directory}
+ dodoc ${target}
+ ;;
+ *.png)
+ insinto /usr/share/doc/${PF}/${sub_directory}
+ doins ${target}
+ ;;
+ *.el | *.elc)
+ insinto ${SITELISP}/${PN}/${sub_directory}
+ doins ${target}
+ ;;
+ *.info*)
+ doinfo ${target}
+ ;;
+ *)
+ insinto ${SITELISP}/${PN}/${sub_directory}
+ doins ${target}
+ echo ${target} >>"${S}/IMPLICIT_TARGETS"
+ ;;
+ esac
+ done
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
diff --git a/app-emacs/cedet/files/1.0_pre4-semantic-build.patch b/app-emacs/cedet/files/1.0_pre4-semantic-build.patch
new file mode 100644
index 000000000000..45e9de569639
--- /dev/null
+++ b/app-emacs/cedet/files/1.0_pre4-semantic-build.patch
@@ -0,0 +1,23 @@
+--- cedet-1.0pre4/semantic/Makefile~ 2007-06-06 04:00:10.000000000 +0200
++++ cedet-1.0pre4/semantic/Makefile 2007-06-27 00:45:06.000000000 +0200
+@@ -114,7 +114,7 @@
+ "$(EMACS)" -batch --no-site-file -l $@-compile-script -f batch-byte-compile $^
+
+ .PHONY:wisent
+-wisent:
++wisent: bovinator
+ cd wisent; $(MAKE)
+
+ .PHONY:Tests
+--- cedet-1.0pre4/semantic/document.el~ 2007-06-06 04:00:09.000000000 +0200
++++ cedet-1.0pre4/semantic/document.el 2007-09-07 00:40:24.000000000 +0200
+@@ -41,9 +41,6 @@
+ (require 'document-vars)
+
+ ;; XEmacs change: needed to define macros at compile time.
+-(condition-case nil
+- (require 'ede)
+- (error nil))
+ (require 'semantic)
+ (require 'semantic-util)
+
diff --git a/app-emacs/cedet/files/digest-cedet-1.0_pre4-r2 b/app-emacs/cedet/files/digest-cedet-1.0_pre4-r2
new file mode 100644
index 000000000000..d8e4e259e8f6
--- /dev/null
+++ b/app-emacs/cedet/files/digest-cedet-1.0_pre4-r2
@@ -0,0 +1,3 @@
+MD5 fdc22624ae284166d9617acdc6ecbfda cedet-1.0pre4.tar.gz 1452946
+RMD160 db09e6b5ae6bf3f9a357b4baf85447bd1ce80437 cedet-1.0pre4.tar.gz 1452946
+SHA256 9bead2d8e7e5f1ddb07b18674216c7ec85418fa29d14355c247de58666dc2c64 cedet-1.0pre4.tar.gz 1452946