summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-02-01 22:06:04 +0000
committerUlrich Müller <ulm@gentoo.org>2010-02-01 22:06:04 +0000
commitdccfb9338e48b147b492f8606876b95d2912ba1a (patch)
tree02937e3c8f35b35170664bcfcc4b978d2898a2b8 /app-emacs/elib/elib-1.0-r1.ebuild
parentstable x86 (diff)
downloadgentoo-2-dccfb9338e48b147b492f8606876b95d2912ba1a.tar.gz
gentoo-2-dccfb9338e48b147b492f8606876b95d2912ba1a.tar.bz2
gentoo-2-dccfb9338e48b147b492f8606876b95d2912ba1a.zip
Add prefix keywords, change EAPI to 3.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-emacs/elib/elib-1.0-r1.ebuild')
-rw-r--r--app-emacs/elib/elib-1.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/elib/elib-1.0-r1.ebuild b/app-emacs/elib/elib-1.0-r1.ebuild
new file mode 100644
index 000000000000..1f7adca3594a
--- /dev/null
+++ b/app-emacs/elib/elib-1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/elib/elib-1.0-r1.ebuild,v 1.1 2010/02/01 22:06:03 ulm Exp $
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="The Emacs Lisp Library"
+HOMEPAGE="http://jdee.sourceforge.net"
+SRC_URI="http://jdee.sunsite.dk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i 's:--infodir:--info-dir:g' Makefile || die
+}
+
+# This is NOT redundant, elisp.eclass redefines src_compile
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir "${SITELISP}/elib"
+ dodir /usr/share/info
+ emake prefix="${ED}/usr" infodir="${ED}/usr/share/info" install \
+ || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog NEWS README TODO || die "dodoc failed"
+}