summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-09-13 15:21:38 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-09-13 15:21:38 +0000
commit9663d5f4c3dfff1dfd37be434351664df54428bd (patch)
treecc9fe2db258a33852708b764dd8fadbed8ce2a4b /app-emacs/emacs-jabber/emacs-jabber-0.8.0.ebuild
parentarm stable, bug #270243 (diff)
downloadgentoo-2-9663d5f4c3dfff1dfd37be434351664df54428bd.tar.gz
gentoo-2-9663d5f4c3dfff1dfd37be434351664df54428bd.tar.bz2
gentoo-2-9663d5f4c3dfff1dfd37be434351664df54428bd.zip
version bump for bug 284766 by Arseny Solokha <b0ntrict0r AT yandex DOT ru>: Dropped sasl USE flag as it is now mandatory
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-emacs/emacs-jabber/emacs-jabber-0.8.0.ebuild')
-rw-r--r--app-emacs/emacs-jabber/emacs-jabber-0.8.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/emacs-jabber/emacs-jabber-0.8.0.ebuild b/app-emacs/emacs-jabber/emacs-jabber-0.8.0.ebuild
new file mode 100644
index 000000000000..7cc44e52cd49
--- /dev/null
+++ b/app-emacs/emacs-jabber/emacs-jabber-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-jabber/emacs-jabber-0.8.0.ebuild,v 1.1 2009/09/13 15:21:38 fauli Exp $
+
+inherit elisp
+
+DESCRIPTION="A Jabber client for Emacs"
+HOMEPAGE="http://emacs-jabber.sourceforge.net/
+ http://emacswiki.org/cgi-bin/wiki/JabberEl"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# emacs-jabber depends on >= gnus-5.10 which is available in
+# app-emacs/gnus or bundled with app-editors/emacs-cvs. emacs 21.4a
+# includes gnus-5.9
+
+DEPEND=">=virtual/gnus-5.10
+ virtual/flim"
+RDEPEND="${DEPEND}"
+
+SITEFILE=70${PN}-gentoo.el
+
+src_compile() {
+ elisp-compile *.el || die
+ makeinfo jabber.texi || die
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo jabber.info
+ dohtml html/*
+ dodoc AUTHORS NEWS README || die
+}