summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-04-26 16:45:06 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-04-26 16:45:06 +0000
commit9097d03cc1934d1a81d052262e54d11f6b525acf (patch)
tree3346877dba393e8220fec47a8ccb665dcce60d06 /app-emacs/jde/jde-2.3.5.1.ebuild
parentStable on alpha wrt security Bug #130505. (diff)
downloadgentoo-2-9097d03cc1934d1a81d052262e54d11f6b525acf.tar.gz
gentoo-2-9097d03cc1934d1a81d052262e54d11f6b525acf.tar.bz2
gentoo-2-9097d03cc1934d1a81d052262e54d11f6b525acf.zip
New upstream version; Gentoo CEDET version check patch no longer required.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'app-emacs/jde/jde-2.3.5.1.ebuild')
-rw-r--r--app-emacs/jde/jde-2.3.5.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/jde/jde-2.3.5.1.ebuild b/app-emacs/jde/jde-2.3.5.1.ebuild
new file mode 100644
index 000000000000..1848a7288937
--- /dev/null
+++ b/app-emacs/jde/jde-2.3.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/jde-2.3.5.1.ebuild,v 1.1 2006/04/26 16:45:06 mkennedy Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="Java Development Environment for Emacs"
+HOMEPAGE="http://jdee.sunsite.dk/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND="virtual/emacs
+ >=virtual/jdk-1.3
+ app-emacs/elib
+ >=app-emacs/cedet-1.0_beta3"
+
+SITEFILE=70jde-gentoo.el
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ cd ${S}/lisp
+ cat >jde-compile-script-init <<EOF
+(load "${SITELISP}/cedet/common/cedet")
+(add-to-list 'load-path "$PWD")
+EOF
+ emacs -batch -l jde-compile-script-init -f batch-byte-compile *.el
+}
+
+src_install() {
+ dodir ${SITELISP}/${PN}
+ cp -r java ${D}/${SITELISP}/${PN}/
+ dodir /usr/share/doc/${P}
+ cp -r doc/* ${D}/usr/share/doc/${P}/
+ cd ${S}/lisp
+ elisp-install ${PN}/lisp *.el *.elc *.bnf
+ cp ${FILESDIR}/${PV}-${SITEFILE} ${S}/${SITEFILE}; elisp-site-file-install ${S}/${SITEFILE}
+ dodoc ChangeLog ReleaseNotes.txt
+ find ${D} -type f -print0 |xargs -0 chmod 644
+ exeinto /usr/bin
+ doexe jtags*
+}