summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-08-27 21:08:08 +0000
committerUlrich Müller <ulm@gentoo.org>2007-08-27 21:08:08 +0000
commit113ef88f6979351338de33ee9bc668d5c2ea687a (patch)
tree7790a75dd1ea66edcbc07e25e1e4dc84444eb1b4 /app-emacs/slime/slime-2.0_p20061118.ebuild
parentapp-emacs/slime, CVS snapshot masked for testing. (diff)
downloadgentoo-2-113ef88f6979351338de33ee9bc668d5c2ea687a.tar.gz
gentoo-2-113ef88f6979351338de33ee9bc668d5c2ea687a.tar.bz2
gentoo-2-113ef88f6979351338de33ee9bc668d5c2ea687a.zip
Version bump: new CVS snapshot, everything contributed by Stelian Ionescu.
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-emacs/slime/slime-2.0_p20061118.ebuild')
-rw-r--r--app-emacs/slime/slime-2.0_p20061118.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/slime/slime-2.0_p20061118.ebuild b/app-emacs/slime/slime-2.0_p20061118.ebuild
new file mode 100644
index 000000000000..d10fe7b5f217
--- /dev/null
+++ b/app-emacs/slime/slime-2.0_p20061118.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/slime-2.0_p20061118.ebuild,v 1.1 2007/08/27 21:08:08 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="SLIME, the Superior Lisp Interaction Mode (Extended)"
+HOMEPAGE="http://common-lisp.net/project/slime/"
+# use ${FILESDIR}/new-slime-ball to create new snapshots
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2 as-is"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="doc"
+
+DEPEND="virtual/commonlisp
+ doc? ( sys-apps/texinfo )"
+
+CLPACKAGE=swank
+
+src_compile() {
+ elisp-comp *.el || die
+ use doc && make -C doc slime.info
+}
+
+src_install() {
+ elisp-install ${PN} *
+ elisp-site-file-install "${FILESDIR}/70slime-gentoo.el"
+ dodoc README* ChangeLog HACKING NEWS PROBLEMS
+ dodir /usr/share/common-lisp/systems
+ dosym /usr/share/emacs/site-lisp/${PN}/swank.asd \
+ /usr/share/common-lisp/systems/
+ if use doc; then
+ doinfo doc/slime.info
+ fi
+}