summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-04-18 06:26:34 +0000
committerUlrich Müller <ulm@gentoo.org>2008-04-18 06:26:34 +0000
commit0c73cb19ff9227d66e3f29b57bbbc9216f0e0225 (patch)
tree9433f79c3634faa3d7c4a995102274c596c6d01e /app-emacs
parentVersion bump. LICENSE changed to GPL-3. (diff)
downloadgentoo-2-0c73cb19ff9227d66e3f29b57bbbc9216f0e0225.tar.gz
gentoo-2-0c73cb19ff9227d66e3f29b57bbbc9216f0e0225.tar.bz2
gentoo-2-0c73cb19ff9227d66e3f29b57bbbc9216f0e0225.zip
Version bump. LICENSE changed to GPL-3.
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ngnus/ChangeLog9
-rw-r--r--app-emacs/ngnus/ngnus-0.8.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-emacs/ngnus/ChangeLog b/app-emacs/ngnus/ChangeLog
index c23e2eb9602b..2b36262d3ae2 100644
--- a/app-emacs/ngnus/ChangeLog
+++ b/app-emacs/ngnus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/ngnus
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ngnus/ChangeLog,v 1.3 2007/12/01 16:09:49 ulm Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ngnus/ChangeLog,v 1.4 2008/04/18 06:26:34 ulm Exp $
+
+*ngnus-0.8 (18 Apr 2008)
+
+ 18 Apr 2008; Ulrich Mueller <ulm@gentoo.org> +ngnus-0.8.ebuild:
+ Version bump. LICENSE changed to GPL-3.
01 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ngnus-0.6.ebuild,
ngnus-9999.ebuild:
diff --git a/app-emacs/ngnus/ngnus-0.8.ebuild b/app-emacs/ngnus/ngnus-0.8.ebuild
new file mode 100644
index 000000000000..204ccc1964a6
--- /dev/null
+++ b/app-emacs/ngnus/ngnus-0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ngnus/ngnus-0.8.ebuild,v 1.1 2008/04/18 06:26:34 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Current alpha branch of the Gnus news- and mail-reader"
+HOMEPAGE="http://gnus.org/"
+SRC_URI="http://quimby.gnus.org/gnus/dist/${P}.tar.gz
+ http://theotp1.physik.uni-ulm.de/~ste/comp/emacs/gnus/release/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-emacs/gnus
+ !app-emacs/gnus-cvs"
+
+SITEFILE=70${PN}-gentoo.el
+
+src_compile() {
+ econf \
+ --with-emacs --without-w3 --without-url \
+ --with-lispdir=${SITELISP}/${PN} \
+ --with-etcdir=${SITEETC} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall \
+ lispdir="${D}${SITELISP}/${PN}" \
+ etcdir="${D}${SITEETC}" \
+ || die "einstall failed"
+
+ # fix info documentation
+ for i in "${D}"/usr/share/info/*; do
+ mv "${i}" "${i}".info || die "mv info failed"
+ done
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+
+ dodoc ChangeLog GNUS-NEWS README todo || die "dodoc failed"
+}