summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-08-11 08:36:32 +0000
committerUlrich Müller <ulm@gentoo.org>2010-08-11 08:36:32 +0000
commit66885d634a9f9ebb2e903d12a93c9491ef33ef2d (patch)
tree309ba12962d8def352b8725c4fcd48e8615a3eac /app-emacs
parentfix bug 331855, respecting LDFLAGS (diff)
downloadgentoo-2-66885d634a9f9ebb2e903d12a93c9491ef33ef2d.tar.gz
gentoo-2-66885d634a9f9ebb2e903d12a93c9491ef33ef2d.tar.bz2
gentoo-2-66885d634a9f9ebb2e903d12a93c9491ef33ef2d.zip
Install site-init file with autoloads. Add ~amd64 keyword. Remove old.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/google-c-style/ChangeLog9
-rw-r--r--app-emacs/google-c-style/files/50google-c-style-gentoo.el5
-rw-r--r--app-emacs/google-c-style/google-c-style-20091009-r1.ebuild (renamed from app-emacs/google-c-style/google-c-style-20091009.ebuild)20
3 files changed, 23 insertions, 11 deletions
diff --git a/app-emacs/google-c-style/ChangeLog b/app-emacs/google-c-style/ChangeLog
index 333f301bdd9e..0ceedee8543d 100644
--- a/app-emacs/google-c-style/ChangeLog
+++ b/app-emacs/google-c-style/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/google-c-style
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/google-c-style/ChangeLog,v 1.1 2010/08/11 03:31:35 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/google-c-style/ChangeLog,v 1.2 2010/08/11 08:36:31 ulm Exp $
+
+*google-c-style-20091009-r1 (11 Aug 2010)
+
+ 11 Aug 2010; Ulrich Mueller <ulm@gentoo.org>
+ +files/50google-c-style-gentoo.el, -google-c-style-20091009.ebuild,
+ +google-c-style-20091009-r1.ebuild:
+ Install site-init file with autoloads. Add ~amd64 keyword. Remove old.
*google-c-style-20091009 (11 Aug 2010)
diff --git a/app-emacs/google-c-style/files/50google-c-style-gentoo.el b/app-emacs/google-c-style/files/50google-c-style-gentoo.el
new file mode 100644
index 000000000000..3e9768b65db7
--- /dev/null
+++ b/app-emacs/google-c-style/files/50google-c-style-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'google-set-c-style "google-c-style"
+ "Set the current buffer's c-style to Google C/C++ Programming Style." t)
+(autoload 'google-make-newline-indent "google-c-style"
+ "Sets up preferred newline behavior." t)
diff --git a/app-emacs/google-c-style/google-c-style-20091009.ebuild b/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild
index 6cecb6904336..5d99987fb527 100644
--- a/app-emacs/google-c-style/google-c-style-20091009.ebuild
+++ b/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/google-c-style/google-c-style-20091009.ebuild,v 1.1 2010/08/11 03:31:35 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild,v 1.1 2010/08/11 08:36:31 ulm Exp $
inherit elisp
-IUSE=""
-
-DESCRIPTION="Provides the google C/C++ coding style."
+DESCRIPTION="Provides the google C/C++ coding style"
HOMEPAGE="http://code.google.com/p/google-styleguide/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
-DEPEND=""
-RDEPEND=""
+SITEFILE="50${PN}-gentoo.el"
pkg_postinst() {
+ elisp-site-regen
+
einfo "Example usage (.emacs):"
- einfo "(require 'google-c-style)"
- einfo "(add-hook 'c-mode-common-hook 'google-set-c-style)"
- einfo "(add-hook 'c-mode-common-hook 'google-make-newline-indent)"
+ einfo " (add-hook 'c-mode-common-hook 'google-set-c-style)"
+ einfo " (add-hook 'c-mode-common-hook 'google-make-newline-indent)"
}