summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-10-16 21:40:58 +0000
committerUlrich Müller <ulm@gentoo.org>2009-10-16 21:40:58 +0000
commit727de3490fa08591d31076c3019a41a0b066d3b6 (patch)
tree2074915b23f11d46401d317c88d7f25847fc9f42 /app-emacs
parentx86 stable, bug #281427 (diff)
downloadgentoo-2-727de3490fa08591d31076c3019a41a0b066d3b6.tar.gz
gentoo-2-727de3490fa08591d31076c3019a41a0b066d3b6.tar.bz2
gentoo-2-727de3490fa08591d31076c3019a41a0b066d3b6.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/mpg123-el/ChangeLog7
-rw-r--r--app-emacs/mpg123-el/files/50mpg123-el-gentoo.el3
-rw-r--r--app-emacs/mpg123-el/mpg123-el-1.52.ebuild34
3 files changed, 40 insertions, 4 deletions
diff --git a/app-emacs/mpg123-el/ChangeLog b/app-emacs/mpg123-el/ChangeLog
index 2097e90dbb52..da1756518b6e 100644
--- a/app-emacs/mpg123-el/ChangeLog
+++ b/app-emacs/mpg123-el/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/mpg123-el
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/ChangeLog,v 1.20 2009/06/03 17:08:58 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/ChangeLog,v 1.21 2009/10/16 21:40:58 ulm Exp $
+
+*mpg123-el-1.52 (16 Oct 2009)
+
+ 16 Oct 2009; Ulrich Mueller <ulm@gentoo.org> +mpg123-el-1.52.ebuild:
+ Version bump.
03 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
-mpg123-el-1.50.ebuild:
diff --git a/app-emacs/mpg123-el/files/50mpg123-el-gentoo.el b/app-emacs/mpg123-el/files/50mpg123-el-gentoo.el
index 9a60a5799548..b65e6b16969d 100644
--- a/app-emacs/mpg123-el/files/50mpg123-el-gentoo.el
+++ b/app-emacs/mpg123-el/files/50mpg123-el-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; mpg123-el site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'mpg123 "mpg123" "A Front-end to mpg123" t)
(setq id3*put-prog "tagput")
diff --git a/app-emacs/mpg123-el/mpg123-el-1.52.ebuild b/app-emacs/mpg123-el/mpg123-el-1.52.ebuild
new file mode 100644
index 000000000000..af70ad5338eb
--- /dev/null
+++ b/app-emacs/mpg123-el/mpg123-el-1.52.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mpg123-el/mpg123-el-1.52.ebuild,v 1.1 2009/10/16 21:40:58 ulm Exp $
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
+HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="vorbis"
+
+DEPEND=""
+RDEPEND="media-sound/mpg123
+ media-sound/aumix
+ vorbis? ( media-sound/vorbis-tools )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ sed -i -e "s/\(mainloop:\)/\1 ;/" tagput.c || die
+ $(tc-getCC) ${CFLAGS} -o tagput tagput.c || die
+ $(tc-getCC) ${CFLAGS} -o id3put id3put.c || die
+ elisp-compile *.el || die
+}
+
+src_install() {
+ dobin tagput id3put || die
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}